Kodi Community Forum

Full Version: XBMC Video Server: stream/download your library contents
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
@negge

Thanks for the quick response! I did some digging and reading re: SymLinks and .htaccess files.

I was able to get everything working by copying the 000-default.conf file from /etc/apache2/sites-available to /etc/apache2/sites-enabled. Once I discovered that worked, I removed the copied 000-default.conf file and created a symbolic link to the original conf using the below.

cd /etc/apache2/sites-enabled
ln -s /etc/apach2/sites-available/000-default.conf

Did I miss that step somewhere in the documentation? Was it supposed to create the link automatically?
@lowmoon: the "default" site should have been enabled by default, otherwise you wouldn't have seen even a directory listing. What distribution are you using?
@negge:
Ubuntu 13.10 Saucy, kernel 3.11.0-18-generic
Apache 2.4.6
PHP 5.5.3-1ubuntu2.2
That's strange, the symlink should be there by default. We'll just have to wait and see if someone else experiences the same issue. You did get it working in the end right?
(2013-07-13, 12:48)negge Wrote: [ -> ]
(2013-07-12, 15:20)discinabq Wrote: [ -> ]Ok, thank you - that got me up and running. Now when i click watch to stream a video - the first 5 seconds play in VLC then the stream shuts off. This seems to happen on .avi's and .mkv's

A few thoughts:

1: embedded html5 player option? for mp4
2: eventual xbmc plugin (would really be nice).

That's odd, I haven't experienced that issue at all. Can you download a file without problems (use the download links instead of the watch button)?

Regarding your points, I was thinking about an in-browser player too but I think it would be useless on most media files since most people use MKV and browser support for h.264 isn't that good last time I checked.

Regarding point #2, what XBMC really needs is a way to connect to a remote library, but that is no simple task to accomplish.

Any fix for this? Mostly I'm able to watch the first 6-7 seconds of any series or movie before it cuts off.. This does NOT happen locally with cable, but it does happen locally with wireless, and via web.. Seems to happen both in MPC and in VLC. Is this a problem with my router/network maybe? Or is it some configuration problem?

The problem seems to at least partially be there when downloading as well, because most downloads gets cut off before they finish, tho they do download longer then 6-7 seconds..

Other then that, thanks for doing this! Its really cool - I just wish it worked for me..
Could you guys post a debug log from XBMC when you try to stream something? Maybe it could shed some light on the issue.
I can look into it tomorrow, I'm not at home so I have to do this via remote desktop, but I really want to make this work for future trips out of town, so I will do what I can do help you solve this =)
Heres the xbmc.log, slightly edited

http://www35.zippyshare.com/v/33583416/file.html

A couple of things I think might affect the outcome is the fact that I have Frodo 12.3 (gonna test gotham later, but it doesnt support the skin I use).
The skin I use? Gonna try with standard skin and see if that affects it. I also had to put apache (or one of the apps I installed on D:\, even tho it warned me it should be installed on C:\). Also I'm on windows 8 on my server/HTPC. Tried streaming to windows7 and windows 8.1.
I started a new log and then attempted to download/stream something: http://www77.zippyshare.com/v/25515901/file.html
@Darre: I can't find anything interesting in the logs, it could be that XBMC is not logging the right stuff. I highly recommend upgrading to Gotham since it could very well solve your issue (there were some changes made to the web server code pretty early in the development cycle), though I can understand your reluctance if it breaks your favorite skin. Hopefully the skins will soon be updated to be compatible again.

@snatch22: you don't have debugging enabled, but judging from your log XBMC is not able to extract the RAR archive files. It could have been unrelated too, it's hard to tell without debug logging. Have you tried downloading other files?
It can extract RAR archive files as far as I know, but I've tried with files I know are mp4 as well. The errors you're seeing are subpack files without video in them, only subtitle files, I think... either way I've enabled debugging and repeated the process. Sorry!

http://www10.zippyshare.com/v/1571406/file.html

This time I've tried downloading and streaming both types of files, the last two (community s05e10 (packed in a RAR file) and breaking bad s01e01 (straight mp4)) I did from the SAME machine that the server is running on, and they completed successfully. I don't know if this can tell you anything useful..

Thanks again for your help.
Thanks for providing a new log. The only strange thing I see is that there are sometimes five consequtive requests for the same file. You really need to test Gotham to see if the issue is reproducible.
(2014-03-23, 10:18)negge Wrote: [ -> ]Thanks for providing a new log. The only strange thing I see is that there are sometimes five consequtive requests for the same file. You really need to test Gotham to see if the issue is reproducible.

I'm on Gotham beta 2, it was the other poster that wasn't Sad
@snatch22: Sorry about that, I got confused. What happens when you download a file that "doesn't work"? Does it not start the download or does the download stop halfway through or something?

I suggest you create a bug report on trac.xbmc.org since this is definitely a bug in XBMC (or at least not in this application).

In other news, I finally started working on implementing transcoding, and I can say that it's looking good so far. At the moment I've only tested with WebM video, but the system is based on presets so any combination of audio/video codecs should work. The main issue at the moment is getting the transcoding process to stop once the user quits watching something, I thought I had it working but right now it has to be manually killed. It will take a lot of work before the whole thing can be merged into the master branch (I haven't even pushed the changes to Github yet), but like I said it's looking promising.
The download or stream will always begin, and then abruptly stop downloading (with a broken file resulting) or just no more visible stream. Occasionally the entire thing will complete, but very very rarely. What I don't understand is if it was a bug in xbmc -- why would downloading or streaming on the same machine the server is running on work perfectly every time? Isn't it more likely it has something to do with serving the file over the internet?

To clarify, streaming over the internet or even lan over wifi essentially does not work, same machine always works.

Anyway I'll have to format my computer sometime soonish and I'll reinstall at that point.. here's hoping this problem goes away Sad

Transcoding will really be awesome though, great to hear it is coming along well. I'd love to replace my Madsonic server altogether.