Kodi Community Forum

Full Version: XBMC Video Server: stream/download your library contents
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
will try that later
Hey Negge,
Any reason why the Reverse proxy would be terminating downloads?

I'm running vanilla Ubuntu Server now rather than on an xampp stack.

Reverse proxy works, however the downloads/streams terminate early.
Some other guy had the same problem, I have to say I don't know why. I've never experienced that myself, though I have a feeling it's a bug in XBMC on some platforms or something. Can you describe your setup a bit?
Sure,
Main Machine - XBMC Gotham running on Windows 8.1 with Hyper-V

Ubuntu Server 14.04 VM running on the Windows box with SickBeard, CouchPotato and XBMC-Video-Server.
xbmc-video-server is running on port 80, all other web apps are running on 808x so there is nothing on the same port.

ApachevHost file:

<VirtualHost *:80>

ServerName stream.xxxxxx.com

ServerAdmin [email protected]localhost
DocumentRoot /var/www/html/xbmc-video-server


ErrorLog ${APACHE_LOG_DIR}/stream.error.log
CustomLog ${APACHE_LOG_DIR}/stream.access.log combined


<Directory /var/www/html/xbmc-video-server/>
Options FollowSymLinks
AllowOverride All
Require all granted
</Directory>

AllowEncodedSlashes On

<Location /xbmc-vfs>
ProxyPass http://172.30.1.3:8000/vfs
ProxyPassReverse http://172.30.1.3:8000/vfs
RequestHeader set Authorization "Basic eGJtYzp4Ym1j"
</Location>

</VirtualHost>


Browsing to 172.30.1.3:8000/vfs displays a blank page ( as it should).
So I know the reverse proxy is working. However it seems to be stopping the download about 5-6 seconds into it.
Can you pastebin the Apache access and error logs plus an XBMC debug log when the disconnect happens?
(2014-08-26, 09:37)negge Wrote: [ -> ]Can you pastebin the Apache access and error logs plus an XBMC debug log when the disconnect happens?

Here's the Access log
http://pastebin.com/sZnGzj1F

Here's the XBMC log
http://pastebin.com/456w7zK2

There's nothing in the error log.

Thanks for you help!
Can you provide a debug log (wiki), the one you posted is a normal one.
(2014-08-26, 16:16)negge Wrote: [ -> ]Can you provide a debug log (wiki), the one you posted is a normal one.

Oops.
Here you go!

http://pastebin.com/456w7zK2

and updated apache.access.log
http://pastebin.com/sZnGzj1F
Can you successfully download the file if you disable the proxy?
(2014-08-27, 12:24)negge Wrote: [ -> ]Can you successfully download the file if you disable the proxy?

Yeah,
If the proxy is off its totally fine.
Which is what led me to believe that it was the proxy causing this issue in the first place.

When I was running this on a xampp stack in Windows I managed to get it working by adding the proxy details to the ghost file and not the httpd-proxy.conf file. But obviously Ubuntu is completely different.

So I'm at a bit of a loss here.

If its any more helpful, I can give you login and ssh access to my setup so you can play is you like?
CHANGELOG.md Wrote:#### 1.6.6
* fix adding and using backends using an IPv6 address
* fixed a bug where normal users couldn't wake a sleeping backend using WOL
* add typeahead functionality for the actor filter field
* add ability to filter TV shows by actor too
* display movie director on the details page
* add ability to filter movies by director
CHANGELOG.md Wrote:#### 1.6.7
* show watch/download options in a modal dialog instead
* added ability to select the playlist format used for playlists (the application default is selected by default)
* added ability to start playing an item in XBMC instead of streaming/downloading it
Hello friends ..
this xbmc video server I am not able to watch the movie using browser
click to watch it downloads in m3u,
How do I watch in chrome without downloading?
You can't watch the movie in your browser, you'll have to open the playlist file in VLC or some other media player.

As a note to everyone, there's a pretty serious performance regression in the last two versions that affects the Movies -> Browse page. I'm looking into the best way of solving it.
One really small "bug": in https://github.com/Jalle19/xbmc-video-se...es-min.css (and login-min.css too) - line 1

Code:
@import url("http://fonts.googleapis.com/css?family=Lato:400,700,900,400italic");/*!

Could you drop that http protocol and change that line to:

Code:
@import url("//fonts.googleapis.com/css?family=Lato:400,700,900,400italic");/*!

This will only clean up some "browser bitching". If XBMC Video Server is accessed via "https", browsers it should load those fonts via https too. That small change should't affect anything else.