Kodi Community Forum

Full Version: XBMC Video Server: stream/download your library contents
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pretty strange to get that many requests if that IP really doesn't belong to you. From the log I can see that there was one successful request at creating a thumbnail images, that is one of the few actions that don't require any authentication (since e.g. VLC can request images when using XSPF playlists), but other than that there's nothing harmful going on.
Hi negge, can you help me, i have a problem with your xbmc-video-server. I am upgrading from your version 1.6.14 to the latest with the commands you write in the upgrading from windows:

cd htdocs\xbmc-video-server
git pull
composer install
.\src\protected\yiic migrate --interactive=0

But when finish the instructions and log me in my page show me these:


Notice: Undefined index: disableFrodoWarning in C:\xampp\htdocs\xbmc-video-server\src\protected\models\Setting.php on line 118
CException

Property "Setting.disableFrodoWarning" is not defined.

I'm reboot the the machine and continue show me these error. And i upgrading Kodi before your xbmc-video-server to the lastest 15.1 Isengard. What you recommend to repair the problem, it is possible change another setting to resolve the problem?

And another question, i'going to add the spanish language in your xbmc-video-server with you explain me to go but in the 3 pass:

In a terminal, run the command src/protected/yiic message src/protected/config/message.php. This will create a new set of files in the src/protected/messages/<language> directory.

But the command don't execute, when in the tutorial says run terminal you says the terminal of SourceTree or terminal of windows or another terminal. Can you revise the command if have any error to execute these?
That's strange, did you get any errors while running ".\src\protected\yiic migrate --interactive=0"?
Can you also pastebin your protected/runtime/application.log file?
Here you are, in this link

http://pastebin.com/LVHQ5ifa

Locate the part who start today at:

2015/09/27 08:32:30

This is the full log

When i running the upgrade i don't look if i have an error but i don't look any error but i don't think so
Found the problem, I'll push a fix later tonight when I get home. Sorry for the inconvenience.

Regarding translations, you need to run those commands in a command prompt from the project directory.
Thanks Negge, if you repair the problem, i need only upgrade another to a new revision if you reapir or you write me who is the line to change the problem?

And for translations, i understand you say me in cmd in windows in my project directory, but i write the same sentence but don't work, when i view the yiic bat command and view need the php.exe of xampp directory, if is possible to add xampp directory in the path of windows who locate the file php.exe to execute the command?
(2015-09-27, 17:32)peu7510 Wrote: [ -> ]Thanks Negge, if you repair the problem, i need only upgrade another to a new revision if you reapir or you write me who is the line to change the problem?

I just pushed a fix, try updating again now.

peu7510 Wrote:And for translations, i understand you say me in cmd in windows in my project directory, but i write the same sentence but don't work, when i view the yiic bat command and view need the php.exe of xampp directory, if is possible to add xampp directory in the path of windows who locate the file php.exe to execute the command?

Okay, it seems on Windows PHP isn't available in the path, you have to add it manually in that case or use the absolute path to php.exe when executing those commands. I don't remember off the top of my head where XAMPP stores php.exe so you'll have to do a bit of digging.
Thank you negge, the page works perfect, a lot of thanks with your support, you are amazing.

The other part (the php), i view later because i view a movie in this moment!!!!!!!!!!
Negge, i have another problem, when i log in in the index page don't works if says maximum execution time exceded in VideoLibrary, i go to settings and in request timeout i push 180 seconds but don't charge the first page includes mark Cache all api results but don't work. And i up memory limit of php.ini (2048M) and reboot the apache server but don't charge the first page when i log in with my user.

I'm sorry for help many times but can you help me please?
I pushed another fix, now the execution time limit (which by default is set to 30 seconds) is changed to the value of the "Request timeout" setting. Change it to 60 or 120 and your library should load. After it has loaded once the "Cache all API calls" setting will actually do something, the next time you go to the index page it will load almost instantly.

I've been looking into improving the loading time since it's obviously taking too long for some users. I have some potential solutions lined up but none are really trivial so I haven't had time to really dig into it yet.
Good Morning Negge, one question, the last comment you write the improving time to load the pages, i view since from the upgrade of you xbmc video server, the pages when i load any thing the page is frozen to finish the load of page to click another other link. the potential solution is possible resolve in a few days or you search these solution from many months ago?
I have finished work on one thing that alone will dramatically speed up loading the index page but I haven't pushed it yet cause I have another improvement pending which should reduce it even further.

Stay tuned, I'll have something by the end of the week.
@peu7510 mind testing the latest changes? It should dramatically speed up the movie index page since auto-complete data for the various filter form fields are now fetched asynchronously in the background (especially the actor names took forever to retrieve). I also finally got around to implement an enhancement to the movie name auto-complete field.

Image

I haven't tagged a new release yet, I want to get some additional changes in before I do that. Stay tuned!
CHANGELOG.md Wrote:#### 1.8.0
* don't log logout attempts by guest users
* fixed another two migration issue
* use the value of the "request timeout" setting as the maximum execution time too
* add fancier movie suggestions in the auto-complete dropdown
* major performance fixes, especially on the movie browse page
* moved database connection configuration to a separate file, should be helpful for MySQL users who previously had to configure their credentials in two places
* improve the library update user experience when the backend is connectable using WebSocket