Kodi Community Forum

Full Version: Frodo Crashes on Ubuntu when playing any video
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I have a PC which was running Vista and XBMC Frodo with no issues.

I have installed 64bit Ubuntu as duel boot and made no other changes to the machine what so ever.

First I installed Eden and now Frodo and get the same issue with both version.

I select a video, so far I have tried both local files and You Tube.

The 'Working' icon spins for a few second, then as the figures showing the video length and current position (still at zero) appear the 'Working' icon freezes for another second and then XBMC closes will no error messages.

It works fine when I boot into Vista so I guess all the hardware works with XBMC.

Ubuntu can play You Tube via my web browser and can play my video files via VLC or it's own movie player, so I guess the hardware works fine with Ubuntu's drivers.

I have tried changing the 'Render Method' between Auto, Software, Advanced and Simple.

I found something on line about deleting a .asoundrc which I don't seem to have, but that was from version 10.10 so I guess it no longer exists.

I'm new to box XBMC and Ubuntu so please bare this in mind when giving any help and don't assume I know anything Blush

I've noticed in other threads people asking for crash logs, so here is what I have found, I hope these help.

For this log I took the following steps:

Alt+F2
Click XBMC from History
Click Video -> Add-ons -> YouTube -> Explore YouTube -> YouTube Categories ->Film & Animation
Click on American Hustle Trailer
'Working' icon spins
Current position (zero) and video length appear in bottom left.
XBMC vanishes and leaves me looking back at this page which was open in the back ground

MOD EDIT: REMOVED CRASHLOG

Many thanks in anticipation

Rick
welcome. please read the forum rules.
do not post logs directly on the forum please
Ah, my apologies, I'll read up on where/how to post them.

Thanks for the message.
Ok, I've repeated the exact same steps as above with the addition of following the instructions for uploading logs.

So I had debug turned on, reproduced the error, then ran XBMC again after crashing to select the log uploader.

So without further ado, here are the logs

Your debug xbmc.log: http://xbmclogs.com/show.php?id=41419
Your debug xbmc.old.log: http://xbmclogs.com/show.php?id=41420
Your XBMC crashlog: http://xbmclogs.com/show.php?id=41421
it crashes in the intel driver, after it failed to initialize vaapi. What hardware is this exactly, intel haswell maybe?
For those to work you'll need a much newer kernel and gpu driver stack then ubuntu 12.04 offers by default.
All that is way over my head, I'm new to both Ubuntu and XBMC.

Could you give instructions to how to obtain a new kernel and driver stack? Or point me in the direction of where I can read up about it?

Also, everything runs fine in VLC and the Movie Player which is bundled with Ubuntu and on line videos play fine through Chrome, so would what your explaining effect XBMC only?

As said, being new to Ubuntu I'm still finding my way around, but clicking system setting -> system -> details -> graphics the following is all I can retrieve about the driver for now

Driver IntelĀ® 915G
Experience Standard

Thanks very much for taking the time to reply. Very much appreciated.
Ok, I have done some more googling following what you have said as I don't just want to sit back and make you guys do all the hard work.

I have disabled vaapi in the setting menu and it still crashes.

Here are the logs following the steps as above, this time with vaapi disabled.

Your debug xbmc.log: http://xbmclogs.com/show.php?id=41436
Your debug xbmc.old.log: http://xbmclogs.com/show.php?id=41437
Your XBMC crashlog: http://xbmclogs.com/show.php?id=41438
Hello,

To the best of my knowledge there are no major problems with Ubuntu 12.04.2 LTS Desktop and XBMC 11 version from official repository, with a relatively recent GPU from Intel, AMD or Nvidia, while also installing XBMC standalone & creating a user account dedicated to XBMC. (with decent CPU, GPU & amount of RAM)

There may be trouble with one or more ODDs which are not recognized by XBMC & which unfortunatly only supports a single one & not all models.

But if Ubuntu is correctly configurated and updated and you can correctly read your videos with Ubuntu default video player, you should not have trouble with XBMC.

I also suggest not install device drivers other than those possibly proposed by the system and install a 32-bit version of Ubuntu if the machine is not very powerful.

If despite everything this was the case you can perhaps try to carefully change display options of XBMC.

Regards,
Palmer.
Sadly you didn't answer my question about which hardware you have there...

In general, here is a copy/paste howto to upgrade kernel and intel driver stack http://forum.xbmc.org/showthread.php?tid...pi+testing
Palmer Eldritch -
Thanks very much for taking the time to reply.
What do you call relatively recent? The machine is admittedly a few years old now, and was probably a cheap spec to begin with.
But as mentioned, everything else will play video so I can only assume that drivers, hardware and OS are all compatible.

I've not installed any device drivers other than those packaged with Ubuntu, or updated by Ubuntu, I've made no steps to manually install any drivers.

I was thinking of abandoning this install at one point and going for a 32bit version of Ubuntu, but then decided that the learning curve of getting this one working might be an interesting and valuable experience. Which is about the point I posted up on here.

wsnipex -
Sorry about that, I hoped the driver would be enough information. I'll google how to find out what hardware is in there. The machine was gifted to me by a business who where throwing it out during an upgrade. It's then been little more than a door stop for a few years. Having recently discovered XBMC on my phone, then my Windows 7 lap top, I thought I would dust off this machine, firstly installed XBMC on it's existing install of Vista and now on Ubuntu. So what I'm trying to say is, I don't know very much about the machine it's self.

Thanks very much for the link. I'll definitely try all that.

The one thing that's perplexing me is that everything else will play video just not XBMC.

I also installed FilmON TV last night and that crashes too in the same way.
wsnipex -
I have following that link and completed all the instructions but there is still not different.

I have done some googling to find out what how to find out what graphics card I have, and after coming across some information about lspci here is what I have come up with. I hope this means more to you than it does to me.

00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)

00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04) (prog-if 00 [VGA controller])
Subsystem: Intel Corporation Device 4147
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at ff480000 (32-bit, non-prefetchable) [size=512K]
I/O ports at ec00 [size=8]
Memory at d0000000 (32-bit, prefetchable) [size=256M]
Memory at ff440000 (32-bit, non-prefetchable) [size=256K]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: intelfb, i915

I really hope someone can help soon. I'm sure it's the most simple of answers once we get to the bottom of it.
Hi Guys,

I kinda got this this working.

I did a lot of googling about the above graphics cards and couldn't find anything to suggest that it's supported by Ubuntu 64bit even though it was working with the other video player.

So in the end I have reinstalled Ubuntu but this time the 32bit.

Installed XBMC, added my videos and now they are working.

I'm going to put this one down to a Ubuntu 64bit\XMBC\Graphics Card combo.

Thanks again for the helpful posts.

Rick