Kodi Community Forum

Full Version: Edit Movie / Details will not save when OK is clicked
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I was so glad to find the latest version of EMM - been using 1.2 forever and loved it.

I'm having an issue that I couldn't find in any of the posts here or bug reports. I'm finding that a few of my movies didn't have that much (or anything) on the Edit Movie / Details page, so I decided to re-scrape them to add the info. It finds everything nicely - posters, fanart, details, but when I click the OK button at the bottom, it doesn't save any of the details.

Even if I type something in manually on the Details page and click OK, it will not save it - and if there was already something in that box, it will over-write it to what it was. Ex: I tried to change a Tagline but it reverted once I clicked OK then went back to check.

I have tried running the program normally and also as administrator, but it will not save any Details.

Any help would be appreciate.
Thanks!
Zer0
(2013-08-06, 18:45)Zer0Squared Wrote: [ -> ]I was so glad to find the latest version of EMM - been using 1.2 forever and loved it.

I'm having an issue that I couldn't find in any of the posts here or bug reports. I'm finding that a few of my movies didn't have that much (or anything) on the Edit Movie / Details page, so I decided to re-scrape them to add the info. It finds everything nicely - posters, fanart, details, but when I click the OK button at the bottom, it doesn't save any of the details.

Even if I type something in manually on the Details page and click OK, it will not save it - and if there was already something in that box, it will over-write it to what it was. Ex: I tried to change a Tagline but it reverted once I clicked OK then went back to check.

I have tried running the program normally and also as administrator, but it will not save any Details.

Any help would be appreciate.
Thanks!
Zer0

Cany you check the nfo-file of those movies - are they named differently, are there multiple nfo files in videofolder, is it VIDEO_TS-Folder ? Maybe try to move/delete the nfo file temporarly of one of the critical movies, then refesh database, rescrape that movie and then look if nfo is build by ember and stored. Thats what I would do. Maybe you can take a look into the log folder of Ember to see if something happens when hitting the "ok" button of the edit menu Smile
(2013-08-06, 19:23)Cocotus Wrote: [ -> ]Cany you check the nfo-file of those movies - are they named differently, are there multiple nfo files in videofolder, is it VIDEO_TS-Folder ? Maybe try to move/delete the nfo file temporarly of one of the critical movies, then refesh database, rescrape that movie and then look if nfo is build by ember and stored. Thats what I would do. Maybe you can take a look into the log folder of Ember to see if something happens when hitting the "ok" button of the edit menu Smile

Thanks for the reply but a couple of problems with those suggestions on my end.
1. I don't have nfo files in the movie folders and I have unchecked them in Ember because all I want in the folder is the movie, a poster, and a fanart image.
2. When I go into the log folder, it is empty.

Seeing that there are no nfo's in the folders, I assume that it doesn't create one just because you clicked on OK after scraping for the details. I have since checked the box for <movie>.nfo in the Settings and am able to make edits and save correctly.

Thanks for the help!
Zer0
(2013-08-06, 19:37)Zer0Squared Wrote: [ -> ]
(2013-08-06, 19:23)Cocotus Wrote: [ -> ]Cany you check the nfo-file of those movies - are they named differently, are there multiple nfo files in videofolder, is it VIDEO_TS-Folder ? Maybe try to move/delete the nfo file temporarly of one of the critical movies, then refesh database, rescrape that movie and then look if nfo is build by ember and stored. Thats what I would do. Maybe you can take a look into the log folder of Ember to see if something happens when hitting the "ok" button of the edit menu Smile

Thanks for the reply but a couple of problems with those suggestions on my end.
1. I don't have nfo files in the movie folders and I have unchecked them in Ember because all I want in the folder is the movie, a poster, and a fanart image.
2. When I go into the log folder, it is empty.

Seeing that there are no nfo's in the folders, I assume that it doesn't create one just because you clicked on OK after scraping for the details. I have since checked the box for <movie>.nfo in the Settings and am able to make edits and save correctly.

Thanks for the help!
Zer0

Hi glad you got it to work. I believe nfo files are necessary for ember to work, and I think it's one of the main advantage in Ember to manage your movie collections offline from XBMC / YAMJ - and the key doing this is thourgh nfo files of the movie which XBMC/YAMJ respects. This has advantages like importing playcount, genre setting of each movie,moviesets and so on making the scan process in XBMC A LOT faster and you can even delete the whole XBMC database without losing any information because XBMC will build everything up using nfo information Smile