Kodi Community Forum

Full Version: changing sound device in xbmcbuntu desktop.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've been using XBMC for a few years now, I love it and think its great.
Everything for me always works flawlessly first time.

I've now run into a problem, I've moved my HTPC from its normal location to another. While everything in XBMC itself works fine, when I'm in the Xbmcbuntu desktop I get no sound over HDMI, it is stuck coming through the Analog ports, normally this isn't a problem because at the usual location I use analog speakers, but in this case I have to use the HDMI sound.

My question is, how do I change the audio device from analog to HDMI? Huh
Welcome to the XBMC forums.

Have you already tried changing the settings on: System/Settings > System > Audio output?
In XBMC the program everything works fine. I'm talking about when I boot into the desktop.
Ah, sorry, misread your initial post.
You probably need to redine the alsa default device in /etc/asound.conf