Kodi Community Forum

Full Version: Game Controller Not Working - Windows
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I've been trying out these branches for a while and the progress has been amazing. Having an issue though with the retroplayer8 branch on a Windows system. XBMC no longer responds to input from my game controller. This isn't just for playing games, but navigating XBMC in general. In the log file I can see that XBMC recognizes the controller, it's just a regular Xbox type game pad, but when I try to press buttons or move the directional pad nothing happens.

I've also tried a more generic Logitech controller, which has also worked in the past, with the same results. Both of these controllers have worked on vanilla Frodo 12.2 installs and previous versions of the the retroplayer branch. I'm thinking something in the XBMC codebase when the rebasing was done must be to blame here. I can post a debug log for more info but first wanted to check if anyone else was having a similar problem and has a fix I could try.

I've been compiling these myself so I don't mind messing with the code if needed.

let's see if anyone else speaks up. unfortunately i can't verify.. i jacked a controller from my friend to develop with, but he stole it back.

i'm a pretty profuse debug-logger with my code, so i wouldn't be surprised if something useful showed up. look for lines starting with RetroPlayerInput, CJoystickXInput or CJoystickDX. if anything raises a red flag, upload your debug log to http://xbmclogs.com or pastebin and i'll take a look at it
Seriously no one - not one person using Retroplayer on Windows?

Thanks for the reply garbear. I'll get a debug log together and post it back here. I'll also try the controller on an alpha of regular Gotham to rule out if it's the Retro branch or Gotham in general.
I don't have access to builds, want to send me one or a link? I can test.
I downloaded and tested the newest hosted build by celedhrim with the same results as when I compiled it myself. You could try one of those:

Here is debug log from the latest retroplayer8 branch. I tried to navigate xbmc with the controller as well as play a game, neither of which worked. Keyboard and mouse inputs work just fine. Tested again with Frodo 12.2 and the controller does work.

I did find this in the log file:

CJoystickXInput: Found a 360-compatible XInput controller on port 0
10:24:33 T:3148   ERROR: CJoystickDX::Initialize : No Joystick found

Not sure if this means something, seems like it found the controller but then couldn't load it or something. Any ideas would be appreciated. If you think it's a Gotham related issue I can post this on Trac as well.

(2013-09-02, 17:35)robweber Wrote: [ -> ]I did find this in the log file:

CJoystickXInput: Found a 360-compatible XInput controller on port 0
10:24:33 T:3148   ERROR: CJoystickDX::Initialize : No Joystick found

The error there is that "No Joystick found" should be INFO, not ERROR. DirectX purposefully skips XInput controllers. IOW, not the cause of the error we're seeing.

Something must have broke internally when rebasing on a newer Alpha version. No E.T.A on a fix, but i'll look into it when I get a chance.

In the meantime, I rebased on the alpha released yesterday (alpha7). Instead of naming it "retroplayer9" the new branch is called "retroplayer-alpha7". The source is https://github.com/garbear/xbmc might be worth it to give the new version a try
finally had time to test this again. did a clean clone of the latest retroplayer-alpha7 branch and built it for windows. still can't get xbmc to register any input by my controller.

i'm cloning the main xbmc repo right now and will build that as well. at least then I can test if it is xbmc in general or something to do with the rebasing into the retroplayer branch. I'll report my findings back here.
nice thread...