Kodi Community Forum

Full Version: Netflix shortcut in within XBMCbuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Team, I have an issue trying to add the Netflix shortcut/Add-on in within XBMCbuntu. I have downloaded the following file spudsdude-XBMC-Flicks-a644263.zip from https://github.com/spudsdude/XBMC-Flicks/zipball/master, and tried to install it by going to "Install from ZIP file, but I get the following error: " Add-ons doesn't have the correct structure".

I have also manually uncompressed the file and placed into my local xbmc folder at /home/USER/.xbmc/addons, but still I'm not able to view or add the Netflix Add-on into XBMC, so I can have a direct access to it in within the user interface.

Also I have already installed Netflix by following this how-to : http://www.omgubuntu.co.uk/2012/11/how-t...-on-ubuntu. Netflix can be lunch and played just fine when login into XBMCbuntu, is just I would like the direct access from Video Add-on on the XBMC UI.

If any help I appreciate. Thanks a Lot

XBMCbuntu 3.5.0-22 i686, XBMC 12.2 FRODO, Skin ACE

Lud.
This is resolved, as I was using wrong plugins.

However I had to use Advance Launcher to create a direct access in within XBMC, and also I ran into an issue with the Window focus, as XBMC doesn't run a Window Manager, so I had to created a script to fix that. Now a new issue came up with the sound through HDMI, where 2 applications (XBMC and Firefox running Netflix) cannot use/share the sound.
(2013-09-17, 00:20)Ludvicfer Wrote: [ -> ]This is resolved, as I was using wrong plugins.

However I had to use Advance Launcher to create a direct access in within XBMC, and also I ran into an issue with the Window focus, as XBMC doesn't run a Window Manager, so I had to created a script to fix that. Now a new issue came up with the sound through HDMI, where 2 applications (XBMC and Firefox running Netflix) cannot use/share the sound.

This is likely due to a conflict between pulseaudio and alsa over resources. You have 2 options.

1) Configure pulseaudio as described here, or

2) Kill XBMC before running the browser as described here, and then set up a hot key on your remote to kill the browser and launch XBMC again, as described here.
[Note: if you're using a keyboard/mouse with the browser, which I suppose is pretty likely, then there's obviously no need to set up a hot key on your remote. Just make sure to set up the script (as in that last link) such that it launches xbmc once you exit the browser.]
(2013-09-17, 16:12)fasteddy Wrote: [ -> ]
(2013-09-17, 00:20)Ludvicfer Wrote: [ -> ]This is resolved, as I was using wrong plugins.

However I had to use Advance Launcher to create a direct access in within XBMC, and also I ran into an issue with the Window focus, as XBMC doesn't run a Window Manager, so I had to created a script to fix that. Now a new issue came up with the sound through HDMI, where 2 applications (XBMC and Firefox running Netflix) cannot use/share the sound.

This is likely due to a conflict between pulseaudio and alsa over resources. You have 2 options.

1) Configure pulseaudio as described here, or

2) Kill XBMC before running the browser as described here, and then set up a hot key on your remote to kill the browser and launch XBMC again, as described here.
[Note: if you're using a keyboard/mouse with the browser, which I suppose is pretty likely, then there's obviously no need to set up a hot key on your remote. Just make sure to set up the script (as in that last link) such that it launches xbmc once you exit the browser.]

Thanks fasteddy for your answer. Issue is now resolved.

To resolved this, I had to see what Sound card is my TV using through HDMI, so I ran aplay -l, then I ran the following command to know the exact card/device it's using: speaker-test -D plughw:1,3

Finally, after a few attempts playing with the combination of 1,3 - 1,4 -1,5 -1,7 I found that the device was 1,7. This can be know by the "noise" more commonly known as static.

Then we need to created a asound.conf file, and placed it into /etc/ folder, and adding the following into it by running sudo nano /etc/asound.conf

Quote:pcm.!default { type plug;
slave.pcm "dmix0"; }
ctl.!default { type hw; card 1; device 7; }

pcm.dsp0 { type plug;
slave.pcm "dmix0"; }
ctl.dsp0 { type hw; card 1; device 7; }
ctl.mixer0 { type hw; card 1; device 7; }

pcm.dmix0 { type dmix;
ipc_key 13759;

slave.pcm "hw:1,7";
slave.channels 2;

slave.rate 48000;
slave.period_size 4096;
slave.buffer_size 16384;

slave.period_time 84000;
slave.buffer_time 340000;

# Map only the first two channels
bindings.0 0;
bindings.1 1; }

After this, just sudo reboot

And now when Netflix is launched, sound its pretty good.