Kodi Community Forum

Full Version: XBMC doesn't recognize proxies or changes in IP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Yes I am a noob compared to you guys but I am smart for a rookie.
I am trying to get XBMC on my raspberry Pi to go through an Italy address to watch content-locked Italian TV.

I have tried to use VPNs, proxies... nothing.

The VPNs and proxies work on my computer, but when trying to get xbmc to work work it didn't.

"Use an HTTP proxy server to access the internet" <-- Doesn't work.
I enter my credentials in. Content still locked. I type in completely random stuff to test, and the internet still works. This means it just doesnt even do anything. If your proxy isn't right, then the internet won't load.

I test it further on my computer and it connects flawlessly, Italian TV unlocked.

I then try to use export http_proxy="http://username:[email protected]:port/" command.

So before I do this I type curl ifconfig.me
it shows my home IP

Then I execute the export http_proxy command
it shows my proxy IP!!!

Only when I go to connect, nothing, locked.

XBMC doesn't like proxies.

Last stage of the test. I configure "Use HTTP Proxy" via the XBMC installed on my windows computer. Guess what? Doesn't work. But when I enter it into chrome's settings, works perfectly, all content unlocked
Is the value still there if you return to the config screen for proxy? Meaning is the value saving?

Are you setting up any system-wide proxies at the same time? Just saying to be sure you don't have a conflict.
Yeah it's saving and nope, no system wide proxies, only on the Pi.
Interesting I never use proxies myself but I am running frodo on windows 7 and tried to enable proxies and tested with wireshark and like you said I dont see XBMC using the proxy. I tried using a real proxy and a junk IP and get the same results where I can connect no problem and the packet captures shows no connectivity to a proxy.
Yeah :/
Hi,
Did you found a solution to get proxy setting working ?
Thanks