Kodi Community Forum

Full Version: OpenELEC 4.0 nightly Gotham builds
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
For the people who would like to start using OpenELEC Gotham nightly builds you can find the a thread on the Openelec forum where you can download these.


Starting with OpenELEC 4.0 there will only be a generic build which should replace the other specific builds
While the OpenELEC forum is down perhaps someone here can advise whether this is an OpenELEC specific problem or a general XBMC problem?

With the latest Gotham builds when I view an rtsp stream from an ip camera it doesn't play smoothly. I can tell because the timestamp from the camera regularly speeds up and slows down.

The log shows these messages.

09:45:40 T:140029036828416 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
09:45:41 T:140029036828416   DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 0
09:45:42 T:140029036828416   DEBUG: Previous line repeats 3 times.
09:45:42 T:140029036828416   DEBUG: CDVDPlayerVideo::CalcDropRequirement - hurry: 1
09:45:42 T:140029036828416   DEBUG: Previous line repeats 1 times.

With the latest OpenELEC 3.2 releases the stream plays perfectly.
Thanks for cutting the logfile.
probably the same issue this fix is for: https://github.com/xbmc/xbmc/pull/3913
@Leopold: Please update to a later nightly, see here: http://sources.openelec.tv/tmp/image/

Those have the fix in it.
Thanks guys.

I tried the latest official build from yesterday, but the problem is still there.
This is the build info.

# cat /etc/openelec-release
OpenELEC (unofficial) - Version: devel-20131230133454-r16750-gd434c0e
After playing around a bit more this only happens when VDPAU is enabled in the video settings, on my Acer Revo 3610 which is an ION 1 machine.

I also confirmed again that the stream plays fine with VDPAU enabled in the 3.2.4 ION.x86_64 release.

I'm trying to run nightlies but I can't get them to boot past the boot splash screen. I AM able to log in to the machine over ssh. When I manually try to start xbmc.bin in /usr/lib/xbmc/xbmc.bin I get following error: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

I'm using a AMD machine with geforce graphical card. What am I missing here ? I'm trying the generic x86_64 builds ...

any help is appreciated !

Just upgraded mine finally now Aeon Nox 5 is released.

Had to uninstall TVheadend server, force update repository and re-install but everything else worked fine.

Also had to set Video >> playback to "Allow hardware acceleration (VDPAU)" enabled and all other options disabled to remove artifacts from live tv playback.

This is on an Intel NUC haswell.

Everything else working well Smile
Quote:Also had to set Video >> playback to "Allow hardware acceleration VDPAU enabled and all other options disabled to remove artifacts from live tv playback.

That's completely wrong. VDPAU is for nvidia/amd oss and not for Intel. Intel uses VAAPI.
tvheadend seems to be broken on the latest nightly, at least on my system. I'm running Generic r17148 which I installed on an empty SSD yesterday. I can install the tvheadend plugin, tune and find the channels, but when I reboot the machine, it does not work anymore. The web interface responds, but it only shows me the Electronic Program Guide tab, nothing else. I cannot access the configuration, since the configuration tab is not visible. If I boot the system without the tuner plugged in, it works, I can see all the tabs on the web interface. Also, if I boot up the system without tvheadend enabled, then enable it, it works.

I've got r16865 on an USB stick and it works ok. The tuner is a typical cheap AF9015. tvheadend add-on is version 4.1.1 and I've tried to refresh the repositories and reinstall both backend and the frontend. But since the problem exists even if frontend is disabled, I think it's something related to the backend. Does tvheadend log somewhere?

Bus 002 Device 002: ID 15a4:9016 Afatech Technologies, Inc. AF9015 DVB-T USB2.0 stick
Above is more a timing issue than OpenELEC nightly issue. I upgraded at the same time to an SSD disk, which boots the system up in a couple of seconds. When I added a sleep command in the tvheadend.start script, it works ok. Don't know why this happens. I've selected the "wait for FE init" option that is available in the addon settings.
@trsqr: How did you add the sleep command?

Did anyone have playback issues on the Gotham nightly. I have gone back to frodo because of play back issues I was having

Yes last few weeks i've had video playback issues with the nightlies.

I'm trying to find the release where it changed. I think its got something to do with VAAPI again.
Pages: 1 2