Kodi Community Forum

Full Version: Windowed mode after killing zsnes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I run xbmc on ubuntu 12.04.3 in shell mode. From there I have set up Rom Browser Collection together with zsnes. I use a openbox as the window manager and a shell script to launch openbox and zsnes,

My script looks like this:

#!/bin/bash
pgrep -f xbmc.bin | xargs kill -STOP
openbox &
/usr/bin/zsnes "$@"
killall -9 openbox
pgrep -f xbmc.bin | xargs kill -CONT -fs


Everything works great, BUT everytime I exit zsnes in order to return to xbmc, xbmc always starts back up again in windowed mode(sits in the upper left corner on my screen). This is extremly annonying as I have to go in to settings in XBMC everytime I am done playing SNES and set the resolution back to fullscreen again.

Any inputs on how to start xbmc back up again in fullscreen mode? I have searched the web like a mad man without finding anything solid Sad
There is a advancedsettings.XML option that enables starting up in full screen, have you tried that?
(2013-10-29, 23:13)teeedubb Wrote: [ -> ]There is a advancedsettings.XML option that enables starting up in full screen, have you tried that?

No I haven't, but I dont think that has anything to do with it. If so, please explain in more detail.

At every boot when i boot up directly into xbmc in shell mode it always launches in fullscreen at first, so thats not an issue, its just when I am done using an application(in my case zsnes) and wants to return back to xbmc again that xbmc remains in windowed mode.

I read somewhere that when XBMC launches any application with a new window manager like openbox, then xbmc always sets itself in windowed mode in order to let the application launch.

The problem is once you are done using that application and wants to go back into xbmc it still remains in windowed mode :/
Ah, you're not restarting xbmc. Maybe the -fs switch at the end of your script is toggling fullscreen?
(2013-10-29, 23:48)teeedubb Wrote: [ -> ]Ah, you're not restarting xbmc. Maybe the -fs switch at the end of your script is toggling fullscreen?

I was hoping that by adding -fs to the last line regarding the relaunching of xbmc, that it would force xbmc to launch back up again in fullscreen, but the -fs command has no effect at all, and xbmc just reappears in windowed mode like I described in my previous post.
You could try the programme wmctrl to maximise xbmc. Is killing and restarting xbmc not possible?
(2013-10-30, 01:00)teeedubb Wrote: [ -> ]You could try the programme wmctrl to maximise xbmc. Is killing and restarting xbmc not possible?

It seems that xbmc never really shuts down while zsnes is running, because once I kill zsnes it looks like xbmc has just been sitting there all the time in windowed mode running in the background while i play SNES.

What I need is a script that terminates xbmc while I am running zsnes, and then relaunches xbmc when I exit zsnes. That way xbmc should start in fullscreen mode.
tried rcb in solo mode?
(2013-10-30, 10:08)teeedubb Wrote: [ -> ]tried rcb in solo mode?

I did try solo mode a couple of days ago, but that was before I got the script that I am now using to work(so basically nothing worked back then).

But that was a very good suggestion indeed, so I will give that a try later on and see how that works out Smile
Looks like it is a pretty common problem I am facing, which several others have tried to tackle as well.

I found this, which really shows the magnitude of this problem. Argh.

http://0x4c.wordpress.com/2013/03/29/xbm...th-screen/
The post that you mentioned is talking about rasbberry pi. I think this is another situation.

What you could try:

Without solo mode: try to increase the post-launch delay in RCBs addon settings. This adds a little wait time before RCB tries to resize XBMC.

With solo mode: did you check if the applaunch.sh file in RCBs userdata directory is executable?
(2013-10-31, 08:03)malte Wrote: [ -> ]The post that you mentioned is talking about rasbberry pi. I think this is another situation.

What you could try:

Without solo mode: try to increase the post-launch delay in RCBs addon settings. This adds a little wait time before RCB tries to resize XBMC.

With solo mode: did you check if the applaunch.sh file in RCBs userdata directory is executable?

I am no expert, but I doubt that increasing the post-launch delay time will make any difference, because xbmc gets windowed allready from the time I launch any ROM(you can actually see this happen, because it takes a good second or so from I launch the ROM to openbox starts and thereafter zsnes, and then you clearly see xbcm shrink and set itself in windowed mode up in the upper left corner of my tv screen just before zsnes starts).

On a personal note I also think that the script I am using never really kills xbmc while I run zsnes, and that xbmc therefore just sits there in the background in windowed mode all the time while i run znsnes, so when I close zsnes xbmc just continue in windowed mode like it did when zsnes first got launched. If the script actually terminated xbmc, and relaunched it like the script is intended to do, then xbmc should start in full screen mode again, so there is something very strange there.
RCB actively sets XBMC to windowed mode and should restore fullscreen mode after the game is finished. So, modifying the delay could help.
(2013-10-31, 13:38)malte Wrote: [ -> ]RCB actively sets XBMC to windowed mode and should restore fullscreen mode after the game is finished. So, modifying the delay could help.

That had no effect at all. That being said, I now effectively give up making xbmc to work with other programs in "shell mode"/standalone mode!

What I have done instead to "fix" this is to set the pc to auto log into Gnome Shell on boot. That way xbmc has a window manager to run in. Then I made a shell script that waits 5 seconds after gnome shell has loaded and then it executes xbmc(the 5 second delay is actually nessesary in order for the sound server to get detected by xbmc running in gnome shell). I set the background in Gnome Shell to completly black so that as little as possible steals any attention before xbmc loads.

I don't like this solution at all, I think it is kind of amateurish, but there is nothing more to do really. This is a problem that really should be solved, because it affects lots of people, and people running xbmcbuntu instead of ubuntu like I do do(and lets face it, far more people actually do that) do not have the same possibility to just "cheat" by logging into Gnome Shell first. Well well, what can you do sometimes Sad

SOLVED?
Since you already have openbox installed use that instead of gnome shell, it lighter and doesn't use pulse audio. Click on the 'xbmcbuntu users read here' link in the link in my signature for a quick guide to set it up.
Pages: 1 2