Kodi Community Forum

Full Version: XBMC in Ubuntu Linux - mouse drift and also movie sets
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I hope a newbie is posting this in the correct place.

I run Ubuntu Linux (currently 13.04, but the "problem" was there prior as well). I seem to have a problem in XBMC with the mouse. If, for example, I go through Videos and try to add a source, the mouse seems slow to repond and then it drifts beyond what I was trying to "land" at. It also does this on the opening menu bar sub-selections.

Also, if I may ask here, I have some home movies for which of course there are no entries in an online database. I was told in another site to use an XML .nfo file. I know squat about XML, but looked up the examples in the XBMC online site and found the samples. I get the titles, outline and plot information just fine, so the .nfo appears to be working, except that I do not get a "set". I added the line for "set" and always used the same name but it never shows up under the "Sets" movie option.

Any help/pointers to help would be greatly appreciated.

  1. Not a solution, but a workaround: Disable mouse support in XBMC and use a keyboard or remote control to navigate/control XBMC. XBMC is designed for a "ten foot" user experience, so navigation and access to its features are optimized for a keyboard or remote.
  2. Did you also enable the option: System/Settings > Video > Library > Group movies in sets ?
(2013-10-31, 20:22)artrafael Wrote: [ -> ]Not a solution, but a workaround: Disable mouse support in XBMC and use a keyboard or remote control to navigate/control XBMC. XBMC is designed for a "ten foot" user experience, so navigation and access to its features are optimized for a keyboard or remote.

I'm about 5 ft away from the wireless receiver, but that's probably not the problem. My biggest problem is that my TV doesn't support CEC so the remote won't do anything. The keyboard is awkward at best for me for some reason (can you say "operator problem" Wink ), but I guess I'll need to get used to that. I was just used to using a mouse when I was setting up a small media center with OpenELEC on a Raspberry Pi for someone else.

Quote:Did you also enable the option: System/Settings > Video > Library > Group movies in sets ?

I didn't think about that until after I posted last night, but I did try it but no go.

I've also run into a small problem, for which I've seen several threads on the net, perhaps leading back to this forum, but no real solution: my own genres. I have Home Movies as the genre for the items I mentioned, but all I see is a lower case home movies. Interogating the database using sqlite3 at the command line shows "Home Movies", not the lower case one. I even removed the source, cleaned the library and re-added the source and still just lower case. Wierd?

So, still looking for anything on sets. I hope I'm doing it correctly:

<set clear="true">our name Family Movies</set>

and would like to know more about cleaning up/adding new genres.

Thanks for the input!! Wink
I'd suggest removing the "clear" attribute, just:
<set>our name Family Movies</set>
should work.
I thought I posted this just a short time ago, but don't see it. So, if this is a duplicate post I apologize.

For the "set" problem, I found out I had accidently left off a ">". Fixed that and the "set" is working fine.

Still looking for help on the wayward mouse. Almost impossible to control.

Thanks for the input!
Do you also get mouse drift when not using XBMC?
No - just in xbmc. this seems to be a common complaint amongst at least ubuntu users who install xbmc - the mouse is almost uncontrollable. going to try building an ir receiver and getting a remote working with xbmc via lirc since my tv doesn't have cec.
Say again, XBMC is not really designed for mouse use. Get a remote, they're only $15.
I *HAVE* a remote!! DId you read the part about my TV not doing CEC? I don't want to buy another remote and IR receiver. This *should* work. When I had Raspian running on a Pi and started XBMC the mouse worked fine - that should work in Ubuntu as well. I suspect it is not completely overriding the mouse driver or some such thing. Move the mouse on 1 screen - it's fine. Go to another with more options - the mouse is all over the place. Seems to me when you move a mouse up, it should go up, not to the side, down or diagonally. The speed should be regulated - it shouldn't start out going nowhere then suddenly the speed keep growing and the pointer keep moving long after you have stopped moving the mouse.

2 screens I notice it really bad on: when adding a video source, the screen you go to when you "browse" is terrible. When you eventually do get something selected, then trying to get on "OK" is next to impossible. Returning from that screen to screen I selected "browse" on and that screen is stable. Click "OK" is stable. The next screen - where you select the "type" is questionable and when you eventually click on "Settings" on the bottom of the page the next page is impossible again.

If anyone here is familiar with the source for XBMC for Linux, especially whatever it is for the Ubuntu port, and would like to point me in the direction of the mouse code, I can try working on it myself. Not here to argue, not here to be told "buy a remote". Just a simple guy here looking for genuine help.
I assume you mean your tv has a remote. So you'll need one for xbmc too. Really you'll enjoy it much better than trying to us a mouse even if the mouse was working perfectly. I highly recommend these and they are dirt cheap. No lirc crap either. http://rtr.ca/sapphire_remote/. There is a howto in the wiki.

I haven't seen that mouse problem described before but the source code is in github.
just do a net search on ubuntu xbmc mouse and you'll see I'm not alone. Personally, I have enough remotes - one of the reason I spent some extra dollars on a programmable multi-function remote. I really don't understand how the mouse can work fine in: Raspian with XBMC running, and in OpenELEC on a Raspberry Pi. It tells me it's something specific to the Ubuntu port - perhaps another mouse driver is not being disabled that should be. Would life be easier with a remote? Yes and no. Am I going to spend MORE money on ANOTHER remote when I already have one? Nope.
The Pi has HDMI-CEC built in, I assume you are running ubuntu on a regular x86 PC which doesn't have HDMI-CEC built in. None of them do. You can get a pulse eight adaptor http://www.pulse-eight.com/store/product...apter.aspx

However if you have a universal remote, you can probably just buy an IR receiver for the PC and set the universal to emulate a microsnot mce remote.
The mouse works with OpenELEC on the Pi. The mouse works running Raspian on a Pi and starting up XBMC. It does not work worth any sort of usable state with Ubuntu. Therein lies the rub - XBMC seems to support if fine, but not on the Ubuntu install. I don't know what it does on other flavors of Linux like Mint, etc.. So somewhere it is grabbing an interrupt or in some other way stepping on something - or perhaps something is stepping on it. It only happens with XBMC in Ubuntu for me. Forgive me if I want to do some simple point-and-click's to get everything set up instead of who knows how many remote button pushes (like for scrolling down through source's lists). No over/down/up buttons - just put the mouse on the selection and click. Can't get much simpler or easier to use than that.

Remember this is on my PC - not a dedicated HTPC. My PC is connected via HDMI to my TV and I use my TV as the monitor. I have the keyboard and mouse right with me - so why complicate things with ANOTHER remote, and IR receiver and the extra button presses instead of just point-and-click?

Simple as that. Problem seems to be in the port for Linux, in particular when installed in Ubuntu (i don't know what it does in other Debian distributions or other flavors of Linux).

I already had the source for XBMC - I was just hoping someone could point me to mouse handling. It's not an event like click - it's actual mouse movement.

EDIT: Shoot - please forgive a sort of duplicate post. I didn't see the second page so I didn't know my post was here along with replies - sorry.

For an IR receiver - if I want to use a USB IR receiver I did fine some generic thing on EBay for $19 that's labeled as a "MCE 83-00000005G Infrared USB Receiver New Bulk IR601". If anyone knows it this works with a Universal remote and lirc/XBMC then I could pick up one of those and not have to go through the hassle of another remote (how many do I need to lose? Wink ). I really would like the mouse working as well though.

Thanks for the replies.
I think theres a couple of things here, obviously the mouse support is one, the remote is another.

Mouse: The devs have said many times that xbmc is bout the '10 foot interface' - mouse support is not a priority, hence perhaps why no one has fixed whatever code causes this problem. There are options for you - the keyboard is pretty intuitive in terms of key presses. You only need it until we get a remote working.

Remote: If it says MCE it should work, and for $19 it is probably worth a punt.
On a keyboard how do you do the equivalent of a right-mouse click?

Also - ordered the IR receiver to try it.

Perhaps you can answer another question in this as well. I know PC's don't do CEC - or at least none that I know of. I knew the Pi does CEC, but I've been having a problem with it with one Pi-based media center. I made it up for my sister and brother in-law for connection to their Magnavox 42" HDTV. The TV remote doesn't seem to do anything for XBMC within OpenELEC on it. The TV is getting it's HDMI input from the cable box via input HDMI4. I put the Pi on HDMI2. HDMI3 and HDMI1 are open. On the Pi, using a mouse, once you click a movie or tv show for play, the TV changes to HDMI1 and you lose the signal from the Pi until you manually change back to HDMI2. I've heard that some devices will automatically change the input when they detect a CEC device. So, I'm thinking perhaps CEC (I think it's called fun-link or some such thing on the Magnavox) is expected to be used only on HDMI1 on the TV. Can't switch the inputs until sometime when more help is available (read nephew and nieces's husband) since I'm handicapped. In the mean time, have you ever heard of such a thing?
Pages: 1 2