Kodi Community Forum

Full Version: bluez install errors (goal towards PS3 bluetooth remote)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm trying to get my PS3 remote to control XBMC. I have XBMCBuntu installed, Frodo.Im following the wiki (http://wiki.xbmc.org/index.php?title=How..._BD_Remote).

I've acquired a bluetooth dongle, and the remote. Next, I need to install bluez. I've tried to install the latest version (5.10) and I get an error after typing ./configure ... the error is:

glib >2.28 required.

The wiki data is sort of dated, so I tried to just use an older version of bluez. And after typing ./configure for bluez version 4.94, I get another error. It is:

D-Bus library is required.

Has anyone else experienced this? What do I need to do to get this up and running?
why don't use install a package? on ubuntu: sudo apt-get install bluez
I tried that and I think it installed. But i downloaded multiple copies of bluez, how do I know which it installed? I also need to apply a patch. I'm new to executing commands in Linux and I'm not familiar with all of the keywords and such. I'm sort of trying to follow what other people are saying to do on the forums.

What version of ubuntu are you on?

You can find what version of bluez was installed by
dpkg -l bluez
I'm on the "out of the box" xbmcbuntu frodo. I think its 12.x something.
I don't currently have xbmcbuntu installed, so how about answering the question? And the result of the command I gave in my previous post.
Thought I answered it. That line worked, and I was able to get the remote working. Thanks