Kodi Community Forum

Full Version: Ubuntu 12.04 XBMC no longer working after upgrade
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm on Ubuntu 12.04

My XBMC was having some issues, so I upgraded to the 2.12.2~git20130502.1706-frodo-0precise.

When I tried to launch via Unity, no luck. So uninstalled via Software Center, then reinstalled via Software Center. No luck. Some recommendations on this site said to delete all files and directories for xbmc, which I did, including my $HOME/.xbmc directories - it was OK to me that I start fresh.

So, I tried this from http://wiki.xbmc.org/index.php?title=HOW..._for_Linux section 1.1 for Ubuntu:
sudo apt-get install python-software-properties pkg-config
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install xbmc

Now I'm getting this error when trying to launch xbmc via terminal, which I can't seem to resolve:
/usr/bin/xbmc: 128: /usr/bin/xbmc: /usr/lib/xbmc/xbmc.bin: not found

I checked /usr/lib/xbmc, and there's nothing there, except for a subdirectory 'addons', no xbmc.bin. Neither 'whereis' nor 'locate' can find xbmc.bin, so it doesn't look like it's been installed.

In checking the repository using sudo apt-cache policy xbmc the output is:
xbmc:
Installed: 2:12.2~git20130502.1706-frodo-0precise
Candidate: 2:12.2~git20130502.1706-frodo-0precise
Version table:
*** 2:12.2~git20130502.1706-frodo-0precise 0
500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ precise/main amd64 Packages
100 /var/lib/dpkg/status
2:11.0~git20120423.cd20772-1 0
500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages


This looks correct to me, since I'm on an amd64, and this appears to be the correct ppa and version for Ubuntu 12.04.

I've tried deleting everything I can find relating to xbmc, uninstalling and installing via Ubuntu's Software Center as well as the apt-get install and update for the xbmc-team ppa, but nothing works.

I would have thought the install would have placed a new $HOME/.xbmc directory, but it didn't do that either. So it appears to be failing on the install, but examining the screen output, I don't see any evidence of problems.

Any suggestions?
try /usr/local/bin/ and /usr/local/lib and see if it's there
Just checked, not there either.
Sorry - don't think I presented my request for help clearly.

I'm not really looking for xbmc.bin. I'm trying to find a way to do a complete, clean install, so things operate the way they should, which would include the installation of xbmc.bin where it's supposed to be. I'm OK with deleting any old remains from previous installs.
first try:
sudo apt-get upgrade

if it still doesn't work:
sudo apt-get install xbmc xbmc-bin

failing that:
sudo apt-get install -f
sudo apt-get dist-upgrade

still no go?
apt-cache policy xbmc xbmc-bin | pastebinit
wsnipex, thanks for your response.

I just performed all of those instructions, but it didn't work - same problem as before:
/usr/bin/xbmc: 128: /usr/bin/xbmc: /usr/lib/xbmc/xbmc.bin not found.

Here's the link to pastebinit: http://paste.ubuntu.com/6394266/

I wanted to note that there's no ~/.xbmc either, so I'm thinking (not very knowledgeable about this!) the install must be failing/stopping at some point, but I'm not seeing errors in Ubuntu Software Center nor in sudo apt-get.

Thanks,

Ben
seems you broke something Smile

lets try to reinstall:

sudo apt-get install --reinstall xbmc xbmc-bin

if it still doesn't work, pastebin the output of that command
"seems you broke something " - LOL!

That did it!

I would have thought that sudo apt-get purge xbmc would have done the trick, but it didn't.

Thanks for your help!