Kodi Community Forum

Full Version: Umlauts in EPG and channel names sometimes not showing correctly
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
In the channel names and the EPG the "umlauts" (german special characters) are sometimes not shown correctly. I've tried to delete the database, but this did not help in any cases. Some were fixed after that, some were not. I don't know if it's an issue of vdr, xbmc or vnsi. Hopefully someone can help me.
Your channels.conf needs to be encoded in utf-8. You can either do this with w_scan when creating the file or use iconv in case you missed this.
Some channels don't braodcast the used character set for EPG. You need to set charset override for vdr:
Thanks! Seems to have worked. Still saw some characters that were wrong, but only on non-german channels (spanish, ...). But I don't care about that.
The issue is not finally solved. After some time the wrong characters in the EPG are back. Do I have to put export VDR_CHARSET_OVERRIDE="ISO-8859-15" into some config file?
I have it in the script runvdr
(2013-12-22, 20:35)FernetMenta Wrote: [ -> ]I have it in the script runvdr

I've tried ti change the /usr/sbin/runvdr as follow

echo 'C.UTF-8'

setEnv() {
    if [ -z "$VDR_LANG" ]
        local VDR_LANG=$(getLang)


start() {
    local plugins=''
    local args="-u $USER -v $VIDEO_DIR -c $CFG_DIR -L $PLUGIN_DIR -s $VDRSHUTDOWN \
                -E $EPG_FILE -g /tmp --port $SVDRP_PORT $OPTIONS $@"
    local epg_dir=$(dirname "$EPG_FILE")

    for i in $PLUGINS
        if [ -f "$PLUGIN_CFG_DIR/plugin.$i.conf" ]
            a="$(echo $(cat "$PLUGIN_CFG_DIR/plugin.$i.conf" | sed "s/ *#.*$//"))"
            plugins="$plugins -P '$i $a'"
            plugins="$plugins -P $i"

    [ ! -d "$epg_dir" ] && mkdir "$epg_dir" || true
    [ ! -d "$VIDEO_DIR" ] && mkdir "$VIDEO_DIR" || true
    chown $USER:$GROUP "$epg_dir"
    chown $USER:$GROUP "$VIDEO_DIR"

    ([ -z "$PLUGINS" ] && echo 'Starting VDR') || \
    echo "Starting VDR with plugins: $PLUGINS"


    eval exec "$EXECUTABLE" $args $plugins

start $@


is it right in this way, because I had no succsess
I would put it before the call to start vdr.
Thank you,

I will try..
Thanks again....

It workd...
It's working for me too, but after every update of vdr, the code line is gone and I have to add it again manually. Is there another way I can do this or another file I can add this to so that it stays permanently?