Kodi Community Forum

Full Version: Frodo V12.2 Stuttered Playback of BluRay ISO Files
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm new to XBMC (V12.2 Frodo) and am running the software on a WIN8.1 Haswell (Assassin-built) HTPC system connected to my Denon 4520.

I've successfully played MKV movies in XMBC but am having a peculiar problem with BluRay ISO files.

Strangely, the preview trailers in the BluRay ISO play perfectly ... no video or audio issues. Once the BluRay menu is up and the actual movie is started, the video begins to stutter and play very slowly -
like in slow motion. No audio is audible at this point.

I've checked my settings but can't seem to make this work. I've seen similar threads on this topic but the solutions don't work.

Any ideas on what's going on?

Thanks,
Herb...
It's a problem with your audio settings for TrueHD and/or DTS-HD. Make sure you set your audio device and passthrough device (in xbmc's audio settings) to WASAPI: HDMI - Denon 4520, and enable TrueHD and DTS-HD under the list of formats to passthrough. The video stuttering is just a symptom of the audio issue.
The Audio Output settings are set as follows:

Audio Output Device: WASAPI: HDMI - DENON-AVRHD-3 (2-NVIDIA High Definition Audio)

This setting was in place BEFORE I noticed the stuttering problem.

Besides, why will the Trailers on the BluRay ISO play perfectly but the main movie won't?

Thanks,
Herb...
Just audio output device, or passthrough device as well? It's the passthrough device that's important here.

Trailers and extras tend to use regular AC3 or DTS audio, which can be decoded just fine by xbmc and don't need to rely on being decoded by an external device.

Here's a big thread which deal with the problem you're having, http://forum.xbmc.org/showthread.php?tid=146911
PROBLEM SOLVED!!

Thanks for your help. Oddly, I couldn't navigate to the Pass Through section with the Cursor. It's only when I used the up/down arrow keys that I was able to see this setting at the bottom
of the menu.

Regardless, it's now set the same as Audio Output.

Cheers,
Herb...