Kodi Community Forum

Full Version: Boblight stopped, only corner showing
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

As of this morning my boblight setup stopped working.. Only about 40 leds work as video plays in the upper left corner. The startup swirl and the rgb walktrough from the arduino works fine. My setup:
Win 7 ultimate 64 bit
XBMC 12.2
126 LED ( 378 channel ) WS2801 strip
10Amp 5V supply

a movie about the fault can be found here

a pastebin of the boblight.conf can be found here http://pastebin.com/fKZuaMUz

Boblightd starts as always with only a warning about the path:
ERROR: unable to make directory /home/nrrepel/.boblight/:
No such file or directory
(PrintFlags)                    starting /boblightd/boblightd -c c:\boblightd\bo
blight.conf -f
(CConfig::LoadConfigFromFile)   opening c:\boblightd\boblight.conf
cygwin warning:
  MS-DOS style path detected: c:\boblightd\boblight.conf
  Preferred POSIX equivalent is: /boblightd/boblight.conf
  CYGWIN environment variable option "nodosfilewarning" turns off this warning.
  Consult the user's guide for more details about POSIX paths:
(CConfig::CheckConfig)          checking config lines
(CConfig::CheckConfig)          config lines valid
(CConfig::BuildConfig)          building config
(CConfig::BuildConfig)          built config successfully
(main)                          starting devices
(CClientsHandler::Process)      opening listening socket on
(CDevice::Process)              ambilight: starting with output "/dev/com3"
(CDevice::Process)              ambilight: setting up
(CDevice::Process)              ambilight: setup succeeded
(CClientsHandler::Process) connected
(CClientsHandler::ParseMessage) said hello
(CClientsHandler::ParseSet) priority set to 128
(CClientsHandler::ParseSet) priority set to 255
(CClientsHandler::ParseSet) priority set to 128
(CClientsHandler::ParseSet) priority set to 255
(CClientsHandler::Process) Connection closed
(CClientsHandler::RemoveClient) removing

Ive already reinstalled XBMC and used system restore but the problem stays.

Any help would be highly appriciated !

PS just tried Prismatek, works perfect but the smoothness i like from boblight isnt available for adalight Sad


Just connected the laptop to the setup. No problems.... Running the same deamon and config as my HTPC. It seems the problem is with the PC and/or something conflicting with boblight. In the meanwhile ive:
- resoldered all connections
- used an different USB port and reinstalled the usb/serial driver
- tried Prismatik and ambibox, both work fine but (PC is a but slow) i really like Boblight

Any ideas ?
Quote:both work fine but (PC is a but slow)
Quote:Any ideas ?

AmbiBox as Boblight uses direct capture of images from XBMC, it can not be slow.