Kodi Community Forum

Full Version: Nestopia on XBMCBuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm trying to install Nestopia 1.40 on XBMCBuntu so I can use the ROM loader in Frodo.

in the README it says to unpack the Nestopia file, and the Linux overlay. In your terminal, go to the directory and type "make -j3" or "make -j5" if dual or quad core.

I have an Intel Pentium 4 HT which I believe is single core. At any rate, I get the following errors:

Code:
Compiling source/linux/main.cpp...
Compiling source/linux/auxio.cpp...
Compiling source/linux/input.cpp...
source/linux/auxio.cpp:14:39: fatal error: core/api/NstApiEmulator.hpp: No such file or directory
compilation terminated.
source/linux/main.cpp:21:39: fatal error: core/api/NstApiEmulator.hpp: No such file or directory
compilation terminated.
source/linux/input.cpp:15:39: fatal error: core/api/NstApiEmulator.hpp: No such file or directory
compilation terminated.
make: *** [objs/linux/auxio.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [objs/linux/input.o] Error 1
make: *** [objs/linux/main.o] Error 1

has anyone else installed Nestopia on their xbmcbuntu system? If so, can you shed any light on this or let me know what to do? Or is there a more preferred emualtor for NES? Thanks for any help
Try dropping the -j option, do a 'make clean' then try compiling again , sometimes it causes problems. You could try find a ppa or precompiked version on the net. Or use mednafen, it emulates nes and is awesome to boot Smile
Ok thanks. Is mednafen a preferred emulator for XBMC? I see it works pretty much as an emulator for most all the popular systems
Its my preferred emulator Smile its very high quality. It doesn't really matter which one you use with xbmc, as long as they support command line arguments, launching addons can use them.
What should happen when you open the executable in XBMCBuntu?

I installed it via:

Code:
apt-get install mednafen

Everything looked good. It placed the exe in /usr/games/mednafen.exe ... when I open it, I'm prompted to execute or execute in terminal. Neither option opens the program that I can see...

Also, it seems the ROM Collection Browser won't allow me to point to the appropriate path of the exe? It just shows the DVD drive and a USB HD I have attached. Is this common?

And the ROM Collection Browser just doesn't seem to recognize the NES .ROM's at all. Not sure what the deal is on that. Maybe its associated with being able to point to the actual location of the emulator exe?

Still learning the ropes of XBMC and managing the add-ons. Thanks