Kodi Community Forum

Full Version: [HOW TO] KODI Linux on Amlogic TV Boxes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2015-06-01, 21:07)xbmcdoc Wrote: [ -> ]
(2015-05-30, 08:49)raymw Wrote: [ -> ]
(2015-05-29, 20:01)xbmcdoc Wrote: [ -> ][quote='raymw' pid='2013979' dateline='1432713445']
Those dual core 520 boxes get hot already so by default they are now usually set to 1.2 Ghz and that IMHO is plenty fast enough so it is a good think if setting it faster than 1.3 Ghz is disabled. I live in a hot climate and even consider slowing my old 520 box down a little but it does seem to just about be okay if getting a little close to critically hot. 1.5 Ghz is a no no unless your TV room is running well below 20C or even less IMHO. Turn the box upside down and the heat can more easily dissipate of course though does not look so good

Thanks for posting that tip as indeed it is a good on for readers here to see. I do already use one though for the past year xbmcdoc so know their benefits in hot places like here. I got hold of a quite small one that is more in size to fit under my ATV1200 box and cost me about 200 Thai Baht (£4). The ATV520 box though is very much smaller than the ATV1200 so I doubt I could find a suitable USB fan small enough to be practical. But I mainly use my ATV1200 as it is a superior box that also supports WiFi with Gotham and Helix of course.

Too bad the ATV1200 isn't in production any more. It was a good box.

Interesting enough pushing cooler air from under the box is more efficient than fanning from the top. The ATV1200 has a fan plug inside too. I think it is a 2-pin plug. I tried a little fan inside the box once but it was loud and didn't have time to install a switch in between (turn it on only when needed).

Yes it was a good box xbmcdoc but so is the ATV1220T which is basically the same box inside with the addition of a DVB -T (NOTE not T2 so not a lot of use to a lot of us and anyway only works with Android so not worth using it if you could) I believe they made a none DVB-T model too but I only seem to be able to get the 1220T model now but at the same special price to me as the 1200 boxes.

Yes sure always best to push the cooler air up form below of course, basic physics. But many do not have a fan so the upside down trick does help the 520 box owners until they get a fan. Never thought of fitting a small internal Northbridge / Southbridge type small fan over the ATV1200 box cpu heatsink, but to be honest never had one fail with heat yet and that is even here in very hot Thailand. I also have no real need or desire to want to over-clock them to 1.3 to 1.5 GHz anyway as the 1200 and 1220 boxes are nigh on perfect as they are at 1.2 GHz IMHO so no need to take any even slight risk of frying the cpu.
Hi, & yes you've guessed right again another day another brick, this time it's a nano slim+ M3 box I thought I was sure that I was putting in the right firmware (Droidtv M3 20130520), However, after inserting the sd card holding the reset & plugging it in the big green man appeared staring at me from the screen menacingly almost threatening & then he was gone & I have not seen him since, the screen went black for a few seconds & then I got the onscreen message telling me to to check the cable etc. as nothing connected to hdmi. I would like to say I'm sorry & i am for having to keep coming here for help but I enjoy playing about with them so I'm not sorry for that every body needs something to occupy them. Thanks again for any help offered.
Oh rotten luck mate, sorry to hear that. Hmm sounds just possible that you may have a dodgy HDMI lead (yes I have had two of them over the past couple of years) or the HDMI connection to your TV is not fully pushed home. Could be the graphics chip in the box has blown but again that would be rare as never come across this happening. Just double check out all your connections and even try it with a different TV or using a different HDMI socket on the TV too. Those M3 boxes did put out I think 480 line low res output in recovery mode and I have had some TVs that are not able to display that res properly if at all, so try with another TV that is definitely capable of displaying 480 line input (most modern TVs do but not all) . Just some other ideas worth a try Joshua

Otherwise it is most likely bricked of course and you will need to carry out one of the many unbricking procedures discussed in these forums many times. Probably the shorting of the two pins procedure may be the way for you, again all well documented in this forum with photos too.
@AuXBoX, did you ever get around to do a 14.2 build for the MX g18ref ?
Hi Raymw, thanks for the reply, I've been going through the posts on here & can find the pin shorting method but most of the files are for the M6 or MX have I got to use a specific file on the bootable sd card or just an old rom.
cheers. josh
(2015-06-06, 20:38)joshua99 Wrote: [ -> ]Hi Raymw, thanks for the reply, I've been going through the posts on here & can find the pin shorting method but most of the files are for the M6 or MX have I got to use a specific file on the bootable sd card or just an old rom.
cheers. josh

What box have you got joshua,as I cannot remember what you said you have? I use a blank boot SD card set up with no image on it so I end up in the basic recovery mode once the pin shorting procedure hard resets the device. I then hard reboot the box with the reset button held in with a normal SD card with MX Linux KODI Helix 14.2 compile on it so it can auto flash as normal then.

As I said for now I no longer use Ember as causes too many problems at the moment until it is fully fixed. So now I exclusively use with Android based ATV1200/1220 boxes, AuxBox's excellent MX Linux KODI Helix 14.2 compile available on Page 1 of this forum thread and it works flawlessly for me..

Ah sorry Josh just seen it is an old M3 box. Well never shorted any pins on those M3 boxes and never had to. So I am personally not sure what set of files you need to put on your bootable SD card when you short the pins. Did not know there was even a photo on here of the M3 board to be able to locate the pins to short.
Finally I went and upgraded my ATV520e from Geniatech Linux running Frodo. For whatever reason I chose first to go for MX Linux Helix 14.2. My choice was affected probably most that I didn't want to go through reverting to Android, as some recommended with EmbER.

I did straight upgrade. Easy and fast. Everything seemed to work well, alhtough I had red leds on all the time. I liked especially being able to shutdown and power on the box with remote. Some problems with some of the mythtv recordings, but really minor things.

Then I read about others experiences in EmbER. I downloaded 1.01 release, which is latest as of now. I didn't want to go through Android this time either, so I did straight upgrade. No problems this time either. Remote does not power off the box, but it powers it on. Any chance get that to work with remote.conf?

I like EmbER, and I think I will stick with that. I use my box mostly for livetv with mythtv pvr addon and watching recordings. I have same issue with same recording as I noticed with MX Linux running Helix 14.2. Couple of crashes too, but I'm impressed.

I'm escpecially interested in OTA upgrade as an option, since tell you the truth, everytime I have to flash the box, I'm afraid I will brick it.
If you have the kr60 remote the 4 button is on I think. But never mind you can't power off.
ATV520 remote has only power on/off button (same button). With EmbER it only powers the box on, but not off. With MX Helix 14.2 it also did power box down.

I don't see any difference between EmER remote.conf and MX Helix remote.conf. They both have:

0x45 31         ;POWER
When I triy to power off EmbER, I get following entry on kodi.log:

10:12:09 T:1093468160   DEBUG: Keyboard: scancode: 0x1f, sym: 0x0073, unicode: 0x0073, modifier: 0x0
10:12:09 T:1093468160   DEBUG: OnKey: s (0xf053) pressed, action is noop
So I guess the "action is noop", where as it should power down the system. I'm sstill not following how should I edit remote.conf. If I try to put there line:

0x1f 31         ;POWER
Which in my logic might work, it really doesn't. No matter if I boot the system.
(2015-06-25, 20:40)sonicov Wrote: [ -> ]
0x45 31         ;POWER
Actually, I think this is correct. When I press power, I get scancode 0x1f which is 31 in decimal. Earlier I mixed the button and function. Seems to be first function, and then button scancode.

Anyway, on all my remote.conf files action for POWER has been 0x45, so I can not figure out how to get this working.

I welcome any ideas.

I have installed both the Helix 14.1 and 14.2 builds from the first page on my Mygica ATV1200 and they boot up but end up with a black screen. I've tried this with both the HDMI and component outputs.

After power on, I see the MX-Linux penguin screen and then the Kodi Loading scree. After that it goes to a black screen. The box can be rebooted by pressing ctrl-alt-delete using a usb keyboard. Anyone got any ideas why this might be happening? Any tips for debugging?

The Geniatech Frodo and the XDA Gotham builds both work fine for me.
Is that Ember Helix 14.2 or the MX Linux Helix 14.2 version from Auxbox ?? Have no problems with Auxbox's compile Helix 14.2 at all, but have had some issues with Ember which I think and hope they are working on currently . So what box are you using ? I use primarily MyGica ATV1200 and 1220 boxes which are G02Ref based boxes.

You could try reverting to Android first using one of the first;page links and make sure that it boots okay and then try flashing to Helix 14.2 from there. Obviously make sure your HDMI lead is fully pushed home but if not then you would not see the initial boot up KODI screen of course.
It is with the MX Linux Helix. Same issue with both the MX linux 14.1 and 14.2. I've not tried Ember. I'm using a MyGica ATV1200.

I haven't tried reverting to Android first. I'll give that a try.
(2015-06-30, 08:46)widdly Wrote: [ -> ]It is with the MX Linux Helix. Same issue with both the MX linux 14.1 and 14.2. I've not tried Ember. I'm using a MyGica ATV1200.

I haven't tried reverting to Android first. I'll give that a try.

How did you get on with first reverting to Android ??
Haven't had a chance yet Ray. I will post my results once I do.