Kodi Community Forum

Full Version: [HOW TO] KODI Linux on Amlogic TV Boxes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
@raymw: no prob, i have tried that version but the back button takes you right back to the start and not back one step. There is a newer version that this is fixed, however it does have a crackling problem on very loud scenes. i have seen this issue in the Jan Geniatech version, Coreys version also. Also the screen borders screw up when changing to 1080p, but from what i have learnt recently there is no advantage changing it to 1080p.
Spada Spud, that is no problem with the remote all you just need to do is to change the remote.conf file to the correct one which I do with all MX box versions of Frodo anyway so I get the ideal remote settings I want depending on make and model of box. There is a lot about that on this forum, easy and quick to do. Also I personally have absolutely no sound problems with this 12.3 version either and that alone is a big reason why I like it. So maybe a hardware related problem as indeed may my AC3/DTS audio probelm wiht my Denon HT though it is a brand new model.

As to screen calibration well I do that with all versions for both 720p and 1080i though I normally leave mine in 1080i even though it may only be up-scaled it looks gorgeous on my now 3 year old 46" Samsung Series 6. So I honestly have absolutely no issues with 12.3 as I said so is my preferred version still.

All I really very much need now is this surround sound AC3/DTS audio problem sorted with Gotham 13.1
Ignore my comment on the screen screwing up.... I decided to check it on another screen. It seems that it was my dell(dell s2409w) monitor was screwing it up not the box.
(2014-06-14, 01:49)AuXBoX Wrote: [ -> ]Hey bobones,

I noticed on the XDA forums you asked about the advancedsettings.xml. Why dont you just put it in /root/.xbmc/userdata, you can create files in that directory

Thanks, I'll play around with this. On my first go, the advanced settings I put on the image didn't replace the one I already had on the box, but that is fine on an upgrade install. Maybe it will work on a fresh install which would be ideal.

(2014-06-14, 03:38)Spada Spud Wrote: [ -> ]@bobones: From what i know there is only one version of the 4.2 with KR34 remote. Have you found any issues? I have found that the remote stops working sometimes and then just starts up again. This might be take sometime. not sure yet. could be 5min could be 30 mins. Have you found this issue?
This is the Android 4.2 version I have tried http://www.mygica.ca/forum/viewtopic.php?f=41&t=1570 It works really well with Gotham 13.1 IME and I don't have major problem with my KR32 remote (http://www.mygica.lk/mygica-remote-control-KR32.html) although I did have to tweak /etc/remote.conf to get it perfect.

(2014-06-14, 06:44)raymw Wrote: [ -> ]Bobones just to confirm I am trying to use the HDMI passthrough audio with AC3 and DTS sound source content and whatever I do it just causes the very loud staccato crackling, and the Denon does not even auto switch to Dolby D or DTS. Cannot be hardware as the same box works fine with Frodo 12.3 so something changed since Frodo 12.4 and still there in Gotham.

Sure I can use the Toslink FO cable and configure my Denon to receive digital audio on that link but it then is not what I wanted as the HT does not auto recognise DD or DTS then. Just would love it working as well as it did with Frodo 12.3 and before. Please can someone confirm they also get this surround sound problem too with their Home Theatre units Huh As you would expect the problem occurs with ANY DD or DTS source content whether streamed or from a file on my system.

Also BoBone not having any audio sync problem with your new 13.1 Corey compile. Been testing out with various content both HD and SD content streamed and from files on my system. Also so far I have only had one lock-up with 13.1 and that was internet drop-out related. Usually I have only ever had audio sync problems with either poor internet streaming or from a corrupt file I am trying to play. This new Corey build and you excellent compile is awesome AFAIC, other than the AC3/DTS audio passthrough problem and ATV520 WiFi the others I listed are only minor issues.
There must be something weird going because DD and DTS passthrough over HDMI are working with my Panasonic amp. The amp detects Dolby Digital or DTS signal on passthrough and detects DD signal when AAC is transcoded to AC-3 by XBMC. This was my major motivation for compiling this build: I wanted to try Linux with Gotham and pass through. I don't really get why you get crackling noises with your Denon amp, but as I said, Corey has disabled it in his repo for some reason that he must have seen in testing.

I'm still seeing lipsync problems, but I don't know if Android was any better in this regard to be honest.
(2014-06-14, 14:54)bobones Wrote: [ -> ]This is the Android 4.2 version I have tried http://www.mygica.ca/forum/viewtopic.php?f=41&t=1570 It works really well with Gotham 13.1 IME and I don't have major problem with my KR32 remote (http://www.mygica.lk/mygica-remote-control-KR32.html) although I did have to tweak /etc/remote.conf to get it perfect.

Yeah thats the same version im using. I have been in XBMC a few time and the remote just stops working. Its rare. So you might have not picked it up yet.

What did you have to tweak in the remote and where is there best info on tweaking the remote for Android 4.2?

I will also check HDMI passthough with DD and DTS on my old onkyo amp on your Linux build and see how it goes.
Install sshdroid then edit /etc/remote.conf and use keymap editor add-on in XBMC. You need to make filesystem writable with mount -orw,remount /system
bobones you can put the advancedsettings.xml in after you flash your device
Hmm bobones something weird indeed if your AC3/DTS works fine to you Panasonic and you really switching to full 5.1 surround ?

Tried everything I can think of here with both the ATV1200 box settings in 13.1 and my Denon AVR 500 too. Crackling sound very loud and more of a rushing sound with staccato over the top but no required audio heard in the background either and Denon will not show any auto switching to DD or DTS. As I said same material with same model ATV 1200 boxes using Frodo 12.3 build of 2nd Jan 2014 works perfectly but not 12.4 or Gotham builds.

Can anyone help me here please ??
Of course I am! My amp is displaying Dolbly Digital or DTS when the appropriate signal is received, and through the speakers it's obviously digital surround that I hear, with zero distortion. Post a screenshot of your audio settings or just list them here. Make sure you don't give your amp settings that it is not capable of. Keep it simple, just plain, vanilla AC3 and DTS, nothing else. If you want AAC to be heard at its best, set your speaker config to 2.0 (yes, this is still 5.1) and enable AC3 transcoding.

BTW, here is another cut of the same compile, this time with a minimal read only advancedsettings.xml in /usr/share/xbmc/system and remoteaskeyboard=true as default. This leaves all gui settings available to the user to tweak and will work out of the box for typing the network key in network manager on fresh installs. The actual OS and XBMC are identical to previous build so it's just minor tweaks to settings:


If you want to reproduce the advancedsettings.xml from Corey's repo in writeable /root/.xbmc/userdata, use these:
  <loglevel hide="false">2</loglevel>
  <cputempcommand>echo "$(cat /sys/class/saradc/temperature) C"</cputempcommand>







I'm just uploading another compile, this time I believe Broadcom wireless is enabled. Sorry, can't test it all: I just enabled the option and it appears to have added some modules to the kernel.


I have an ATV520 so I'll give your build a try to let you know if the wireless works (even though I don't use it on my setup).


Good news and bad news (but not that bad!

Bad news first: No wireless that I can see on the Network Manager under Programs. Is that where I check? There seems to be no settings under under System/Internet access that I can see.

The good news: You build installed over-top of my old build, keeping all my settings intact. Also, I can now ssh in with Putty! This is the first build of Gotham that I've been able to do that with! I just rebooted the ATV520 from this machine to test it, a handy feature to have.

When you sort out how wireless can be activated, I'll be happy to test it for you, but preliminary shows that your build is sound otherwise.

Good work!


P.S. Anyone know why the 'shutdown' command doesn't work on these boxes?
Tinker: thanks for testing. I would think Network Manager should just start working if the Broadcom stuff is correct. I tried a quick compile after I enabled the option, but maybe a complete rebuild is required. I'll upload another tomorrow, but if that doesn't get wireless working with the 520 then I guess we're just going to have to wait.until someone with real skills gets on to it!

OK, we'll see if wireless works on the next build then. Is there anything else that needs test with this build now that I have it up and running?

This is basically Croniccorey's latest code (united_aml branch) with passthrough audio force enabled. I have no problem with DD or DTS passthrough, but others experience heavy audio distortion. I get some mild lip sync problems and the occasional video and total system freeze so yeah, let's know your experiences.

There's probably very little I can do about problems but maybe Corey at XDA developers would appreciate feedback. See this thread http://forum.xda-developers.com/showthre...29&page=85 I am still not convinced that this is a better option than the recent MyGica 4.2 Android f/w on these boxes. For sure, XBMC is faster and remotes work better under Linux (and there are likely other advantages), but system/video hangs are a big deal and don't seem to happen under android, at least not with the same frequency.