Kodi Community Forum

Full Version: [HOW TO] KODI Linux on Amlogic TV Boxes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

About wifi:

When I look at my Network Manager addon settings, the version number is 12.00. It also says: "Requires Network-Manager 0.9 which are included in XBMCUmbuntu." Is that addon missing in your build?

Tinker: no, mine says the same thing, but the Network Manager actually detects wireless networks since I have a non-Broadcom ATV1200.

Here is the new build. It's just the same configuration as the last but a complete clean build from adding the BR2_PACKAGE_BROADCOM=y option. It would not surprise me if it made no difference and the NM still did not detect networks on 520 machines, but it's worth a try.


OK, I'll give it a try!


No joy on the wifi! Everything else seems to function though. If wifi works on your ATV1200, then you've got to be close. I'm sure folks would like to see this taken care of. I have mine hooked up through ethernet... which I unplugged before I booted and still nothing. I tried everything but still it says "No wifi device found".

Tinker. Sorry, I am not a dev, I am just modifying options and compiling code from repos, so if this is going to get fixed for the 520, it will have to be Croniccorey or some other dev who does it, not me. You could try asking about it on here http://forum.xda-developers.com/showthre...p=53492243
Hi Bobones

Once again many thanks for the latest compile of 13.1 with Corey''s latest build. Really appreciate what you are doing for us all BoBones and of course Corey's wonderful development work on the kernel builds, and indeed everyone else involved with this project,

Now installed it on a MyGica ATV520 box (with the WF aerial on the back) but can confirm running the pre-installed Network WiFi Manager add-on in the Program group still does not work with MyGica ATV520 boxes with Broadcom fitted (note this is not, as the other posted mentioned, the Network Manager Addon you can install from a repo as that has been around a long time and is not the same as this pre-installed WiFi Manager). SO even though the 520 has the external WF aerial the NM WiFI Manager does not show me any WiFI access points available. So the Broadcom fix does not seem to work. Can you pass this onto Corey please as I cannot write to that forum because my status is not senior enough yet.

As to my Audio passthrough corruption well have been trying every possible combination and even with setting the channels as for 2 and enabling AAC to transcode to AC3 as you suggested, it then brings me the same loud distortion with AAC content which of course is now transcoded as AC3 passthrough. So it is on ALL passthrough content. The volume control on the XBMC box remote shows audio as passthrough and as normal is then not adjustable from the box, only from the AVR. I am sure my latest model Denon AVR 500 is capable of all the passthrough digital modes but have no True HD content to check it with, but as I said I tried all combinations of enabling and disabling audio features, and on my AVR too. Works fine with passthrough disabled.

As I said this Audio problem is only on Frodo 12.4 and all Gotham versions so far. Once again can you kindly pass this on to Corey for me on the XDA Dev forum..

Currently for both ATV1200 and ATV520 boxes then the Frodo 12.3 build of 2nd Jan 2014 is so far the best as it all works with both boxes and with the MacBeth1975's DialogAccessPoints.xml easy fix applied for WiFi access.
One other point to add re my passthrough audio corruption is that if I connect direct to my Samsung Series 6 TV which does accept AC3 and DTS signals then I get no distortion (of course the TV downgrades it to 2 channel stereo through the TV;s awful speakers). Once again the box shows it is in passthrough mode as the volume control on the remote does as normal not then function. So the problem is with my Denon AVR 500 box and this being a latest model should be compatible with all flavours of AC3 and DTS. BUT we have to remember the Denon works perfectly with AC3 and DTS passthrough with Frodo 12.3 and earlier on both ATV1200 and 520 boxes.
Hi Raymw

It looks like your Denon amp doesn't like something about the signal, but other A/V amps (including my Panasonic) don't have a problem. There are just too few of us using these builds to know what's going on. I won't bother Corey with any of this stuff at the moment because he hasn't released anything official that claims to have fixed broadcom wireless or pass through. I would think the time to report bugs is once he releases a new version because what I have compiled is still work in progress for him.

I have actually abandoned this build on my box and gone back to MyGiga 4.2.2 Android with Gotham 13.1 as it seems more stable if a little slower. These linux builds seem to crash and freeze fairly frequently, but the stock Gotham 13.1 release works well on this Android firmware, and yes passthrough works here too. I just use an Autostart app to kick off sshdroid and xbmc at boot time.

I am now trying to get Codesnakes' port of OpenELEC for MX to boot on my box, but no joy as of yet. I am hoping someone with real skills will pick up on this for our Geniatech devices. This is port really has potential for us.
Strange as Denon, Nad, Yamaha are the top brands for high quality home theatres over my old consumer level Samsung unit which sounded very poor in comparison to the Denon of course. As I said fine with Frodo 12.3

I would think Corey would want all feed back for his test builds so I think well worth mentioning to him if he has made Broadband mods to this current build.

Won't go with Android bloatware as would rather have the better streaming and more XBMC addons I am told you can get with Linux XBMC as XBMC is all I want my media box for. The rest like games, email and web browsing are so much better on my iPhone iPad and PC. So i much prefer to put up with maybe more crashes via Linux if even this is the case, though this latest compile of yours seems pretty stable to me here.

Keep up the good work. Wish I knew how to set up a virtual Linux Ubuntu machine on my PC so I could also compile but never got my head around virtual machines as that all happened long after I retired.
Going back to Frodo 12.3 on my main everyday used ATV1200 box so I get my surround pass-through sound back working well with my Denon AVR500, I will use other 1200 and 520 boxes for testing new Gotham builds and compiles until the Broadcom and Denon AVR distortion problems are both fixed. Frodo 12.3 does all I need and is stable with the only minor problem being the shut-down is messy being unable to power it back up without manually switching the box off and back on, which was fixed with 12.4 and correct remote conf file installed..I do tend to leave my 1200 / 520 main box on 24/7 though as it keeps the updates coming in and keeps my temporarily cached info too and is instantly ready for use.
(2014-06-20, 18:03)bobones Wrote: [ -> ]I have actually abandoned this build on my box and gone back to MyGiga 4.2.2 Android with Gotham 13.1 as it seems more stable if a little slower. These linux builds seem to crash and freeze fairly frequently, but the stock Gotham 13.1 release works well on this Android firmware, and yes passthrough works here too. I just use an Autostart app to kick off sshdroid and xbmc at boot time.

Hi Bobones

Could you post the steps and links to the software needed to revert to Android from Linux, I have tried several boot cards with no luck it just keeps booting to Linux.
This is on a Sumvision Cyclone X2.
Bodgit well my main box here I use for my personal use is a Sumvision Cyclone X2 and I was running the latest Bobones compile of Gotham 13.1 on it until yesterday. It was running pretty good though had a couple of full freeze crashes when it was left on idle, though that may have been an overheating problem as it was in a cupboard here in very hot Thailand. Maybe this Linux Gotham build does heat the box up more than Linux Frodo 12.3, certainly seems to feel cooler now.

I have definitely not gone to Android as I find it way much slower for streaming than Linux XBMC like for like, and I do simply not want to clutter up my system with all that useless for me Android bloatware. So purely efficient and fast Linux XBMC for me as I just want to use XBMC and that is exclusively essential IMHO.

Anyhow due to the Surround sound corruption through my Denon AVR (see above postings) I have reverted back to Linux XBMC Frodo 12.3 of 2nd Jan 2014 which works beautifully with passthrough digital sound working 100% and is very very stable too (can also run Amber skin without subtitle problems as I get with Amber on Linux Gotham still). Quite honestly Gotham does not offer me much improvement over Frodo even irrespective of the audio problem I have with Gotham. I will continue to test and give feedback on new versions of Linux Gotham on a spare MyGica ATV1200 and 520 box too, but wont switch my main home use box to it until the problems are all sorted with my audio mainly.

I won't go back to Android though. That is to me totally unnecessary and has a much inferior XBMC performance. Like most of my friends here I just do not want or need all that Android bloatware apps and other stuff thanks, as we all have that stuff and better on our iPhones, iPads and PCs of course. We really just need good stable movie, TV and music streaming to our TV systems as we normally get very well with the brilliant Linux XBMC.

Interesting technically is that I could not simply revert back to Linux Frodo 12.3 build of 2/1/14. It would not take th SD bootup card at all just leaving me in booting into the installed Linux Gotham, So I had to use the Revert back to Android 4.1 of last August and then flash to Linux Frodo 12.3, which all worked fine though of course I then had to restore my settings and my add-ons from a recent 12.3 XBMC Backup I had. BoBones or Biatsch will probably know the reason why I had to revert first to Android 4.1 as something I feel to do with the bootup loader Linux Gotham installs.. Anyway mega happy now with Linux Frodo 12.3 all back up and running but will go back to Gotham once it is completely fixed for Linux.
Raymw, Thanks for that, i also was running the latest Bobones compile of Gotham 13.1 with pretty much the same results as you, perhaps your right about the heat issue as i am located in St Lucia.
I have managed to revert to MyGiga 4.2.2 Android with Gotham 13.1 allthough first impressions are that it is noticable slower, will test a bit more but i suspect that i will folow the same path as you and go back to Linux and 12.3.
The latest build here is working amazing with my pioneer vsx 820. Pass through is perfect.

Quick question. For someone with android can they just directly flash with this build?
Yes Redi you should be able to flash directly from Android. I certainly flashed BoBones previous Linux Gotham 13.1 compile direct to a brand new MyGica ATV1200 box with Android install by default and that worked perfectly so unless BoBones says otherwise I think this latest excellent 18th June compile of his will work fine.

Glad to hear your passthrough is okay as you read above mine is not to my otherwise superb latest Denon AVR500 unit, though fine with Linux Frodo 12.3 and earlier. So my only important two gropes with Linux Gotham 13.1 is the passthorugh audio problem to my Denon AVR 500 and no WiFi working with the ATV520 with Broadcom WiFi. Maybe it gets the box a little hotter than Linux Frodo but cannot be certain on that and I do live in a hot climate in Thailand and not helped with my box domestically friendly placed in a glass fronted cabinet under the TV. Going to get a small cheap USB connected fan to help cool it when I next go into the local IT mega mall