Kodi Community Forum

Full Version: [HOW TO] KODI Linux on Amlogic TV Boxes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Onto it AuxBox and will install and test later on my spare 1200 and 520 boxes. Don't think I can test for true 1080 though as have not got that testing graphics file at the moment and cannot find the link to it without a long laborious search through this thread and no time for that right now.

To be honest I never found the upscaling issue much of a problem as from normal sitting distances on my 46" screen I find it difficult to see the difference anyway between 720 and true 1080 res. Sure bigger screens or sitting closer may result in being able to discern the difference but that does not apply to most of us at this time I reckon. This is why I have no interest in 4k Ultra HD as to discern that extra res then I reckon you need a 65" screen as a minimum or be sitting very very close to the screen. Only purpose of 4K to me is that we can then have passive 3D without the current poor visible 540 lines resolution it gives and that will be magic as so much brighter and vivid and effective than Active 3D.

Of course the move to OLED will be a huge improvement in picture quality but as yet those TVs are very very expensive and beyond most folks budget.

I think I've done it now! I seem to have locked up my ATV520 trying to update to the latest XDA Gotham. Screen went black during update and none of boot SD cards I've tried makes it respond. My TV is only 720p so I don't know whether the claim that this new version has a 1080p kernel has anything to do with this issue.

I think I should have done a factory reset from the update menu first. Do you think you could make a boot card that simply performes a factory reset/wipe and maybe even get me to the update menu? If that doesn't work, do you know where I can get a TTL cable so I can try that method?

I noticed your DropBox has been temporarily shut down because of too much traffic. You can PM me for my email and I can host what you come up with on my website. A factory wipe SD card would be a very handy tool for all of us, I think.

Hey tinker how did you try to flash the file

I copied all the files to SD, powered down, pushed the upgrade button, powered up and... nothing! I even lost video not switching on, but one of the Android reverts got that back. I use a smart HDMI switch that lets me know when the box turns on video. So, when I power up the box will switch video on but just to a black screen. I was running Bebones latest GitHub compile but I think it was XDA based.

I've tried every build that's worked so far, but I haven't been able to get the box back to Android in months so I've been progressing deeper and deeper into Linux/XBMC.

Hope that helps some.

Can you not get recovery menu up at all by holding the reset button on boot

(2014-06-29, 01:23)AuXBoX Wrote: [ -> ]Can you not get recovery menu up at all by holding the reset button on boot

Nope! Screen stays black. The TV is a 720p Sharp. The 1080p Android worked fine out of the box so I don't know if that's an issue here. I still get activity on the blue network light so I know the box is still 'alive' but the other two lights stay solid red.

have you tried this

My Hard Brick Fix

Downloading it now. Was this post here? I'll let you know how it goes.

Even if you can get to recovery to start with, then try to flash anything

No joy. I've used the SD card maker before and it didn't work that time either. I wonder if my SD slot isn't worn out with all the tinkering I've been doing.

Can you point out where I can get a TTL cable online? I can wait for it to come. I have a lot of data on how to talk to the box through a terminal.

You can get any usb to ttl serial cable, you might have to modify the connections a little, i had to on mine

Will this cable do?


Yeh that will do

I wouldn't have to mod that cable, right? Just take the box apart and plug the four loose cables into the connector inside. I have the Teraterm terminal program already, it'll see the box through the USB port of my computer?


[edit] Just ordered the cable from AdaFruit. Unless something comes up I'll just wait for it to get here. If another solution comes along, it'll still be handy for the next time I brick my box. Either way I'll pass on what I learn.

Well no problem here with you new compile AuxBox as it installed perfectly over the top of Bobones last compile and as expected kept all the configurations including set up shortcut icons too. This worked fine for both a 1200 and 520 box too. Not tried it straight onto a virginal Android new box yet but will maybe today.

Anyway this does not fix the Broadcom incompatibility issue with WiFi manager on the 520 box and also I still have my audio problem with the Denon AVR500 on both boxes with not recognizing the pass thought data stream and not auto switching to DD or DTS mode.

Okay video res is partly fixed as when I switch to 1080i or p my TV screen does switch to 1920 x 1080 60Hz but the video content output from the box seems to stay at 720p so I get a small about 25% of the screen picture of the XBMC confluence home screen or indeed any 1080 streaming content I play too. So still seems some work needed on this though for me not as urgent as the ATV520 Broadcom WiFi problem.as that would I think for most folk matter more.

Anyway I have to say how impressive I find you dev guys who do all this for the community here. Many thanks indeed. Glad if my feedback gives you even a tiny bit of help.