Kodi Community Forum

Full Version: XBMC.updatelibrary(Video) not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've been changing from using CEC to control XMBC to an infrared dongle and I have everything working except the update library button.

It pops up and says it's updating the library but doesn't actually add any new files. If I run the update command from the iPhone app it finds the new files and adds them to the library.

This is what I get in the debug logs.

***Logs Removed***

If I update on start-up, iPhone/iPad app or from the web console it works, the only thing that doesn’t work is the command XBMC.updatelibrary(Video). I rebuilt XBMC on a fresh SD card over the weekend and the button still doesn’t work.

Can anyone help as this is driving me nuts!
read the forum rules please.
don't post snippets on the forum and no snippets at all.
only full logs
I've edited the post to include full debug logs.
I thought I'd share my solution for other people in the same boat.

I was using this key id from my Harmony to start the update.

<key id="61952">XBMC.updatelibrary(Video)</key>

I changed it to this

<key id="323593">XBMC.updatelibrary(Video)</key>

and now it works.

So if you are having the same problem I had try mapping a few more keys to the function you want and test them all. I won't begin to try and explain why this happens but everything is now working as I want it.