Kodi Community Forum

Full Version: Several video plugin errors- related to the same source problem? ; help identify
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, dropping this over here as well in hopes it garners some attention.
I've come along ways in fixing some errors and plugins however I believe there's a singular issue causing the majority of the faults.
See below and please advise if anything is obvious :
--------------------

Hello,

I have several video.plugin failures and while I have reported a few to the appropriate threads/authors, I believe I am seeing a pattern with the errors in the logs.

This could have something to do with my MX2 being a cooked/pre built.

Here is a link to the most recent debug http://xbmclogs.com/show.php?id=101088
As you'll see in the log the following plugins are affected(there could be more). I've snipped an example from the tubeplus error to point out the directory lines.

tubeplus
TV Online
much movies
movie kingdom
motrosports replay the666sicco
IWO (Iwatch)
ITV (missing from log, see new log http://xbmclogs.com/show.php?id=101098)
ExPat
Easynews
skyaccese.se


14:50:32 T:1085947488 ERROR: - Error getting plugin://plugin.video.tubeplus/
14:50:32 T:1085947488 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.tubeplus/) failed
14:50:32 T:1085947488 DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/video/)
14:50:32 T:1085947488 DEBUG: ParentPath = []
14:50:32 T:1085947488 DEBUG: waiting for python thr
ead 27 (/storage/emulated/0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/plugin.video.tubeplus/default.py) to stop
14:50:32 T:1085947488 DEBUG: python thread 27 (/storage/emulated/0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/plugin.video.tubeplus/default.py) destructed

This may not be a relevant portion of the log - I was taking a guess.

If anyone would please have a look through and point out anything they think is problematic for any of these, thank you.
I've seen this signature several times, and it is not an official XBMC release:
Code:
Starting XBMC (12.0 Git:20130430-d9119f2), Platform: Linux (Android, 3.0.50 armv7l). Built on Sep 16 2013

Could you tell me where this comes from?
I don't know how to answer that other than I bought the box with everything installed on it. Whatever is on here is what I have been working with.
I have access to the people who did it, if you want me to relay that question to them?
Facts are:
- This version (12.0) is very old and outdated
- As we don't know what's in there, we cannot give support
- You have a sh...load of plugins I know nothing about which might cause your problem

Bottom-line: You'd better ask in your box support forum.
Thank you Koying.

If I were to start fresh, would I simply uninstall XBMC as an app; remove my user data (temporarily), install a new Frodo (or Gotham if I get brave) and reapply the user data? [I question whether any of the data binds itself to the client version and would spaz out if it could not find "12.0"]
(The repositories that came with this box will be lost, but I am told I can download them again as a courtesy from the supplier)

FYI I did previously try an upgrade to 12.2 but got the conflicting signature issue, so gave up.
(2013-12-24, 14:52)Saraya Wrote: [ -> ]FYI I did previously try an upgrade to 12.2 but got the conflicting signature issue, so gave up.
Yep, that's what happen with unofficial builds whose owner was even too lazy to change the package name Wink

Indeed, If you want to start anew, save the data (/sdcard/Android/data/org.xbmc.xbmc), uninstall the unofficial one, restore and install a Gotham nightly.
I understand.

12.2 up and running - all previously listed plugins still failing.
Log here http://xbmclogs.com/show.php?id=101437

Thanks again for your time today!
(2013-12-24, 16:22)Saraya Wrote: [ -> ]I understand.

12.2 up and running - all previously listed plugins still failing.
Log here http://xbmclogs.com/show.php?id=101437

Thanks again for your time today!

Try changing this in the addon.xml file in the plugin's directory in user/username/appdata/roaming/xbmc/addons/addonfolder
from <import addon="xbmc.python" version="2.1.0"/> to <import addon="xbmc.python" version="2.0"/>
All those plugins you mentioned have trouble with the new python in the xbmc nightlies and only work on XBMC 12.2 if you don't change the above.

Try the latest nightly builds and reinstall the plugins from scratch, as you might have outdated versions of the plugins.
This is not an XBMC issue, as those developers of the plugins should fix their plugins, and will only do it when the new XBMC Gotham Final is released.
(2013-12-24, 18:07)mo123 Wrote: [ -> ]
(2013-12-24, 16:22)Saraya Wrote: [ -> ]I understand.

12.2 up and running - all previously listed plugins still failing.
Log here http://xbmclogs.com/show.php?id=101437

Thanks again for your time today!

Try changing this in the addon.xml file in the plugin's directory in user/username/appdata/roaming/xbmc/addons/addonfolder
from <import addon="xbmc.python" version="2.1.0"/> to <import addon="xbmc.python" version="2.0"/>
All those plugins you mentioned have trouble with the new python in the xbmc nightlies and only work on XBMC 12.2 if you don't change the above.

Try the latest nightly builds and reinstall the plugins from scratch, as you might have outdated versions of the plugins.
This is not an XBMC issue, as those developers of the plugins should fix their plugins, and will only do it when the new XBMC Gotham Final is released.
that is totally unrelated to the issue
(2013-12-24, 18:11)Martijn Wrote: [ -> ]
(2013-12-24, 18:07)mo123 Wrote: [ -> ]
(2013-12-24, 16:22)Saraya Wrote: [ -> ]I understand.

12.2 up and running - all previously listed plugins still failing.
Log here http://xbmclogs.com/show.php?id=101437

Thanks again for your time today!

Try changing this in the addon.xml file in the plugin's directory in user/username/appdata/roaming/xbmc/addons/addonfolder
from <import addon="xbmc.python" version="2.1.0"/> to <import addon="xbmc.python" version="2.0"/>
All those plugins you mentioned have trouble with the new python in the xbmc nightlies and only work on XBMC 12.2 if you don't change the above.

Try the latest nightly builds and reinstall the plugins from scratch, as you might have outdated versions of the plugins.
This is not an XBMC issue, as those developers of the plugins should fix their plugins, and will only do it when the new XBMC Gotham Final is released.
that is totally unrelated to the issue

As far as I'm aware I have all the latest repositories and addons.
Out of curiosity I looked in the .xml files and some of them are python version 1.0, others 2.1.0 and the rest 2.0
I also have a generic python.py script failure that comes up when browsing the video menus - cannot find it in the log.

Could it be a lib file issue? I tried to update it and it said 'sorry failed.'
Pending.
(2013-12-24, 21:15)Saraya Wrote: [ -> ]Bad update ; video playback has dropped to about 10-15 fps under this 12.2 ;/

Try this build
https://www.facebook.com/permalink.php?s...4459966022
Also try to search with Google for AMLogic builds of XBMC.
That's very kind of you, I will check it out asap.
Does this mean my box is AMLogic?
I hear Gotham has video decoding support - might that be the culprit? [Tried the Gotham, same problem]
If you read previous comment here about blackscreen - solved, was firmware related - have right version now.
MX2 with firmware 1.16 required modified XBMC under title : mx2-xbmc12.2d-launcher.apk


Mo thanks a bunch for putting me on the right track and salvaging this.


Mash up is the only one not playing ball at the moment. Oh well I guess.
SO much better than it was before!

One last thing - my favorites menu has disappeared. I think it used to be a third party as Ace doesn't have it's own. Any idea what it was called?
Hello again, wanted to update this as I made some forward movement thanks to Mo.

The rest of the plugins - for the most part - were failing due to a dependency on advertising marketing addon that was disabled.