Kodi Community Forum

Full Version: TVheadend HTSP client - Connection lost problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi, I hope someone can help or point me in the right direction.

I've installed tvheadend v3.4.27 and was able to connected successfully to my tvcard. I am running Ubuntu 13.10.

Under xbmc I looked for settings - addons - to enable my pvr client as most installation guidelines seem to state that pvr addons are installed by default. Going round in circles a few times, today I added the pvr addon manually from a zip file (pvr.hts-linux-x86_64.zip) and I was able to configure it with local host and user name and password.

But immediately a message appears stating TVheadend HTSP client: connection lost.

What is this, as I am able to log into the tvheadend admin web page successfully with the same credentials.

So close and yet so far.

Thanks, Frank

oh, the xbmc log file shows this
Quote:19:43:27 T:140283295561472 NOTICE: AddOnLog: Tvheadend HTSP Client: CHTSPConnection - SendGreeting - connection opened to 'HTS Tvheadend 3.4.27~gfbda802~raring', protocol v10
19:43:27 T:140283295561472 ERROR: AddOnLog: Tvheadend HTSP Client: CHTSPConnection - Auth - failed to get a reply from the auth command
19:43:27 T:140283295561472 ERROR: AddOnLog: Tvheadend HTSP Client: Connect - failed to authenticate
19:43:27 T:140283295561472 ERROR: AddOnLog: Tvheadend HTSP Client: ReadResult - 'enableAsyncMetadata' failed - not connected
19:43:27 T:140283295561472 ERROR: AddOnLog: Tvheadend HTSP Client: Open - couldn't send EnableAsync().
19:43:27 T:140283295561472 ERROR: ADDON: Dll Tvheadend HTSP Client - Client returned bad status (1) from Create and is not usable
19:43:27 T:140283295561472 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 1

I found another post in this forum http://forum.xbmc.org/showthread.php?tid=121353&page=2 suggesting to:

In tvheadend, go into Access control and in the User and Password boxes just put a * and enable streaming. Save that, then go into xbmc and just delete the username/password entries. It should then connect straight up .

Makes no change. Still the same failed authentication.
Remove the addon and use "apt-get install xbmc-pvr-addons" to install instead. It looks like you have a version mismatch or something.

Regarding the addons, they are only installed by default on Windows. On Linux they're in separate packages which like I mentioned can be installed using apt-get.
Thanks Negge,

That is how I tried to install pvr addons originally. Didn't work as shown below. I picked a zipped version (v1.6.9 Lars op den Kamp) from the net and installed that manually into xbmc.

Quote:[email protected]minty ~ $ sudo apt-get install xbmc-pvr-addons
[sudo] password for cookf:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package xbmc-pvr-addons
[email protected]minty ~ $

I don't understand this as xbmc installed without issues. Is there some ppa I need to add?
What's the output of "apt-cache search tvheadend"?

Also what version of XBMC are you using ("apt-cache policy xbmc")?
Thanks. I'll check as soon as I am home (18:00 GMT).
The output is
Quote:[email protected]:~$ sudo apt-cache search tvheadend
[sudo] password for cookf:
tvheadend - Tvheadend
tvheadend-dbg - Debug symbols for Tvheadend
[email protected]:~$
you've still got a username and/or password set in the add-on config, or that code wouldn't be called at all. remove them both
You don't have the package in your repository, I don't know why that happened. I guess you should try to follow opdenkamp's advice.
Sorry, there is nothing in the user name and password box under tvheadend config. Checked it, backspaced and pressed ok. I've also set it back to default settings; still the same message of "connection lost".
I use version xbmc addon V1.6.9. with TVHeadend V3.4.27 on ubuntu 13.10.

TVheadend initially did not show any entry under Access Control. In an attempt to get around the "connection lost" problem I added a single entry:

Quote:[email protected]:/home/hts/.hts/tvheadend$ sudo cat accesscontrol/2
"enabled": 1,
"username": "*",
"password": "*",
"comment": "New entry",
"prefix": ",::/0",
"streaming": 1,
"dvr": 1,
"dvrallcfg": 0,
"webui": 0,
"admin": 0,
"id": "2"

Quote:12:46:15 T:139696285935360 ERROR: ADDON: Dll Tvheadend HTSP Client - Client returned bad status (1) from Create and is not usable
12:46:15 T:139696285935360 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 1

I am probably on the wrong track but is this a permissions thing?
Quote:[email protected]:/home/hts/.hts/tvheadend$ sudo ls -al accesscontrol/
total 12
drwx------ 2 hts video 4096 Jan 4 13:18 .
drwxr-xr-x 9 hts hts 4096 Jan 2 19:41 ..
-rwx------ 1 hts video 191 Jan 4 13:18 2

Where do I find the tvheadend logs?
Is there a way of checking tvheadend without xbmc (e.g. vlc player)?
Most interesting. Trying to play with VLC media player and checking the xbmc port settings, I noticed that I didn't get the connection error. Checking liveTV next, I was able to watch and switch TV. Why? Don't know, but a big step for man kind and this family in particular who have been waiting for the promised land for 4 weeks.

Thanks, no doubt I'll return.
Ok, it worked for 1 hour. I watched and recorded tv successfully. I looked at the epg functions and played back some home recordings.

Next back to TV, I get an error message: TVHeadend HTSP Client: No service enabled.

What is causing this?
I can't test the tv-card as VLC has stopped manually viewing TV channels since TVHeadend was installed.
First, how to I disable TVheadend to check that my TV card is ok?
Any reason why you're not using a username and password like everyone else? I don't think you would have had this problem then.
i'm not using username/pass for tvheadend. don't assume you're "everyone else" Smile the error that you're seeing now isn't related to username/pass
@opdenkamp it seems you're right :-) I have tvheadend exposed to the internet so going passwordless isn't really an option.
I have a Raspberry with tvheadend backend running and a Sundtec DVB-C stick.
When I connect from my PC with xbmc and tvheadend frontend it works for several minuets fine and than I get the same error: connection lost.
I assumed this happens because of the Raspberrys bad network performance because (W)LAN is done via USB.

Are frontend and backend running on the same machine or are they connecting via network? Have you compared LAN and WLAN? Same behavior?

I have one username in tvheadend with streaming privileges and the connection works fine (until it crashes afeter several minutes).
Pages: 1 2