Kodi Community Forum

Full Version: VNSI5 - undefined symbol: _ZN11cRecordings9DelByNameEPKc
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I recompiled VNSI5 server plugin from opdenkamp master (git commit 9021115ddb) as I was still running the initial commit. It seemed to compile fine - compile log > http://pastebin.com/QZBybN7f

I ran:
sudo make clean
make install

vdr -V
Quote:vdr: /usr/lib/vdr/plugins/libvdr-vnsiserver5.so.2.0.0: undefined symbol: _ZN11cRecordings9DelByNameEPKc
vdr (2.0.1/2.0.0) - The Video Disk Recorder
hmm, no idea. I have not heard any issues related to this one. where do you get vdr from?

Its been running VNSI4 and then upgraded to 5 when you first released it. Its only shown this error since pulling in your recent (last month of so of commits) changes today. Just tried using your vnsi5 branch on the off chance it would be fixed, same problem im afraid.
There was no change to this symbol. Maybe the source package provided by yavdr has an issue or is not for your version.
i have no idea, I have forked your repo and reset head right back to VNSI4 and I still get that error message
either your vdr sources don't match the version of vdr you run or the provided vdr.pc is wrong.
Removed the ppa and reinstalled vdr from another ppa and it compiled fine. I think what had happens is I've accidentally updated my server to saucy and the ppa didn't have packages for saucy