Kodi Community Forum

Full Version: TWiT
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
Hello everybody, thanks for reporting your issues. I've been working hard on a new release and am hoping to get a few to help test this out.

Version 2.1.2
testing/beta release
fix script errors on systems running python 2.6(android)
fix for shows "Radio Leo" and "All TWiT.tv Shows"
we now use the RSS feed for the initial episode directory of a show

Download and use the install from zip method -> https://github.com/divingmule/plugin.vid...-2.1.2.zip

Report back if you have any issues.
First run - works great!

I will test it thoroughly during next few days. Thank you!

Edit: 1. bug - I can't enter Triangulation from main menu, error from log:

Code:
http://pastebin.com/raw/Gk36kBri
(2016-02-24, 22:23)letac Wrote: [ -> ]First run - works great!

I will test it thoroughly during next few days. Thank you!

Edit: 1. bug - I can't enter Triangulation from main menu, error from log:

Code:
http://pastebin.com/raw/Gk36kBri

Good catch, thanks! That one is an easy fix. -> https://github.com/divingmule/plugin.vid...891ee05daa
(2016-02-25, 11:13)divingmule Wrote: [ -> ]That one is an easy fix.

Yeap, its fixed now, tnx!
Thank you divingmule, for fixing your TWiT plug-in.
TWIT Live is not working, since yesterday.

When I click on "TWIT Live", nothing happens. Tested on Windows and Android platform.
(2016-03-12, 18:32)letac Wrote: [ -> ]TWIT Live is not working, since yesterday.

When I click on "TWIT Live", nothing happens. Tested on Windows and Android platform.

Yep Twit Live not working here either.
(2016-03-12, 18:40)gate1975mlm Wrote: [ -> ]
(2016-03-12, 18:32)letac Wrote: [ -> ]TWIT Live is not working, since yesterday.

When I click on "TWIT Live", nothing happens. Tested on Windows and Android platform.

Yep Twit Live not working here either.

Yeah I've got this problem plus none of the prerecorded links work at all. Can't even get to a list of episodes. I've got the Feb 20th compiled version of Jarvis. Can't remember if that's when the problem started though.
I think the problem is with several of the stream sources. You can go into the plugin settings and change the stream to bitgravity to get live working again. ustream and flowsoft.biz are not working.
(2016-03-13, 16:01)Shryp Wrote: [ -> ]I think the problem is with several of the stream sources. You can go into the plugin settings and change the stream to bitgravity to get live working again. ustream and flowsoft.biz are not working.

None of the streams seems to work for me
I am dead in the water this morning also.. I am not sure when it started as I didn't watch twit yesterday..

The add-on says script error when loading. I have also now tried with the updated version of the add-on.. same result.

Not sure what changed. I am running it on android FireTV version 1. Using the zip version posted above.

Update: Just to make sure, I downloaded the Github version.. Still resulted in Script error on start up.
Update. I tested the above with a linux laptop and kodi 16 with a fresh config file. (I never actually set Kodi up on this since I installed Manjaro.) Worked fine last night and still works fine now.

My main desktop with Windows 7 and my library setup with twit and youtube apps causes a script error on startup. I even tried deleting the twit addon and all settings for it from the add_on folder and reinstalling fresh and same issue. I have not tried a fresh Kodi profile to see if that helps yet. *Same issue occurs when I close Kodi, rename my Kodi userdata folder and let it create a brand new profile.

Both systems are using Kodi 16.0. The windows one is the exe downloaded from here and the Manjaro one is from the official Manjaro repository.

Code:
17:01:17 T:4664 WARNING: JSONRPC: Could not parse type "Setting.Details.SettingList"
17:01:17 T:4664  NOTICE: ActiveAE DSP - starting
17:01:17 T:4664  NOTICE: initialize done
17:01:17 T:4664  NOTICE: Running the application...
17:01:17 T:4664  NOTICE: starting upnp client
17:01:17 T:1984  NOTICE: ES: Starting UDP Event server on 0.0.0.0:9777
17:01:17 T:1984  NOTICE: UDP: Listening on port 9777
17:01:35 T:4856   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: expected string or buffer
                                            Traceback (most recent call last):
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 444, in <module>
                                                display_main()
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 100, in display_main
                                                display_shows('active')
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 78, in display_shows
                                                shows = cache.cacheFunction(shows_cache)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.common.plugin.cache\lib\StorageServer.py", line 570, in cacheFunction
                                                ret_val = funct(*args)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 69, in shows_cache
                                                'active': parse_shows_to_list(base_url + '/shows?shows_active=1'),
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 59, in parse_shows_to_list
                                                convertEntities=BeautifulSoup.HTML_ENTITIES)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1522, in __init__
                                                BeautifulStoneSoup.__init__(self, *args, **kwargs)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1147, in __init__
                                                self._feed(isHTML=isHTML)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1171, in _feed
                                                smartQuotesTo=self.smartQuotesTo, isHTML=isHTML)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1773, in __init__
                                                self._detectEncoding(markup, isHTML)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1918, in _detectEncoding
                                                '^<\?.*encoding=[\'"](.*?)[\'"].*\?>').match(xml_data)
                                            TypeError: expected string or buffer
                                            -->End of Python script error report<--
17:01:35 T:4664   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.twit/?content_type=video
17:01:35 T:4664   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.twit/?content_type=video) failed
17:01:38 T:1216  NOTICE: [plugin.video.youtube] Running: YouTube (5.1.20.1) on Jarvis (16.0) with Python 2.7.8
17:02:25 T:4664  NOTICE: Log level changed to "LOG_LEVEL_DEBUG_FREEMEM"
17:02:25 T:4664  NOTICE: Enabled debug logging due to GUI setting. Level 2.
17:02:25 T:4664   DEBUG: ------ Window Init () ------
17:02:31 T:4664   DEBUG: Keyboard: scancode: 0x0e, sym: 0x0008, unicode: 0x0008, modifier: 0x0
17:02:31 T:4664   DEBUG: CInputManager::OnKey: backspace (0xf008) pressed, action is Back
17:02:31 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Deactivate
17:02:32 T:4664   DEBUG: ------ Window Deinit (SettingsCategory.xml) ------
17:02:32 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Activate new
17:02:32 T:4664   DEBUG: ------ Window Init (Settings.xml) ------
17:02:32 T:4300   DEBUG: Thread JobWorker start, auto delete: true
17:02:33 T:4664   DEBUG: Keyboard: scancode: 0x0e, sym: 0x0008, unicode: 0x0008, modifier: 0x0
17:02:33 T:4664   DEBUG: CInputManager::OnKey: backspace (0xf008) pressed, action is Back
17:02:33 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Deactivate
17:02:34 T:4664   DEBUG: ------ Window Deinit (Settings.xml) ------
17:02:34 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Activate new
17:02:34 T:4664   DEBUG: ------ Window Init (Home.xml) ------
17:02:35 T:4664   DEBUG: Keyboard: scancode: 0x4b, sym: 0x0114, unicode: 0x0000, modifier: 0x0
17:02:35 T:4664   DEBUG: CInputManager::OnKey: left (0xf082) pressed, action is Left
17:02:36 T:4664   DEBUG: Keyboard: scancode: 0x4b, sym: 0x0114, unicode: 0x0000, modifier: 0x0
17:02:36 T:4664   DEBUG: CInputManager::OnKey: left (0xf082) pressed, action is Left
17:02:37 T:4664   DEBUG: SECTION:UnloadDelayed(DLL: special://xbmcbin/system/ImageLib.dll)
17:02:37 T:4664   DEBUG: Keyboard: scancode: 0x4b, sym: 0x0114, unicode: 0x0000, modifier: 0x0
17:02:37 T:4664   DEBUG: CInputManager::OnKey: left (0xf082) pressed, action is Left
17:02:38 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:02:38 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:02:38 T:4664   DEBUG: Keyboard: scancode: 0x4b, sym: 0x0114, unicode: 0x0000, modifier: 0x0
17:02:38 T:4664   DEBUG: CInputManager::OnKey: left (0xf082) pressed, action is Left
17:02:39 T:4664   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
17:02:39 T:4664   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
17:02:39 T:4664   DEBUG: Activating window ID: 10025
17:02:39 T:4664   DEBUG: ------ Window Deinit (Home.xml) ------
17:02:39 T:4664   DEBUG: ------ Window Init (MyVideoNav.xml) ------
17:02:39 T:4664   DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/video/)
17:02:39 T:4664   DEBUG:   ParentPath = [addons://sources/video/]
17:02:39 T:4896   DEBUG: Thread BackgroundLoader start, auto delete: false
17:02:39 T:4896   DEBUG: Thread BackgroundLoader 4896 terminating
17:02:39 T:5012   DEBUG: Thread JobWorker start, auto delete: true
17:02:41 T:4664   DEBUG: Keyboard: scancode: 0x48, sym: 0x0111, unicode: 0x0000, modifier: 0x0
17:02:41 T:4664   DEBUG: CInputManager::OnKey: up (0xf080) pressed, action is Up
17:02:41 T:4664   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
17:02:42 T:4664   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
17:02:42 T:4664   DEBUG: CGUIMediaWindow::GetDirectory (plugin://plugin.video.twit/?content_type=video)
17:02:42 T:4664   DEBUG:   ParentPath = [addons://sources/video]
17:02:42 T:4300   DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin TWiT('plugin://plugin.video.twit/','3','?content_type=video')
17:02:42 T:4300   DEBUG: XFILE::CPluginDirectory::WaitOnScriptResult - waiting on the TWiT (id=6) plugin...
17:02:42 T:4360   DEBUG: Thread LanguageInvoker start, auto delete: false
17:02:42 T:4360    INFO: initializing python engine.
17:02:42 T:4360   DEBUG: CPythonInvoker(6, C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py): start processing
17:02:42 T:4360   DEBUG: -->Python Interpreter Initialized<--
17:02:42 T:4360   DEBUG: CPythonInvoker(6, C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py): the source file to load is "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py"
17:02:42 T:4360   DEBUG: CPythonInvoker(6, C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py): setting the Python path to C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit;C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.common.plugin.cache\lib;C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib;C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.feedparser\lib;C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.parsedom\lib;C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.simple.downloader\lib;C:\Program Files (x86)\Kodi\system\python\DLLs;C:\Program Files (x86)\Kodi\system\python\Lib;C:\Program Files (x86)\Kodi\python27.zip;C:\Program Files (x86)\Kodi\system\python\lib\plat-win;C:\Program Files (x86)\Kodi\system\python\lib\lib-tk;C:\Program Files (x86)\Kodi;C:\Program Files (x86)\Kodi\system\python;C:\Program Files (x86)\Kodi\system\python\lib\site-packages
17:02:42 T:4360   DEBUG: CPythonInvoker(6, C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py): entering source directory C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit
17:02:42 T:4360   DEBUG: CPythonInvoker(6, C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py): instantiating addon using automatically obtained id of "plugin.video.twit" dependent on version 2.1.0 of the xbmc.python api
17:02:42 T:4360   DEBUG: [plugin.video.twit-2.1.3]: Get root directory
17:02:42 T:4360   DEBUG: LocalizeStrings: no strings.po file exist at C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\resources\language\English, fallback to strings.xml
17:02:42 T:4664   DEBUG: ------ Window Init (DialogBusy.xml) ------
17:02:42 T:4360   DEBUG: [plugin.video.twit-2.1.3]: We failed to open "https://twit.tv/shows?shows_active=1".
17:02:42 T:4360   DEBUG: [plugin.video.twit-2.1.3]: We failed to reach a server.
17:02:42 T:4360   DEBUG: [plugin.video.twit-2.1.3]: Reason: [Errno 1] _ssl.c:510: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure
17:02:42 T:4360   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: expected string or buffer
                                            Traceback (most recent call last):
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 444, in <module>
                                                display_main()
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 100, in display_main
                                                display_shows('active')
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 78, in display_shows
                                                shows = cache.cacheFunction(shows_cache)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.common.plugin.cache\lib\StorageServer.py", line 570, in cacheFunction
                                                ret_val = funct(*args)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 69, in shows_cache
                                                'active': parse_shows_to_list(base_url + '/shows?shows_active=1'),
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\plugin.video.twit\default.py", line 59, in parse_shows_to_list
                                                convertEntities=BeautifulSoup.HTML_ENTITIES)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1522, in __init__
                                                BeautifulStoneSoup.__init__(self, *args, **kwargs)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1147, in __init__
                                                self._feed(isHTML=isHTML)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1171, in _feed
                                                smartQuotesTo=self.smartQuotesTo, isHTML=isHTML)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1773, in __init__
                                                self._detectEncoding(markup, isHTML)
                                              File "C:\Users\Geoff\AppData\Roaming\Kodi\addons\script.module.beautifulsoup\lib\BeautifulSoup.py", line 1918, in _detectEncoding
                                                '^<\?.*encoding=[\'"](.*?)[\'"].*\?>').match(xml_data)
                                            TypeError: expected string or buffer
                                            -->End of Python script error report<--
17:02:42 T:4664   DEBUG: ------ Window Init (DialogKaiToast.xml) ------
17:02:42 T:4360    INFO: Python script stopped
17:02:42 T:4360   DEBUG: Thread LanguageInvoker 4360 terminating
17:02:42 T:4300   DEBUG:  XFILE::CPluginDirectory::WaitOnScriptResult - plugin exited prematurely - terminating
17:02:42 T:4664   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.twit/?content_type=video
17:02:42 T:4664   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.twit/?content_type=video) failed
17:02:42 T:4664   DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/video)
17:02:42 T:4664   DEBUG:   ParentPath = [addons://sources/]
17:02:42 T:4228   DEBUG: Thread BackgroundLoader start, auto delete: false
17:02:42 T:4228   DEBUG: Thread BackgroundLoader 4228 terminating
17:02:43 T:4664   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
17:02:46 T:4664   DEBUG: Keyboard: scancode: 0x0e, sym: 0x0008, unicode: 0x0008, modifier: 0x0
17:02:46 T:4664   DEBUG: CInputManager::OnKey: backspace (0xf008) pressed, action is Back
17:02:46 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Deactivate
17:02:46 T:4664   DEBUG: ------ Window Deinit (MyVideoNav.xml) ------
17:02:46 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Activate new
17:02:46 T:4664   DEBUG: ------ Window Init (Home.xml) ------
17:02:48 T:4664   DEBUG: ------ Window Deinit (DialogKaiToast.xml) ------
17:02:50 T:4664   DEBUG: Keyboard: scancode: 0x4b, sym: 0x0114, unicode: 0x0000, modifier: 0x0
17:02:50 T:4664   DEBUG: CInputManager::OnKey: left (0xf082) pressed, action is Left
17:02:51 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:02:51 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:02:52 T:4664   DEBUG: Keyboard: scancode: 0x4b, sym: 0x0114, unicode: 0x0000, modifier: 0x0
17:02:52 T:4664   DEBUG: CInputManager::OnKey: left (0xf082) pressed, action is Left
17:02:52 T:4664   DEBUG: Keyboard: scancode: 0x4b, sym: 0x0114, unicode: 0x0000, modifier: 0x0
17:02:52 T:4664   DEBUG: CInputManager::OnKey: left (0xf082) pressed, action is Left
17:02:54 T:4664   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
17:02:54 T:4664   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
17:02:54 T:4664   DEBUG: Activating window ID: 10007
17:02:54 T:4664   DEBUG: ------ Window Deinit (Home.xml) ------
17:02:54 T:4664   DEBUG: ------ Window Init (SettingsSystemInfo.xml) ------
17:02:54 T:4664    INFO: Loading skin file: SettingsSystemInfo.xml, load type: KEEP_IN_MEMORY
17:02:54 T:4300    INFO: XCURL::DllLibCurlGlobal::easy_aquire - Created session to http://www.msftncsi.com
17:02:56 T:4664   DEBUG: Keyboard: scancode: 0x0e, sym: 0x0008, unicode: 0x0008, modifier: 0x0
17:02:56 T:4664   DEBUG: CInputManager::OnKey: backspace (0xf008) pressed, action is Back
17:02:56 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Deactivate
17:02:56 T:4664   DEBUG: ------ Window Deinit (SettingsSystemInfo.xml) ------
17:02:56 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Activate new
17:02:56 T:4664   DEBUG: ------ Window Init (Home.xml) ------
17:02:57 T:4664   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
17:02:57 T:4664   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
17:02:57 T:4664   DEBUG: Activating window ID: 10004
17:02:58 T:4664   DEBUG: ------ Window Deinit (Home.xml) ------
17:02:58 T:4664   DEBUG: ------ Window Init (Settings.xml) ------
17:02:59 T:4664   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
17:02:59 T:4664   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
17:02:59 T:4664   DEBUG: Activating window ID: 10016
17:02:59 T:4664   DEBUG: ------ Window Deinit (Settings.xml) ------
17:02:59 T:4664   DEBUG: ------ Window Init (SettingsCategory.xml) ------
17:03:01 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:01 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:01 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:01 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:02 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:02 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:02 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:02 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:02 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:02 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:02 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:02 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:03 T:4664   DEBUG: Keyboard: scancode: 0x48, sym: 0x0111, unicode: 0x0000, modifier: 0x0
17:03:03 T:4664   DEBUG: CInputManager::OnKey: up (0xf080) pressed, action is Up
17:03:03 T:4664   DEBUG: Keyboard: scancode: 0x4d, sym: 0x0113, unicode: 0x0000, modifier: 0x0
17:03:03 T:4664   DEBUG: CInputManager::OnKey: right (0xf083) pressed, action is Right
17:03:04 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:04 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:04 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:04 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:05 T:4664   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
17:03:05 T:4664   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
17:03:05 T:4664   DEBUG: Activating window ID: 10050
17:03:05 T:4664   DEBUG: ------ Window Deinit (SettingsCategory.xml) ------
17:03:05 T:4664   DEBUG: ------ Window Init (EventLog.xml) ------
17:03:05 T:4664   DEBUG: CGUIMediaWindow::GetDirectory (events://)
17:03:05 T:4664   DEBUG:   ParentPath = []
17:03:05 T:4664   DEBUG: SECTION:LoadDLL(special://xbmcbin/system/ImageLib.dll)
17:03:07 T:4664   DEBUG: Keyboard: scancode: 0x0e, sym: 0x0008, unicode: 0x0008, modifier: 0x0
17:03:07 T:4664   DEBUG: CInputManager::OnKey: backspace (0xf008) pressed, action is Back
17:03:07 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Deactivate
17:03:07 T:4664   DEBUG: ------ Window Deinit (EventLog.xml) ------
17:03:07 T:4664   DEBUG: CGUIWindowManager::PreviousWindow: Activate new
17:03:07 T:4664   DEBUG: ------ Window Init (SettingsCategory.xml) ------
17:03:08 T:4664   DEBUG: Keyboard: scancode: 0x48, sym: 0x0111, unicode: 0x0000, modifier: 0x0
17:03:08 T:4664   DEBUG: CInputManager::OnKey: up (0xf080) pressed, action is Up
17:03:09 T:4664   DEBUG: Keyboard: scancode: 0x48, sym: 0x0111, unicode: 0x0000, modifier: 0x0
17:03:09 T:4664   DEBUG: CInputManager::OnKey: up (0xf080) pressed, action is Up
17:03:10 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:10 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:10 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:10 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:10 T:4664   DEBUG: Keyboard: scancode: 0x50, sym: 0x0112, unicode: 0x0000, modifier: 0x0
17:03:10 T:4664   DEBUG: CInputManager::OnKey: down (0xf081) pressed, action is Down
17:03:11 T:4664   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
17:03:11 T:4664   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
17:03:11 T:4664  NOTICE: Disabled debug logging due to GUI setting. Level 0.
17:03:11 T:4664  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
Same for me, TWit add-on is broke for me. Both addons, actually - the older TWiT addon 2.1.3 and the newer TWiT API. Both worked before I upgraded from Isengard to Jarvis yesterday.

Log here: http://pastebin.com/3dEtJfwm

tried the API first (yes, I have a key), then tried the non-API version. Both fail.

To my untrained eye, it looks like this is the line that is failing:
https://twit.tv/api/v1.0/shows?shows_active=1

So is this a problem at TWiT's end? Putting that URL in a browser brings back a 404 ...
Everything seems to be back to normal this morning, for me. I don't know whats going on but the website and API has been down several times over the past week or so.

Hopefully they have it sorted out.
(2016-03-14, 13:34)divingmule Wrote: [ -> ]Everything seems to be back to normal this morning, for me. I don't know whats going on but the website and API has been down several times over the past week or so.

Hopefully they have it sorted out.

Yea, seems to be working again on my desktop. Ustream and Flowsoft are not working, but Bitgravity is working for LIVE. I was watching live over the weekend on a computer and did hear them say Flowsoft was having issues on there end.

For the next update would it be possible to have a setting to make it pick a different stream for LIVE of the first one fails to load?
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14