Kodi Community Forum

Full Version: [xbmc-git] vsync regression?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I had the exact same issue yesterday when I updated my packages on ArchLinux and went from nvidia driver version 331.20 to 331.38.

XBMC ran great for years on my Zotac ION-ITX board with Intel Atom CPU and Geforce 9400 GPU on ArchLinux.
With the new driver I had tearing in 24p. Same settings for ages, vsync off, adjust refresh rate to match video, vdpau activated.

With adjust refresh rate deactivated, it worked fine in 60hz, but 24p produced tearing, even when setting XBMC fixed with 24p.

So I downgraded the nvidia package back to 331.20 and thank god the tearing was gone. Unfortunately I cannot provide a xbmc.log from that state of my system.

XBMC version: 12.3
Kernel: 3.12.7
older intel drivers do triple buffering by default and have a bug when vsync in xbmc is set to always on. Set it to "let driver decide"
(2014-01-15, 23:02)m1m1 Wrote: [ -> ]I had the exact same issue yesterday when I updated my packages on ArchLinux and went from nvidia driver version 331.20 to 331.38.

XBMC ran great for years on my Zotac ION-ITX board with Intel Atom CPU and Geforce 9400 GPU on ArchLinux.
With the new driver I had tearing in 24p. Same settings for ages, vsync off, adjust refresh rate to match video, vdpau activated.

With adjust refresh rate deactivated, it worked fine in 60hz, but 24p produced tearing, even when setting XBMC fixed with 24p.

So I downgraded the nvidia package back to 331.20 and thank god the tearing was gone. Unfortunately I cannot provide a xbmc.log from that state of my system.

XBMC version: 12.3
Kernel: 3.12.7
I have exactly the same issue with 331.38
331.38 drivers >>>apparently<<< dont handle vsync properly try 319.x or 331.20
(2014-01-15, 23:02)m1m1 Wrote: [ -> ]I had the exact same issue yesterday when I updated my packages on ArchLinux and went from nvidia driver version 331.20 to 331.38.

XBMC ran great for years on my Zotac ION-ITX board with Intel Atom CPU and Geforce 9400 GPU on ArchLinux.
With the new driver I had tearing in 24p. Same settings for ages, vsync off, adjust refresh rate to match video, vdpau activated.

With adjust refresh rate deactivated, it worked fine in 60hz, but 24p produced tearing, even when setting XBMC fixed with 24p.

So I downgraded the nvidia package back to 331.20 and thank god the tearing was gone. Unfortunately I cannot provide a xbmc.log from that state of my system.

XBMC version: 12.3
Kernel: 3.12.7

I also had the same thing happen to me running arch after upgrading, but no nvidia just intel HD4000 graphics. xbmc 12.3 + 3.12.2. Enabling tearfree option in xorg solved it, just strange that needed to be done.
https://bbs.archlinux.org/viewtopic.php?...0#p1377570

It's not just me. TearFree is the only way to get it to not tear now.
For those running arch this package fixes it for me. https://bbs.archlinux.org/viewtopic.php?id=176651
I'm also in the same boat with the Intel chipset.

TearFree option makes everything too slow.

I found removing Option "AccelMethod" "sna" and all other options from "Device" would limit the tearing region to a small portion on the top of the screen. It's not ideal, but at least the video is watchable.
I decided to manually compile libSDL on my debian machine and merge the patches from https://aur.archlinux.org/packages/sdl-nobackingstore/ and this fixed all my tearing problems. Thank you for posting the link, touser!

basic steps:
# apt-get source libsdl1.2
# download and extract https://aur.archlinux.org/packages/sd/sd...ore.tar.gz
# patch -p1 < sdl-nobackingstore/backingstore_on_demand.diff
# patch -p0 < sdl-nobackingstore/sdl_x11sym.patch
# make
# make install

Make sure your system libSDL files are replaced with the new ones.
The first step is not needed, it should perhaps be: apt-get build-dep libsdl1.2
Ive noticed tearing in xbmc too after upgrading to 14.04 tahr (kernel 3.13 + nvidia331.38 + gotham), with vsync set to enabled and let driver decide. Disabling Composite in xorg.conf solves the tearing, but breaks steam big picture mode. Im having trouble downgrding drivers as installing non 331 drivers pulls in 331 as a dependency and 331 gets used, plus the driver from the nvidia binaries dont load. But I havent noticed tearing in xbmc before with previous nvidia driver versions (I keep them up to date) and there is no tearing in steam/chromium/myth-frontend.

Debug log with 331.38 nvidia drivers http://paste.ubuntu.com/7012511/

EDIT: Still tearing with 304 nvidia drivers: http://paste.ubuntu.com/7013164/

Could be related to this https://bugs.launchpad.net/ubuntu/+sourc...ug/1278012
As per the bug report above downgrading xserver-xorg-core to 1.14.5 gets rid of the tearing, but it does break a whole heap of package dependencies in the process. Now to work out why enabling 'audio sync - drop/dupe' gives me stuttering video with certain sources, but I'll start another thread for that.

EDIT following touser/yukky's info is what works best for me, I can run steam bpm + xbmc in the same session with no tearing.
Posting back because I finally figured out what happened. It seems with a recent update to the intel drivers, triplebuffering which was always defaulted to on before got disabled and you need to re-enable it manually. After I turned triple buffering back on I no longer need to use the tearfree option to prevent the awful tearing.

That being said I did explicitly disable composite though I "believe" that should have no bearing on anything whatsoever in my case since I run xbmc as standalone with no window manager at all as that machine is just an xbmc/headless server box. I am pretty sure it is the triple buffering... try it.
Same problem for me on Ubuntu Trusty 14.04 + XBMC Gotham 13 + nvidia 331.38-0ubuntu7.
I have vsync enabled both in nvidia settings and xbmc settings (requires expert or advanced mode).

The fix from Uveges Valentin (iuv-vali) at https://bugs.launchpad.net/ubuntu/+sourc...ug/1278012 worked for me (need reboot though, log in/out not enough):

cat /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf

Code:
[SeatDefaults]
# Dump core
xserver-command=X -bs -core

Other things that might be worth trying (not tested yet myself):
- Use patched libsdl12 from https://bugs.launchpad.net/ubuntu/+sourc...ug/1280665 (EDIT: previous link wrong - tx Kib)
- Log in directly in xbmc, not in unity then xbmc
https://bugs.launchpad.net/ubuntu/+sourc...ug/1280665

the comments contain the patch as well as a ppa with the patched libsdl

Code:
sudo apt-add-repository ppa:timo-jyrinki/ppa
sudo apt-get update
sudo apt-get install libsdl1.2debian

You can later remove the PPA with:
sudo apt-get install ppa-purge
sudo ppa-purge ppa:timo-jyrinki/ppa
Pages: 1 2 3