Kodi Community Forum

Full Version: XBMC + Ubuntu 13 Autoboot - Mouse Cursor
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Everytime I boot XBMC, I am getting a mouse cursor (system default, not the xbmc cursor) in the middle of the screen. It goes away after a bit, or if I move the keyboard. I tried unclutter, but didn't work well. Anyone have ideas on how to kill this off?
how exacty are you starting xbmc? I use this command in ~/.bash_profile to start X11 and completely hide the cursor:

Code:
if [[ ! $DISPLAY && ! -e /tmp/.X11-unix/X0 ]] && (( EUID )); then
  exec xinit -- /usr/bin/X -nolisten tcp vt7 -nocursor :0
exit
Using this method:

Code:
sudo nano /etc/lightdm/lightdm.conf


[SeatDefaults]
autologin-user=xbmc
autologin-user-timeout=0
user-session=XBMC
greeter-session=lightdm-gtk-greeter

Will your method still work?

(2014-01-20, 07:13)teeedubb Wrote: [ -> ]how exacty are you starting xbmc? I use this command in ~/.bash_profile to start X11 and completely hide the cursor:

Code:
if [[ ! $DISPLAY && ! -e /tmp/.X11-unix/X0 ]] && (( EUID )); then
  exec xinit -- /usr/bin/X -nolisten tcp vt7 -nocursor :0
exit
Not sure, you'd need to find out how X11 is started.
hers some clews on killing cursor from me see http://forum.xbmc.org/showthread.php?tid...pid1230808 and

Of which these are options to keill cursor from various methods as it says in http://forum.xbmc.org/showthread.php?tid...pid1230302

lightdm idk what it uses but you find out what its calling and the above links contain potential good info.

alternatively dont use lightdm to start xbmc remove its conf and add the upstart method I link in first link. It works 100% for me.
I changed the lightdm.conf to default settings, then added /etc/init/xbmc.conf script, but it doesn't work, just boots into desktop normally. =/
I also tried the ~/.bash_profile method to no avail.

Should I delete the lightdm.conf and /usr/share/xsessions/XBMC.desktop?

(2014-01-20, 19:23)uNiversal Wrote: [ -> ]hers some clews on killing cursor from me see http://forum.xbmc.org/showthread.php?tid...pid1230808 and

Of which these are options to keill cursor from various methods as it says in http://forum.xbmc.org/showthread.php?tid...pid1230302

lightdm idk what it uses but you find out what its calling and the above links contain potential good info.

alternatively dont use lightdm to start xbmc remove its conf and add the upstart method I link in first link. It works 100% for me.
You can try, renaming them... deleting is very permanent.
I renamed them and it didn't work, so I rename everything back, now I can't get xbmc session to start, just boots into desktop everytime... ahhhh!!!

(2014-01-21, 08:44)uNiversal Wrote: [ -> ]You can try, renaming them... deleting is very permanent.
Hi all,

First post here!

I have a very similar problem. I run XBMC in Ubuntu (14.10) however not standalone, but as an application.

If I leave XBMC in its main menu, then turn the TV off, when the TV is turned back on there is a cursor in the centre of the screen that I cannot move. Only solution is to exit and restart XBMC.

Ofcouse the -nocursor works, but that means that I have no cursor at all in Ubuntu... :-(

The cursor is not the XBMC one, its a system one.

I'm ripping what's left of my hair out trying to solve this. Any help is greatly appreciated.

It should be said that this problem started after I upgraded from Ubuntu 14.04 to 14.10 so I do suspect that it is a OS problem, not a XBMC one, but I am not 100% sure.

Again, any help is gladly appreciated!
sounds like you need to force the EDID, search the forum for how to do that on your GFX hardware as it differs between nvidia, intel and AMD
(2014-10-27, 23:11)Bebendum Wrote: [ -> ]Hi all,

First post here!

I have a very similar problem. I run XBMC in Ubuntu (14.10) however not standalone, but as an application.

If I leave XBMC in its main menu, then turn the TV off, when the TV is turned back on there is a cursor in the centre of the screen that I cannot move. Only solution is to exit and restart XBMC.

Ofcouse the -nocursor works, but that means that I have no cursor at all in Ubuntu... :-(

The cursor is not the XBMC one, its a system one.

I'm ripping what's left of my hair out trying to solve this. Any help is greatly appreciated.

It should be said that this problem started after I upgraded from Ubuntu 14.04 to 14.10 so I do suspect that it is a OS problem, not a XBMC one, but I am not 100% sure.

Again, any help is gladly appreciated!

Did you manage to sort this by forcing EDID? I'm having the same issue with a Asus Chromebox (intel)