Kodi Community Forum

Full Version: hiccup with subtitles
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

This is my first post and sorry about my poor English.
I've used xbmc on pc for several months, and it's really nice.
Thanks ever so much for this product and team-xbmc's efforts.

Recently i've purchased two android box: OUYA and G-Box MX2.
i downloaded nightly version from this site's download link and installed.

About G-Box: xbmc plays flawlessly, however the resolution is 720p.
anyway, i'm satisfied with that.

My question is about OUYA.
i've installed the same nightly version as G-box.
The xbmc on OUYA is 1080p and plays so well, but i've got problem with subtitles.

When i use Korean/Chines subtitles it shows hiccup slightly whenever they meet subtitles that have many characters.
Without subtitles it has no problem like that.

I've re-installed using many different nightly versions, but got same result.

Why G-box doesn't have that problem?
Is that because the difference resolution between 720p and 1080p?

I appreciate any word of advice.
Thanks.
Could you make a video? "Hiccup" is not precise enough to have an idea of the issue.
OK. I'll try to make some video showing it.

Meanwhile, the 'hiccup' in my post means 'stutter'.
While playing hd movies, xbmc stops for a very short time when it shows subtitles, then goes smoothly again.
It happens through whole movies.

It plays so well on no subtitled-scenes.

Sorry for bad explanation caused by my poor English.
I'm having this exact problem with Ouya and it happens whenever I turn on Chinese subtitles. The video freezes for a split second every time a line of text appears on screen - doesn't seem to happen with English subtitles. I've tried various options in subtitles settings menu but still couldn't fix it. Any ideas what is causing this problem? Does it require more system resource to encode text in Chinese/Korean?
Found some old threads related to this issue in past XBMC versions and as recent as 12.1.1 (looks like no one was able fix it):

http://forum.xbmc.org/showthread.php?tid=91230
http://forum.xbmc.org/showthread.php?tid=78781
http://forum.xbmc.org/showthread.php?tid=98924
http://forum.xbmc.org/showthread.php?tid=159890