Kodi Community Forum

Full Version: Windows 8.1 Cannot Access Windows 7 Shared Folder
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am sorry if this is posted somewhere, but I have done a lot of searching and cannot figure out what is happening. I am not sure if it is a windows issue or an XBMC issue. Anyway, here is what is happening. I have my videos stored on my PC in my home office running windows 7 64 bit. I have followed this guide and set everything up as shown. On my HTPC, I am running windows 8. In XBMC, I can see the folders that I am trying to access, but I get a message saying "UNABLE TO CONNECT: Could not retrieve directory information. This could be due to the network not being connected. Would you like to add it anyway?" Then a yes or no response box.

My setup for networking has a router directly off my modem. There is a switch that goes to the office computer (where my shared folder is). The HTPC is running directly from the router and is where i am trying to run XBMC. Is this the correct way to wire the network? I could bypass the router altogether with 2 gigabit switches but I don't think that is a good idea for security reasons and I am not sure if this is the problem.

Maybe a port needs to be opened on my router? Any help I can get would be appreciated!
Hey Guys,
Looking at the threads I see maybe you need more information from me on my system. Here it goes:

Asus A88X-PLUS Motherboard with an AMD A4-6300 3.7G FM2 CPU/APU
16GB Corsair Ram (2X8GB, 1600 MHZ)
Sound and video are both on board the motherboard
Mushkin Chronos MKNSSDCR120GB Hard Drive
Running Windows 8.1

Office Computer
Asus M5A97EVO Motherboard with am AMD FX-8320 3.5G AM3+ CPU
16 GB Kingston Ram (4X4GB, 1800 MHZ)
EVGA Geforce GT630 2GB Video Card
Sound is onboard the motherboard
OCZ Vertex 120 GB SSD Hard Drive
2X 2 TB Seagate SATA Hard Drives
Running Windows 7 Professional 64 Bit

Running XBMC Version 12.3 on both systems

D-Link DIR-601 Router

XBMC runs great on my office computer. It runs on the HTPC as well, but with the issue as stated above. Please let me know if more info is needed! I would really like to get this solved and be watching some of my movies over the weekend!
Thanks in advance.
I think there might be a step missing in that guide. In step 6, before you change the "sharing" settings on the folder properties, go to the "security" tab and set user "Everyone" to have "full control" on the folder and contents. Then continue on with the "sharing" settings etc. That of course allows any system that can find your shared folder to mess with it, but if your are on a home LAN, and don't for example run open wifi on it and trust your family you should be OK. If you don't like that level of "openness" you could play with those security settings as desired.

scott s.
Thanks for getting back to me! I realized that I never got the IP address setup on my HTPC, once I did that it was able to access the files.

Now the library is setup and the scrapers worked fine, but I keep getting an "error failed to play" message and it tells me to check my log file for details. I will do that tomorow and see if I can get it to work.
Hey guys
I got this log file when trying to play a movie:


I see something about no codecs, do I need to install codecs? Or am I missing something else?
I finally got up and running! For some reason, windows 8.1 would not access the files on my windows 7 system though it would see the files and scrape them into a database for me. Only when I would go to watch the movie it would hang and eventually tell me it could not connect to the server.

I changed the path I was searching for to using an ip address and it is working flawlessly! I have a harmony one remote I have been using for a while that works great with XBMC and the playback looks great. If it is helpful to anyone having this problem, this quick video on youtube is what solved it for me:


Hope this post is helpful!
Reference URL's