Kodi Community Forum

Full Version: Since update to 2.5.3, movies not being 'moved' into subfolders.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, i am scanning a base folder which contains all my new movies, and then once matched and scraped, i clean up the file naming.

Rather than moving into the correct destination folder like it used to i am seeing:

2014-03-02 10:28:04,066 ERROR [tmmpool-rename-thread-1] o.t.core.movie.MovieRenamer:168 - no Datasource set
2014-03-02 10:28:04,066 INFO [SwingWorker-pool-3-thread-4] o.t.core.movie.tasks.MovieRenameTask:72 - Done renaming movies)

and the movie + nfo images remain in the base folder.

Rename settings are unchanged by me:

Folder name: $T ($Y)
File name: $T ($Y) $V $A

Can anyone help?
I've been receiving some other responses with that issue yesterday.
We will dig into this problem asap
unfortunately is looks like a corrupt database
You can try to remove your movies from tmm and then do an "update datasources" - this will reimport all your movies with the existing NFO/artwork and after that it _should_ work..

I am trying to find out how this could happen - but it could be a problem with our used database engine, which we can't fix Sad
Hi- can confirm that removing movies and doing an update sources worked.

Thanks for your help, appreciate it.
Unfortunately, as soon as i scan new movies, the rename is failing again...
is this problem reproduceable?

E.g. when repeat this procedure, does the issue appear again?

I cannot find any error in the code and I am unable to reproduce it here Sad
If you find a way to reproduce it, please let me know how you did that
I found the problem:

the version of the database engine we are using has an (critical) error. This prevents some data of the movies/tv shows to be persisted into the database.
I've contacted their support. Unfortunately we have to wait for a hotfix before this can be solved..
Thanks for this update- i see the new release and i will try this now...