Kodi Community Forum

Full Version: Where did the "Scan for new content" menu option go??
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm on the (constantly crashing) "stable" release of Frodo.
I haven't done anything to this (other than reboot a couple of times a day after XBMC crashes :/).

This last weekend I weekend I added a few movies and I normally follow this routine - Move the ISO and it's accompanying .nfo file that points to the TMDB entry to the appointed location, then on the "Movies" file folder in XBMC, use the "menu" button on the mac mini remote to reveal the "Scan for new Content" menu.

This menu option has disappeared, and all of the movies in the library no longer have images associated with them in the file listings.

Anyone have any idea how this could go away and how I might get it back?

Seeing as how I haven't manually done any updates, the change is especially bothersome seeing as I have not done any manual updates...
If you're having constant crashes and menu items disappearing you should probably post a Debug log (wiki). Frodo 12.3 is very stable on my system. You might want to include system info as well.
crashreport needed.
woops.. Permissions and those crazy symlinks Apple loves.
Try it again.
you seem to have a.) an cec usb adapter connected or b.) some other usb device which interferes bad with xbmc.
A wireless Logitech keyboard with a built in mouse that uses a USB fob between the keyboard and the mac, and a USB attached hard drive that holds Time Machine backups are the only USB devices attached.
Any chance the issue is with the external drive?
Remove usb devices until it stops to crash Wink
Interesting. What does having a USB device attached have to do with XBMC?
I have removed the external USB drive and disabled Time Machine, as trying to attach the Bluetooth keyboard to the mac, using the same keyboard connected via a USB bluetooth fob/device is a bit of challenge.

Still no menu option to update the library content. Is my best bet to correct this now to delete the XBMC install and start over?
I just try to Trouble shoot that crashlog - Thats the Problem when People try to handle multiple Problems in one thread...
I was able (finally!) to get the keyboard connected directly via bluetooth and I removed the external drive and disabled Time Machine.
I then deleted the XBMC app, and removed the /Applications... folder after killing the XBMC.helper process.
I ran Disk Verify on the boot disk (Any way to have fsck run at next boot? I have little confidence in a file system check on a running boot partition.)

I re-installed Frodo 12.3 and let it re-scan all the movies and TV shows.

Somewhere along the line, the "Movies" item on the main "menu" or bar or whatever in the main screen of the application had disappeared and is now back.

I'll let this run for a week, then add the external drive back, via firewire rather than USB and turn on Time Machine.
And it's crashed again.

Is there ANY hardware platform on which this is stable?
How much would it cost to have one of the coders take the Dharma code base and update the TMDB movie scraper?
Any takers on that?

I'm _really_ tired of the crashing, and all I want is to be able to browse an NFS share and watch the ISO and MKV files that have a nice pretty icon of the movie art out by the file name.

Please? Anyone?
Noone can help you unless you provide some information that helps troubleshoot stuff.

Debug Log, crash logs etc.
Last round of logs from incessant crashes are here: http://www.taftbbs.com/xbmc/2014-2/
You can see the hardware/system info http://www.taftbbs.com/xbmc/xbmc_platform.txt

And here: http://www.taftbbs.com/xbmc/2014-3/

And here: http://www.taftbbs.com/xbmc/2014-3/

XBMC was in "debug" mode with the output overlay in the user interface. Kept it there until it crashed again.
Should I create a new post for this?