Kodi Community Forum

Full Version: NFS issues continue with Gotham beta 2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11
I'm on a different computer at the moment, so I won't be able to post a debug log until later on.

I'd been having an odd issue with art since Gotham Beta 2 (and the nightly as of two days ago) where no *new* artwork would show up. This includes posters, fanart, and thumbnails. I wasn't able to find any bug reports for that exact issue, but did find several about NFS issues if used from the windows client -- and all of my media is, guess what, served via NFS from a linux home server, and my HTPC is windows based. I saw some mention that other NFS issues were resolved in nightlies newer then beta 2, so I gave that a shot -- no dice. Again, the only things missing were from new media -- things already in Thumbnails (I presume thats the reason) showed fine.

What I did was open up the Gotham beta 1 installer (since it was the last version where I didn't have any issues) in an archival program (7-zip), extracted the libnfs.dll from it, and dropped it over the existing one in the install directory. Started XBMC again, and like magic -- it all worked fine again.
Probably not what your going to want to hear...

Wow, I can't believe I missed that thread. Also, I can't believe they would seriously release a stable version with broken or missing NFS support. Blows my mind.
What should we do instead - please tell me? I think i described the problem we have here in multiple spots already now. I understand that users won't believe it or can't believe it. But seriously - what are our options?
tbh reading all the reports I'd give my +1 to remove nfs for the windows build already for Gotham.
Makes sense. I am going to try allegro NFS as an alternative ASAP, hopefully in a few hours.

Maybe it IS just a hanewin edgecase.
You really think i will do a PR against gotham with going back to libnfs 1.6.3 again? This kills my credibility.

I don't want to blame it on you. Because I (so my fault!) should have never listened to one user who has problems. And then i also should not have listened when you told me all your problems are gone with libnfs1.3. Multiple errors i made here for sure - but we need to live with it now. (and just overread the blame from users).

This is something i learned. Not jumping into the knife because of 1 or 2 users are reporting a problem and claiming to know a valid fix for it.
There is that.

I don't frickin' know - for years it was perfect with libnfs 1.3

Apparently going back to 1.3 isn't enough (artwork issues)... so it's all a bit f*cked.

Are you planning on removing it then...I guess then there is no point me trying.
If no one really is able to dig onto the ground of the problem - then the real issue will not get fixed. This needs to be someone who

a. can reproduce the problem
b. is able to compile libnfs on windows
c. understands the interna of libnfs and the nfs protocol
d. is willing to work on windows Wink
(2014-03-26, 13:49)Memphiz Wrote: [ -> ]If no one really is able to dig onto the ground of the problem - then the real issue will not get fixed. This needs to be someone who

a. can reproduce the problem
b. is able to compile libnfs on windows
c. understands the interna of libnfs and the nfs protocol
d. is willing to work on windows Wink

Sorry I didn't reply last night -- I was going to see if I could do exactly that. I'm not fond or familiar with compiling (much of anything) on Windows, so we'll see how it goes. I'm a linux guy, so it's a bit outside my expertise. Working with VS and Git on windows thus far has been a new lesson in pain, at least compared to doing similar in linux, heh. I am pretty familiar with NFS (and it's problems, especially with NFSv3, but not libnfs in particular), so, we'll see how it goes.
Just for info - I just tried allegronfs as an alternative server to Gotham Beta 2. I can (like with Hanewin) - now clean the library ok with beta2, but the image issues remain.

I should probably test it against beta1 for comparison but I'm out of time for the moment, sorry.

@garretn...seems you're our best hope!!
I was more curious on if using allegronfs with the newer version of libnfs still nukes your library.

Personally, the whole issue of the library dropping sounds like "a typical NFSv3" problem. XBMC wouldn't be the first app to get confused with a stale NFS mount and missing files (I haven't confirmed whats happening whatsoever yet, but these sorts of problems are typical with unstable NFSv3 mounts in a general sense).

To be clear, I'm looking at the original issue before libnfs was downgraded on windows.
So far I've not been able to reproduce the issue exactly, the closest I've been able to get was simply replicating a "typical NFSv3" problem and that behaved about as I would expect -- and exactly like the original issue.

My test setup being slightly off kilter, a virtualbox bridged VM with the win32 build environment required, along with Hanewin NFS set up inside the VM (However, for access to media, it's actually sharing out samba from my home server).

Using Gotham Beta 2 inside the VM, I added one of my movie folders from an NFS share directly from my home server -- exactly like my HTPC has. I then added a different movie folder (I sort my movies by "me", "family", "kids only" on this server, same with TV shows) through Hanewin NFS, ultimately coming from the same server. After cleaning my library many many times...nothing odd happened.

So instead I decided to produce a stale NFS mount through Hanewin, to see what would happen (this is a typical cause of problems with *anything* using NFSv3). Before producing a stale mount I verified "good" behavior -- I simply shut down samba on my server that Hanewin was mounting a folder from, and everything had good behavior -- XBMC reported the share missing, and prompted me whether or not to keep the entries in my library for it. Good. Now it was time to test a more likely scenario for the "real" cause of problems -- I started samba back up, verified Hanewin was serving the content -- and hit Clean Library, and them *immediately* disabled samba on my server mid-operation. Sure enough, the items were removed from the library -- which I more or less expected to happen.

bossanova808, could you describe your library more in-depth, is it normally slow to scan, is the NFS server typically "busy", does this tend to happen with certain videos (I'm thinking larger files, specially more complex ones like ISOs), wireless connection, etc. Specifically I'm after things that could cause timeouts, drops, or simply something like your NFS being too busy to accept the connections in time.
Just as a silent reader - you are doing the correct thing (chasing the libnfs 1.6.3 issue instead of the 1.3 which we don't really care about as it is fixed in 1.6.3). *keeps silent again cause*
This is somewhat curious.

It would seem that if I get items removed from the library through the stale handle I mentioned earlier, the "Content" type on the related source gets automatically set to None. If I set this back to Movies, and restore the NFS mount to working, updating the library adds duplicates of what it removed earlier (So each item now has two entries under the movie table, referencing the same idFile).
Pages: 1 2 3 4 5 6 7 8 9 10 11