Kodi Community Forum

Full Version: Foscam HD - Video feed with camera controls, and motion/sound detection preview
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
Hi,

Just for your information...

I´m having the same issue with the python error... running in XBMC 13.2 with the addon. XBMC 13.2 was re-installed after try Kodi 14, in the same PC that was working before but now I´m getting this error only when the preview function is in use:

Code:
02:06:13 T:2128  NOTICE: script.foscam v0.0.21: http://192.168.1.21:88/cgi-bin/CGIProxy.fcgi?cmd=setSubStreamFormat&usr=myadminuser&pwd=myadminspass&format=1
02:06:13 T:2128  NOTICE: script.foscam v0.0.21: <Response [200]>
02:06:13 T:2128  NOTICE: script.foscam v0.0.21: <CGI_Result>
                                                <result>0</result>
                                            </CGI_Result>
02:06:13 T:2128  NOTICE: script.foscam v0.0.21: Showing preview
02:06:13 T:2128   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ValueError'>
                                            Error Contents: invalid literal for int() with base 10: 'Username required\n'
                                            Traceback (most recent call last):
                                              File "C:\Users\NICMA\AppData\Roaming\XBMC\addons\script.foscam\service.py", line 167, in <module>
                                                Main()
                                              File "C:\Users\NICMA\AppData\Roaming\XBMC\addons\script.foscam\service.py", line 33, in __init__
                                                self.alarm_check()
                                              File "C:\Users\NICMA\AppData\Roaming\XBMC\addons\script.foscam\service.py", line 162, in alarm_check
                                                self.duration_shown = preview.start()
                                              File "C:\Users\NICMA\AppData\Roaming\XBMC\addons\script.foscam\resources\lib\gui.py", line 103, in start
                                                duration = self.extract_mjpeg.start()
                                              File "C:\Users\NICMA\AppData\Roaming\XBMC\addons\script.foscam\resources\lib\utils.py", line 171, in start
                                                frame = get_mjpeg_frame(self.stream)
                                              File "C:\Users\NICMA\AppData\Roaming\XBMC\addons\script.foscam\resources\lib\utils.py", line 142, in get_mjpeg_frame
                                                bytes = int(content_length.split(':')[-1])
                                            ValueError: invalid literal for int() with base 10: 'Username required\n'
                                            -->End of Python script error report<--

Best regards.
(2015-02-16, 10:11)nickiman Wrote: [ -> ]I´m having the same issue with the python error... running in XBMC 13.2 with the addon. XBMC 13.2 was re-installed after try Kodi 14, in the same PC that was working before but now I´m getting this error only when the preview function is in use:
Which camera model are you using?
Quote:Which camera model are you using?

FI9821W V2
nickiman tried my patched version of the script? should fix it..
Not yet quixers...

I´ve already downloaded and probably I´ll try it tomorrow night...

My setup is:
Windows 7
XBMC 13.2
Addon Foscam HD: 0.0.21
FOSCAM: FI9821W (V2):
-------------->System Firmware Version: 1.4.1.9
-------------->Application Firmware Version: 2.11.2.8
-------------->Plug-In Version: 2.0.2.10

I´ll let you know.
Hi quixers,

I´ve tried your script following your recomendation to install it:

Quote:Download this, rename it script.foscamFix.zip

https://github.com/peteakalad/script.fos...master.zip

To install, uninstall the existing version then install my patched one..

1) Go to settings -> add-ons -> Program add-ons -> Foscam HD -> uninstall -> Yes

2) Go to settings -> add-ons -> Install from zip file -> select the downloaded file above 'script.foscamFix.zip'

After that I´ve configured again all the parameters in the addon and I´ve checked that running the addon I can see in full screen the live view of the camera.

But when an alarm preview is triggered the little square with the image from the IP camera doesn´t show anything.

I can see only the cross to close the preview in the upper right corner fo the square but, without images from the camera. I attach you a snapshot capturing that situation:

Image

Movement triggered on IP cam

I attach you the part of the log where I think could be the error:

Code:
10:40:28 T:4444  NOTICE: script.foscam v0.0.21: Showing preview
10:40:28 T:4444  NOTICE: script.foscam v0.0.21: Snapshot C:\Users\NICMA\AppData\Roaming\XBMC\userdata\addon_data\script.foscam\snapshots\snapshot.1424598028.47.jpg
10:40:28 T:3232 WARNING: JpegIO: Error 30: Bogus DHT index %d
10:40:28 T:3232   ERROR: Texture manager unable to load image from memory
10:40:28 T:4444  NOTICE: script.foscam v0.0.21: Snapshot C:\Users\NICMA\AppData\Roaming\XBMC\userdata\addon_data\script.foscam\snapshots\snapshot.1424598028.48.jpg
10:40:28 T:4444  NOTICE: script.foscam v0.0.21: Snapshot C:\Users\NICMA\AppData\Roaming\XBMC\userdata\addon_data\script.foscam\snapshots\snapshot.1424598028.5.jpg
10:40:28 T:3232 WARNING: JpegIO: Error 30: Bogus DHT index %d

But anyway I send you also the complete log file in case you need to do a deeper analysis of the situation:

https://dl.dropboxusercontent.com/u/3942...foscam.log

Keep waiting your comments.

Thanks for your help.
Does this error also occur when using Kodi 14.1 or 14.2 beta?
(2015-02-23, 18:32)Leopold Wrote: [ -> ]Does this error also occur when using Kodi 14.1 or 14.2 beta?

In my case, I haven´t tried with any of these versions... only with Kodi 14.
Im using kodi 14.2 beta and im also getting the blank preview window
Hmm perhaps the stream handling needs a bit more tweaking for other cameras

Could anyone with a blank image showing send/attach one of the snaphot files from your .kodi directory?

e.g. this one would do for nickiman
C:\Users\NICMA\AppData\Roaming\XBMC\userdata\addon_data\script.foscam\snapshots\​snapshot.1424598028.5.jpg
Ive looked in that folder and its empty when the preview comes up. Their is snapshots that appear but quickly dissappear. But the images dont open when try to copy them they dont work
Hello there

first of all thanx for the plug in but i couldnt make it work until now Sad

I have a raspberry pi with Kodi 14.1 installed

I have a Foscam cam

The latest FOSCAM HD i have is 0.021

I guess i am using the worng data in the field of HOST

please help Big Grin
So latest 2.x.1.119 firmware for HD cameras (mines a FI9831P) fixed the issue with the stream url so the parameters are as per their spec. This broke my fork of the foscam script.

I updated my github fork with a fix for this and confirm its working ok for me.

https://github.com/peteakalad/script.foscam

therealabdo: if you are using wrong data in the host field, er.. use the RIGHT data in host field then, i.e. your internal IP of the foscam Smile
The addon doesnt work for me anymore, the screen stay black, when i press stop and go back to the main menu in a split second i see a normal camera screen.
I use kodi on my raspberry pi 2 with the Foscam HD addon.
What is the problem?
I already reinstalled the addon.

Greetz Martijn
Did you update firmware on the camera? If not update to 2.1.x.119 and try my version of the script, look at previous post on how to get/install it...
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15