Kodi Community Forum

Full Version: Vsync broke after update?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey folks,

I ran some little system upgrades including the intel-display-driver and mesa, and after that I noticed horizontal, flickering line on all of my movies/Tv shows,
like on an old (defective) TV.

Looks like vsync is not working, the line is stuttering, if I play/pause the line sometimes jumps to another section of the screen, but sometimes it stays where it was...
sometimes is isn't just a line but a larger section of the screen which flickers...strange.

I tried Vsync to "always" and "only while playing", played around with all A/V-sync methods; no change.

here's my logs:
Your debug xbmc.log: http://xbmclogs.com/show.php?id=173563
Your XBMC crashlog: http://xbmclogs.com/show.php?id=173564

vsync seems to be enabled
the only errors I see are:
Quote:ERROR: GLX: Same window as before, refreshing context
...
ERROR: VAAPI - unable to initialize display -1 - unknown libva error

sometimes when I restart XBMC, the FIRST file I start plays fine, without the flickering horizontal line,
but the second one (or even if I restart the first one) displays the errors again.
I don't know where to start searching for errors.

ah, yes.
the files seem to play fine with mplayer, so I think it is a XBMC issue.

thx for help!
You use a non supported gentoo patched broken version with external ffmpeg and other external libs, which has absolutely no support by us.

Furthermore you might be running xorg 1.15 which has a backing store problem, which should be disabled.

mplayer does not use SDL and no opengl.
thank for helping, I know that my libs and sys don't have any support by xbmc-maintainers, I just want to figure out where the problem comes from,
and you are much more used to scan the logs for necessary information than I do.

I disabled backing store in xorg 1.15,
problem still exists, i will try after downgrading to 1.14.5

what do you mean with "patched broken version" of gentoo?

Maybe necessary, what version of python does XBMC need?
Because of some old apps I have 2.7 as main active version, should I change it to 3.2 or 3.3 for XBMC?
No. 2.7 is fine.

Please provide the output of vainfo

Btw. I would suggest you to upgrade to xbmc v13 - we are nearly ending beta phase now - so RC will be released the next days, so that would be better to test for now. 12.3 is out of support.
i disabled vaapi, because of my hardware (haswell pentium) vaapi seems to be not supported.

so vainfo always gave me an error message when searching for i965.
because you mentioned the external ffmpeg, I always thought XBMC needs ext. ffmpeg...is there a way to switch to the internal?

xbmc 12.3 was the latest stable in portage, that's why I sticked by the old one.
If RC is out, then stable is not far?

will try it with the beta for testing...
Haswell pentium supports vaapi quite fine. Make sure you use a version >= 1.2.1 for libva and the relevant driver.

Just remove --external-ffmpeg and --external-libraries from your epackage.

Edit: It's more stable than 12.3 ever was.
tried to compile v13, and I got one error:

Code:
...
autoreconf-2.69: Leaving directory `lib/libdvd/libdvdnav'
which: no java in (/bin:/usr/bin)
which: no doxygen in (/bin:/usr/bin)
Warning: No doxygen installed. The Api will not have any docstrings.
mkdir -p xbmc/interfaces/python/generated/doxygenxml
Java not found, it will be used if found after configure.
This is not necessarily an error.
make: *** [java-not-found] Error 1

v13 needs java?

Edit: alright, I use libva 1.0.15 (latest stable) and libva-intel-driver 1.0.17
so I will unmask and give both 1.3.0 a try
Latest stable is 1.3.0 (but I only tested 1.2.2) xbmc needs default-jre for autogenerating stuff when building.
Yes, thx very much, upgrade libva and the driver to 1.3.0 did the trick,
no stuttering video files anymore (in 12.3)!

libva output seems ok too,
I do not have a keyboard on the xbmc machine at the moment, but without X over ssh it reports

Code:
error: can't connect to X server!
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/va/drivers/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.0)
vainfo: Driver version: Intel i965 driver - 1.3.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD

which looks much better than before,
Yeah - be careful with 1.3.0 though - I did not test that one and we reverted it in OpenELEC.

I would have suggested libva 1.2.1-r1 for libva and 1.2.2-r1 for libva-driver-intel (always the latest prior to 1.3.0) - but let's see how much luck you have :-)
yes, we will see. Smile
thx
Since any older libva than 1.3.0 is masked by now,
are there any news which is the latest stable version of libva and libva-intel-driver with working vsync?

thanks!
That post was years old in the meantime ... you can savely use 1.5.0 now