Kodi Community Forum

Full Version: Audio Issue after updating from Frodo to Gotham
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hey there,

today i updated from Frodo to Gotham (XBMC13.0-RC1). After that it seems that in XBMC my rear left speaker is switched with the center speaker. I've found some problems/solutions like that for linux (like that: http://deanvaughan.org/wordpress/2012/08...-speakers/), but not for Mac OS X.
I already tried to switch back to the latest Frodo release, with that everything's ok, as well as the 5.1 Output with the same mkv-file in VLC.

I'm running Mac OS X 10.9.2 on a MacMini Late 2012, 2,5 GHz Intel Core i5, 16GB RAM

i hope that anybody can help.
Thanks in advance

Volker
IIRC it's usually due to your speaker assignment setup incorrectly in OSX preferences. Have a nosy around in there.
Do you mean in Audio MIDI Settings? I already checked that.
You can test every speaker channel by clicking on a button. If i do so everything is ok. I also tried to switch the both channels there, after that the problem in xbmc remains the same.

Any other suggestions?
Had this issue as well; go into expert settings , audio hardware, output configuration and select fixed .(sorry have dutch XBMC here, so guessing the menu names;

But that solved the issue on my anthem for all audio tracks.
I'm getting the same problem. Turning on Expert settings and switching output configuration to "Fixed" does not solve the problem.

You need to turn on "Best Match" for Output configuration, which causes "Enable passthrough" to appear at the bottom. Turn on Enable passthrough and surround content plays correctly again.

I was using a 2010 Mac Mini, also with 5.1 over HDMI, and version 12 worked fine but 13 broke it.
Thanks!
I changed the Output configuration to "Best Match". Everything's fine now.
This thread saved me a lot of work. Today I updated from Frodo to Gotham. I have the same config as Sappharad and his solution also worked for me. Thanx man. ^_^
I don't have audio equipment to test this with, but it sounds like a possibly-common OS X issue, so I'd like to add it to the wiki. Would this be correct:

If you have a multi-channel setup and the channels appear to be incorrect (such as a left speaker gets switched to the center speaker) then you should change output config to "Best Match"?

Is this just for passthrough situations? Do users without passthrough AVRs have an option for correct 5.1 sound?
Could someone explain this in a little more detail? I'm running a Mac Pro and have the same issue as the rest of you. Where is the expert settings to change it to best match?
never mind got it figured out. I had to change skins to get the advanced settings. Thanks for the info it worked great
(2014-05-12, 03:31)Ned Scott Wrote: [ -> ]I don't have audio equipment to test this with, but it sounds like a possibly-common OS X issue, so I'd like to add it to the wiki. Would this be correct:

If you have a multi-channel setup and the channels appear to be incorrect (such as a left speaker gets switched to the center speaker) then you should change output config to "Best Match"?

Is this just for passthrough situations? Do users without passthrough AVRs have an option for correct 5.1 sound?
I think the only point of "Just Match" is that it allows passthrough to be enabled, which bypasses the faulty 5.1 mapping in the new version. Users without a surround receiver that has passthrough support would still be screwed if they wanted 5.1 to work correctly. (It sounds like the other 'fix' is to use 2.0 stereo instead of 5.1 surround)

Looking at some of the other threads here, it sounds like the issue is common and being looked into.
I don't know whether it could be the same issue but since Gotham update when watching some movies I get full 5.1 support from on my receiver but with other files, which have 5.1 audio and in the past worked well, I only have back left speakers active and no sound from the back-right. I've tried to mess-up with all the expert options in system>audio with no success. Any help? Is it the same issue? Tnx.
Set speaker Layout to 2.0 and enable Pass through and ac3 transcode options for now - multichannel pcm (non passthrough) will be Fixed soon...
Thanks, it works this way.

Stupid question: is anyway passthrough a better option if you have a compatible receiver? So even when it will be fixed I should keep using this configuration?.
no - multichannel pcm is the better option once it is mapping the channels correctly to the speakers ... because then xbmc can decode the audio and sync it up to the video in a better way before sending it to the amp. Passthrough might have lipsync issues - depending on the used equipment ...
Pages: 1 2