Kodi Community Forum

Full Version: Dropped frames every minute - CRenderManager::WaitForBuffer
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everybody,

I decided to ask my question on the forum because since 5 days and after many configuration changes I find no solution everywhere on the net.

I have a home server with AMD A10 GPU with Radeon HD 8670D and 4 disks in RAID5.
All worked very fine with Ubuntu 13.10 and XBMC 12.0

But there are some days, I upgraded to ubuntu 14.04 and XBMC 13.0.
Since these upgrades, I have about 10-20 dropped frames every minute and during this, the video freeze (but audio not).

Logs show this message during the freezes :

WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

and this line is repetead many times.
Freezing takes approximately 1 second. And after that, the video resync with audio and no problem until the next minute.
This problem appears with all types of videos files, like HD mkv or little divx / xvid.
It doesn't seems to be a bandwitch problem.

With VLC, no problem at all.
I tried many configuration changes but no result.
All my video files are local on the RAID disks and I have no problem of performance or reading files.
For testing, I upgraded to XBMC 13.1 beta2, but same problem.

Here is the debug log :
http://paste.ubuntu.com/7496639/

You can see the problem every minute at 23:18:36, 23:19:35, 23:20:36 (only 3 times for this debug log but it is each minute if I let the movie play) and it is exactly during the freezes.

Thanks in advance for your help.
You are running OSS radeon drivers without using vdpau video acceleration.

Two chances:

a) install mesa-vdpau-drivers packages (verify with vdpauinfo)

or b) Video -> Acceleration - set it to Software.

In both cases you need ppa:wsnipex/mesa packages cause Ubuntu has a bug when pressing stop, it will segfault.
Additionally some dbus event for upower is spamming the whole main thread ... You can use upower -m from ssh shell to see what device is causing this.
he is using fglrx: GL_VENDOR = ATI Technologies Inc.
Yes you are right - so scratch option a) - No hw decoding support for you.
Hi fritsch and wsnipex,

Thanks very much for your replies.
Fritsch, you're on the right way with the upower -m command.

With this one, I saw that my apc was polled every 30 secs (ok so it isn't the problem) but my logitech unify wireless mouse was polled every minute, in the same time that freeze.
So, I unplugged my unify USB receptor and ... no more freeze !!!

I thought about everything including my apc but not my mouse!
Now I will look deeper into this. So thanks!

A little more question: why can I have hw decoding support ? Is it my graphic card not supported yet by the Radeon OSS driver?
Yes, it is supported by it, but you run the proprietary drivers.
For hardware acceleration follow this guide: http://forum.xbmc.org/showthread.php?tid=174854