Kodi Community Forum

Full Version: Multi-channel support regression in Gotham?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have been running XBMC 12.x up until recently on top of desktop Ubuntu 12.04 LTS in my HTPC. Even with pulseaudio, I was able to have multi-channel output via HDMI (NVIDIA) into my AV amplifier working correctly. By working correctly, I mean that the source channels matched the output into my amp... so 2-channel stereo would only drive 2 channels and no upmixing was occuring. 5.1 sources were output as 5.1, etc.

Now, after updating to Gotham, I cannot find settings that enable me to get source-matching output. Gotham wants to upmix 2-channel stereo to my 5.1 speaker setup. I want 2-channel stereo to play back as 2/2.1, as it was in 12, not upmixed to 5.1. I do not want to have to go into the settings every time I change from movies to music and re-configure my audio settings. This was not necessary in 12.

I find this very disappointing that I had a perfectly working 12 setup and 13 seems to have a major functional regression here. Is there a magic setting that I am missing? I have set the audio output to go directly to my NVIDIA card, not to the pulseaudio sink. I played with the obvious settings already, but it seems I cannot get back to a working setup like in 12, which worked beautifully.

A note to developers, if you are reading this... do NOT assume that just because I have a multi-channel speaker setup I want to send audio to every speaker. Audio should be by default "same as source", that is a 2-channel source should output 2-channels (or 2.1), not 5.1. If I want to upmix 2-channel audio I can enable one of the many "enhanced" surround modes in my amplifier to upmix to multi-channel audio. I do this on occasion, but mostly I listen to music in 2-channel mode.

Wanted to add some more detail about my system. I am running the x64 version of Ubuntu and I have the current Ubuntu 12.04 "recommended" NVIDIA driver installed (331 series, if I recall). CPU is Core i3 2100 and the GPU is GT 430 connected via HDMI to my multi-channel amp. All Ubuntu updates installed as of today.
I do assume, that you did not read the wiki: http://wiki.xbmc.org/index.php?title=PulseAudio
and I also assume, that you did not read "Read this before Posting"

Edit: xbmc only uses your device hogging PA server that you have installed which is up and running. We did not do this. If you don't want PA, then just uninstall it. Don't blame xbmc for using _your_ provided infrastructure.
Yes, I read the PA wiki, thanks for the snarky comment. It did not help, I already have my settings as described in the AVR HDMI
Decode HD Audio (5) column, although many of the settings in XBMC are not visible even when I am in advanced mode. pavucontrol is set for multi-channel mode, no codecs are checked. I have no other audio devices in my system.

Last time I checked, Ubuntu was a fully supported platform for XBMC that just happens to have PA installed by default. If you don't want to support PA, then fine, but then you need to make that clear UP FRONT. Don't blame the user for using a supported platform.
I solved most of this problems by switching to ALSA, I wrote a guide where: http://ubuntuforums.org/showthread.php?t=2225249

But if you want te stay on Pulseaudio, make shure you don't configure pavucontrol for multi-channel, but for stereo, look @ the guide http://wiki.xbmc.org/index.php?title=Pul...avucontrol, I know its a bit strange to setup speakers for stereo to get surround passtrough.

If you upgraded your XBMC it can help to rename "~/.xbmc", rember to export libraries also, this helped me, to get all the proper options for als Pulseaudio.

Also disable upmixing in pulseaudio and in XBMC uncheck stereo upmix: http://wiki.xbmc.org/index.php?title=Audio_settings
Also mentioned in the guide
Quote:When Pulseaudio is configured to be multi-channel output, e.g. 5.1 profile from within pavucontrol, 2.0 streams are automatically upmixed, no matter what setting you have chosen in xbmc. This is default pulseaudio server behaviour. You can workaround that by disabling enable-remixing in /etc/pulse/daemon.conf
enable-remixing = no
He does not want passthrough, he wants 5.1 pcm when there is a 5.1 source and 2.0 when there is a stereo source.

This can be done by setting the output device to the 5.1 profile and disable the auto remix in pa server. The wiki page exactly describes that here: http://wiki.xbmc.org/index.php?title=Pul...own_issues