Kodi Community Forum

Full Version: Pandora and Google Music Plays One Song and Stops
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
On one of my three raspberry pi devices and one of them has this issue. Of course it is the one that I solely use for music as the other two are for video. I have both the JSON and the Pandora that comes from the main repository (rivy?). Both of them play one song then stop. I can go back and click on the same Pandora station again and it will start then, again, play one song and stop. I have tried removing the add ons and reinstalling with no luck. This also happens to the Google Music add-on as well. I play the radio station...one song then stops. I have no issues playing music from my library located on a NAS...only with the streaming add-ons. I found an older thread stating to change the MPLAYER to AUTO in a file in the add-on but that did not work. When I did that the music would not start at all on the main repository add-on and the JSON just crashed and went back to the XMBC main screen.

This is driving me nuts and I really do not want to reload once again. Any help would be greatly appreciated.

Thanks!
Hi,

I was experiencing the same error in Pandora 2.3.2 (I don't have Google Music, so could not test that one) in a Raspberry Pi using Raspbmc.

After hours of debugging I kept wondering why the first song would play and the second one was giving me this error:

ERROR: CAudioDecoder: Unable to Init Codec while loading file...

The way I fixed it was by changing:

self.playNextSong_delay from 0.5 to 1 in the file addons/script.audio.pandora/resources/lib/pandaplayer.py

My guessing is that the Raspberry Pi SD card I'm using is very slow and it takes a while for the system to release the previous file and be ready for the next one.

So guess if you play with the delay between songs until it works for you, it should solve your problem.

Maybe the Google Music addon has a similar parameter.

Otherwise, you can try buying a faster SD card, like a Class 10 SD Card, clone your configuration and give it another try.
(2014-05-27, 18:27)episani Wrote: [ -> ]Hi,

I was experiencing the same error in Pandora 2.3.2 (I don't have Google Music, so could not test that one) in a Raspberry Pi using Raspbmc.

After hours of debugging I kept wondering why the first song would play and the second one was giving me this error:

ERROR: CAudioDecoder: Unable to Init Codec while loading file...

The way I fixed it was by changing:

self.playNextSong_delay from 0.5 to 1 in the file addons/script.audio.pandora/resources/lib/pandaplayer.py

My guessing is that the Raspberry Pi SD card I'm using is very slow and it takes a while for the system to release the previous file and be ready for the next one.

So guess if you play with the delay between songs until it works for you, it should solve your problem.

Maybe the Google Music addon has a similar parameter.

Otherwise, you can try buying a faster SD card, like a Class 10 SD Card, clone your configuration and give it another try.

Thanks for the response. I'm not sure what happened but even after reloading it wasn't working right. Then all the sudden yesterday I started Pandora again and it worked. It has been working ever since and I had it playing all day yesterday. As a FYI - I was not receiving any errors at all. It would simply just stop after the first song. If it happens again I will reference your post for sure.
(2014-05-27, 18:27)episani Wrote: [ -> ]Hi,

I was experiencing the same error in Pandora 2.3.2 (I don't have Google Music, so could not test that one) in a Raspberry Pi using Raspbmc.

After hours of debugging I kept wondering why the first song would play and the second one was giving me this error:

ERROR: CAudioDecoder: Unable to Init Codec while loading file...

The way I fixed it was by changing:

self.playNextSong_delay from 0.5 to 1 in the file addons/script.audio.pandora/resources/lib/pandaplayer.py

My guessing is that the Raspberry Pi SD card I'm using is very slow and it takes a while for the system to release the previous file and be ready for the next one.

So guess if you play with the delay between songs until it works for you, it should solve your problem.

Maybe the Google Music addon has a similar parameter.

Otherwise, you can try buying a faster SD card, like a Class 10 SD Card, clone your configuration and give it another try.

Hey! This worked perfectly for me thanks so much!
(2015-01-27, 03:16)Raggou Wrote: [ -> ]
(2014-05-27, 18:27)episani Wrote: [ -> ]Hi,

I was experiencing the same error in Pandora 2.3.2 (I don't have Google Music, so could not test that one) in a Raspberry Pi using Raspbmc.

After hours of debugging I kept wondering why the first song would play and the second one was giving me this error:

ERROR: CAudioDecoder: Unable to Init Codec while loading file...

The way I fixed it was by changing:

self.playNextSong_delay from 0.5 to 1 in the file addons/script.audio.pandora/resources/lib/pandaplayer.py

My guessing is that the Raspberry Pi SD card I'm using is very slow and it takes a while for the system to release the previous file and be ready for the next one.

So guess if you play with the delay between songs until it works for you, it should solve your problem.

Maybe the Google Music addon has a similar parameter.

Otherwise, you can try buying a faster SD card, like a Class 10 SD Card, clone your configuration and give it another try.

Hey! This worked perfectly for me thanks so much! 
I don't think it has anything to do with your SD card or even the Raspberry. I am running Kodi on an Intel i5 PC under windows 10 with 8 G RAM and plenty of cacheable drive memory space and I am still having that same problem. I edited the python file as suggested and it still plays only one song and then stops.