Kodi Community Forum

Full Version: Video Resolution changes during playback
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
hey there

pretty confusing, couldnt find anything on the web.

Ubuntu 14.04
XBMC Gotham (from 13.0 to 13.1 RC1)

occassionally (at least once every 30min, sometimes twice), the video resolution seems to change during playback, to a lower one. everything gets bigger, video controls too & they move outside of the viewport. this goes on for a few seconds, then it automatically changes back to normal again.
I tried to narrow it down by determining if the video source was to blame - when i rewind back to the same scene in the source where this occured, I can reproduce it sometimes. other times its perfectly fine.
this also happens regularly when I pause a video, though, again, not every time.

Previously my setup (Intel i3-3225, HD4000 graphics) with Ubuntu 12.10 & Frodo was fine. I started with a fresh install of both 14.04 & Gotham and along came the issue.

Didn't modify anything specific, except for xorg.conf, enabling the TearFree Option, because since 14.04/Gotham, I had lots of video tearing (never had that with 12.10/Frodo either). Though this doesnt seem related to the problem, b/c disabling TearFree doesnt do anything for the resolution jumping.
after further investigation, the problem doesnt seem to be tied to XBMC. even while playing videos from the desktop with VLC, screen resolution jumps down & up again randomly.

Its driving me nuts, any idea? Sad
problem still persists.. Sad
Hey m33e pleas post the output of command xrandr
PHP Code:
Screen 0minimum 320 x 200current 1920 x 1080maximum 32767 x 32767
VGA1 disconnected 
(normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected primary 1920x1080+0+(normal left inverted right x axis y axis1280mm x 720mm
   1920x1080      60.0
*+   50.0     59.9     30.0     25.0     24.0     30.0     24.0  
   1920x1080i     60.1     50.0     60.0  
   1600x1200      60.0  
   1680x1050      59.9  
   1400x1050      59.9  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x800       59.9  
   1280x720       60.0     50.0     59.9  
   1440x576i      50.1  
   1024x768       60.0  
   1440x480i      60.1     60.1  
   800x600        60.3  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        60.0     59.9  
DP1 disconnected 
(normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis
Its not the TV switching overscan off and on for some reason is it?

Anyway look in /var/log/Xorg.0.log
I think i can rule out the TV.

here's my Xorg.0.log
Please don't post your logs direct into the forum. Use pastebin.

Where in that file does the resolution change?
(2014-06-17, 22:05)nickr Wrote: [ -> ]Where in that file does the resolution change?
i dont think there is a point in the logs where it did. it doesnt get updated when the resolution changes. also lately the issue is getting more and more frequent, it seems. which is odd...
I am out of ideas sorry.
thanks. nvm, i just started from scratch, did a clean install and threw away every configuration, and for now, it seems to have disappeared..