Kodi Community Forum

Full Version: Gotham, Lubuntu 12.04 and SPDIF
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
sorry for bothering about.
I just upgraded by HTPC to Lubuntu 12.04 and Gotham 13.0
I managed to fix almost all, but unfortunately I can only get Stereo audio via SPDIF.
I removed pulseaudio, and are using the same asoundrc as before, and it was fine with Frodo.

Here my logs
dmesg : http://paste.ubuntu.com/7538733/
xbmc.log : http://paste.ubuntu.com/7538736/
Xorg.log : http://paste.ubuntu.com/7538742/
vdaupinfo : http://paste.ubuntu.com/7538750/
mesa : http://paste.ubuntu.com/7538752/

Thanks,
Claudio
SPDIF can only do more than 2 channels, when it's doing AC3 or DTS - no asoundrc is involved.
You need to enable passthrough:
https://dl.dropboxusercontent.com/u/5572...hrough.png
(2014-05-28, 22:02)fritsch Wrote: [ -> ]SPDIF can only do more than 2 channels, when it's doing AC3 or DTS - no asoundrc is involved.
You need to enable passthrough:
https://dl.dropboxusercontent.com/u/5572...hrough.png

Hi Fritsch,
I did enable passthrough, as I felt like this was the reason, but unfortunately I still have only downmixed audio.
Any other idea?

Could have something to do with this?
http://www.freaktab.com/showthread.php?1...ham-Stable

Thanks.
After 125 posts you should have noticed that we prefer debug logs Smile
Well, yes I should have...
anyhow the problem happens if you select SPDIF as main output and as passthrough output.
You must select an analog output as main output, then you will be shown the possibility for loudspeaker to be 2.0, 2.1 etc
and you shall select 2.0 so that enabling passthrough will be transparent.
It's quite odd actually, I'd prefere a more stupid-proof menu (as I seem to be)

Thanks,
Claudio
No it's not.

spdif can only do 2.0 channel when use in the PCM way.

AC3 is send via those 2 channels but can be 5.1. So just select your Optical device in the pcm and in the passthrough section and all will be fine. Don't forget to enable the codecs your AVR supports.