Kodi Community Forum

Full Version: Symbolic Links on NAS Server are not recognized by XBMC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm using XBMC now for many years on many differnt platforms and I never had to post a question. I could always find an answer on the forum which finally worked for me. I searched the forum this time as well and couldn't find a real answer to my problem.

I'm using Openelec 4.0.3 on a Intel NUC 34010 box which runs very smooth. All the content (mainly movies) are on a QNAP NAS using NFS. I would prefer staying with NFS since it needs less CPU power on my other RPI clients and I can use a shared library

I do have the problem now that I have many recorded movies from Television which I put back than on DVD with a start Menu were you can select between both Movies. To safe space in the early days of DVD R I always put 2 Movies on one disk. I know copied all of those on my QNAP NAS. They still have the orignal file structure. Since there are quite a few I would like to avoid recoding them. I do have every movie in its own folder which has the name of the movie and the year in brackets e.g. Movie1 (2000)

The file structure is as following (basically still the orginal DVD structure) :

./Moviename (2000)/VIDEO_TS/Video_TS.bup
./Moviename (2000)/VIDEO_TS/Video_TS.ifo
./Moviename (2000)/VIDEO_TS/VTS_01_0.vob

I had now the idea to create symlinks pointing on the same directory to add the second movie on the disk also to the library.
I used: ln - s "Moviename (2000)" "Moviename2 (2001)" to create the symlink on the NAS. I did use relativ path that the NFS server is able to export them.

On Openelec/XBMC I added the directory containing the movies and ran the scraper over it. It did find all Movies which are physically there but it didn't scrap the symlinked ones. When I look through the files menu into the folder all symlinked Folders are displayed. When I right click on the symlinked folders I get a limited choice of options. I can play the Folder but I can't open the Movie information or let start the scraper manually on that folder.

I cross checked it on a different Linux machine not running XBMC:
I mounted the NFS share on a Ubuntu 12.04LTS machine and they showed up correctly. I can play the movies from it e.g. by using vlc.

Therefore it really seems to be a Problem with the combination XBMC / NFS server on NAS

1) I'm wondering what I'm doing wrong. -> Any suggestions?
2) If this is a systematic problem which cannot be solved easily -> Do you have an alternative suggestion on how to name or sort the folders in a way that both movies show up correctly in the Library (with TV shows it is quite easy but with standards movies I didn't find a way yet)

Thanks for your help
Thats a limitation of NFS. the symlink will resolve to a directory on the _client_, where this directory does not exist.

thanks for the quick reply. To my knowledge this is only true for absolute symilinks since those - as you pointed out - resolve into a non existing directory on the client.

For that reason I'm using relative links and actually those are browsable in the file section on the xbmc client (and on other Linux machines on the network). The files in the symlink folder even play fine with xbmc..

I just cannot add the symlink folder in the library -> basically the scraping option or movie Information is missing in the right click menu.

Any suggestions how to get a folder containing 2 Movies correctly with 2 entries in the database -> doesn't have to be a symlink though if you have a better idea -> anyhow I would prefer staying with NFS (rather than SMB)

I have exactly the same problem ! Same disk locally attached or accessed via Samba works fine but not if I use NFS !!!

As you also say I can reproduce the movies quite fine via the Videos -> Files and so the symlinks are resolved ok by NFS.

It really looks as if it's a scraper problem.

Could we share the export file on the server machine and the mount / stab stanza on the client ?

Take care
(2014-12-16, 18:58)rjalex Wrote: [ -> ]I have exactly the same problem ! Same disk locally attached or accessed via Samba works fine but not if I use NFS !!!

It really looks as if it's a scraper problem.

Did you ever figure out a fix for this?