Kodi Community Forum

Full Version: (Surface Pro) Side menu constantly popping out, finger scrolling disabled
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Running XBMC Gotham (Compiled 5/5/2014) official release on a Windows 8.1 Pro.

Problems did not exist in earlier Gotham Betas, but on last RCs and final.

Problem description (Sidebar):
No matter which area of the program you are in, the side menu pops out anytime you touch the screen on the left HALF (touching past the middle of the screen does not trigger this). I have attempted disabling the default on 'joystick support', have uninstalled, wiped and reinstalled XBMC, and have ensured that all windows drivers and firmware are up to date.

Problem replication:
On surface (or presumably other touch devices), Open (for sake of example)
Video -> Files -> <SHARENAME> and try to touch a folder name. Any touches on the left half of the screen will automatically register AND bring out the "Video options" sidebar. This is infinitely repeatable and makes browsing a painful experience.


Problem description (scrolling):
Frodo and Gotham betas both allowed for finger scrolling ("flick scrolling") once the user enabled the 'enable mouse and touch support' option in the settings. In the late RCs and final, this support has been either intentionally or accidentally disabled, and scrolling is now only possible using either a scroll wheel (and attached mouse/trackpad) or using touch by carefully touching the visual scrollbar on the file/media list, which acts exactly like a mouse and either (single touch) skips down a page or so (click and drag) moves the list down to the area you drag to. Note: I have tested and drivers are not an issue, version of XBMC does dictate whether this flick scrolling works.

Problem replication:
On surface (or presumably other touch devices), Open (for sake of example)
Video -> Files -> <SHARENAME> and assuming your folder list has an adequate number of files, try to scroll by flicking your finger in the file browsing area.

Has anyone else seen these symptoms on touch devices in the late RCs or final version of Gotham? Any suggestions on changes that can be made to the skin that would fix the side menu or re-enable flick scrolling?

I've used and loved XBMC for years now, and Gotham is excellent in that it reliably plays anything I throw at it, and it's matured so much since the xbox XBMP days. Many many thanks to all the devs that spend so much time making such an awesome program!
Identical situation for me, cant find a solution. Makes xbmc useless on it. Sad
Have the same problem on my Dell 18" touch screen. I ended up modifying the default Confluence skin to create a Kiosk mode which lets you disable the fly out sidebar.
Thats a great idea, care to share what you modified to disable it? also, of note, this issue didnt occur until the late gotham RC's, and the sidebar operated as it 'should have' prior to that, as in it would pop out normally when you touched it, but not when you touched everywhere else.

Has anyone tried a beta confluence skin with the latest version? I cant say I know anything on skinning, else I would try my hand at stitching together the sidebat code from the early betas to the final code.

Finally, has anyone on the skinning team been able to test this to see if it is indeed a bug or if it is a side effect of another design decision?

Thanks everyone for your replies so far, good to know it's not just an oddity on the surface pro.
Use the re-touched theme instead.
(2014-07-15, 04:47)diamond187 Wrote: [ -> ]Thats a great idea, care to share what you modified to disable it?

Navigate to where you have XBMC installed, typically under Program Files:
C:\Program Files (x86)\XBMC\addons\skin.confluence\720p

You need to edit some xml files with Notepad++ or something similar.

1. edit "SkinSettings.xml"

Add this code at around line 275. You'll see the sections, so fit this in between a similar section.

<control type="radiobutton" id="106">
<width>750</width>
<height>40</height>
<font>font13</font>
<label>Enable Kiosk Mode (disable slideout menu)</label>
<textcolor>grey2</textcolor>
<focusedcolor>white</focusedcolor>
<texturefocus>MenuItemFO.png</texturefocus>
<texturenofocus>MenuItemNF.png</texturenofocus>
<onclick>Skin.ToggleSetting(KioskMode)</onclick>
<selected>Skin.HasSetting(KioskMode)</selected>
</control>

2. edit "MyMusicNav.xml"

Add <visible>!Skin.HasSetting(KioskMode)</visible> at line 56 so it looks like below

<control type="group">
<visible>!Skin.HasSetting(KioskMode)</visible>
<left>-250</left>
<include>SideBladeLeft</include>

3. edit "MyMusicSongs.xml"

Add <visible>!Skin.HasSetting(KioskMode)</visible> at line 52 so it looks like below

<control type="group">
<visible>!Skin.HasSetting(KioskMode)</visible>
<left>-250</left>
<include>SideBladeLeft</include>

4. edit "MyVideoNav.xml"

Add <visible>!Skin.HasSetting(KioskMode)</visible> at line 52 so it looks like below

<control type="group">
<visible>!Skin.HasSetting(KioskMode)</visible>
<left>-250</left>
<include>SideBladeLeft</include>

5. Fire up XBMC, go to System, Settings, Appearance, Skin, -Settings, General Settings and check the radio button for "Enable Kiosk Mode (disable slideout menu)"

All done Big Grin
Can someone fix this ,really annoying, I don't want to use the kiosk, too complicate.
Same problem here... i dont want to use kiosk mode neither

tested last daily build, same problem
same on my Dell Venue 8 Pro, so I'm using Re-Touched.
I've got this problem on a Surface 3, except that it happens regardless of where I tap on the screen (aka not just tapping on the left half). Also, it doesn't only apply to Confluence - I've tried several other themes which behave the same. I change views frequently, so Kiosk mode isn't really a good solution (er, it isn't a solution at all - it's a workaround).

This problem has existed for half a year now, is there any hope that it'll be rectified beyond people just saying "use retouched?"
+1

win 8.1 bay trail tablet.

Helix.
Same issue with HP ElitePad!

THINK People are using More and More Touchscreen devices, so Kodi should be aligned this use-case...
Have you tried the fix in post #6?
This bug still appears in Kodi 15.0. Note that the proposed "fix" is merely a workaround.

After some testing, I believe the problem is caused by the coexistence of both mouse and touch input on Windows. Scrolling is smooth and works fine (without the side menu popping out) if no mouse cursor is displayed. The issue is that certain interactions cause the mouse cursor to be shown (e.g. tapping).
  • Dragging works well if no mouse cursor is displayed. Dragging will not cause the mouse cursor to be shown.
  • Dragging while the mouse cursor is displayed causes a mouse movement (and the sidebar to appear). It will also make the mouse cursor disappear afterwards.
  • Tapping works fine. However, tapping causes the mouse cursor to appear (therefore having the same effect as a click).

I think that the popping out of the side menu is caused by the mouse moving to the origin (that is (0,0) in two-dimensional space) by itself when switching from mouse to touch input.

Could anyone who owns a touchscreen device running Windows confirm my observations?

The easy solution to solve this problem is therefore not to treat tapping as clicking (and hence not to switch to mouse input). Kodi must not switch to mouse mode while touch input is used exclusively. By the way, this is already the behaviour of the operating system, as can be observed in web browsers. Additionally, switching from mouse to touch input should not cause the side menu to pop out (possibly requiring a smaller collision box).
problem also in kodi 15.1

Please solve this!
Pages: 1 2