Kodi Community Forum

Full Version: Apple TV 1 "Gotham" MAC Address/Connection Unstable
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Can someone please assist me? I'm requesting assistance in resolving a DNS issue with my Apple TV 1 running XBMC Gotham 13.0.

Platform: AppleTV 1
Launcher version: Gotham 13.0
Install Method: Thumb drive to HDD
Revision: XBMC 13.0 Git:20140505-a394e15

FULL Debug Log: http://pastebin.com/2KEGedNd#

I have an HDD installation of Crystalbuntu running on my ATV1 along with XBMC Gotham. Every time I reboot my ATV1 functions properly for about 5-10 minutes and then shuts down due to the lost of internet connectivity. When I go to System > System info > Network > it shows the following:

Link: Connected
MAC address: Busy
IP Address:
Subnet Mask:
Primary DNS:
Secondary DNS:
Internet: Busy (Not connected. Check network settings.)

If I let it sit for 20-30 minutes or either reboot it will reconnect, and again 5-10 minutes later shutdown. I initially did the direct ethernet connection setup and later moved to wireless. I have also downloaded Network Manager and I'm currently using it to connect wirelessly. Though I'm connected through Network Manager and have adjusted the setting to read DNS Server, System info still shows a DNS of I have also tried a direct ethernet connection and I still get the same result, so it's not just the wireless connection at this point. I've already tried a fresh install, as-well-as ssh in and download the script.linux.nm fix from ( https://github.com/vikjon0/script.linux.nm/downloads ). I'm out of ideas at this point and was hoping someone has a fix that will work. Of interest, Network Manager located in the XBMC.org repository shows it's incompatible, so I went through the SuperRepo repository to install it and gain access through Programs from the Home Screen. Although I have access through the home screen and connect wirelessly through it, the one under XBMC.org still show incompatible. Any ideas?
Have you tried giving the ATV1 a static IP and DNS entries via the GUI? (System - OPENElec). If you are using DHCP, the DNS entries come from DHCP server and your entry has DNS set up for localhost so will not work. I have two ATV1 and both are working great with Gotham (except for some Live HD TV issues).

I am experiencing a similar problem with Gotham on my ATV1.

Don't know how to do a debug log, but mine shuts down to the black Linux screen and reads (at the bottom) "4.510310] init: ureadahead main process (790) terminated with status 5 / [5.175242] EXT4-fs (sda2): re-mounted. Opts: (null).

I can reboot the system (by manually unplugging), and it starts back up fine, but when I am navigating the menus, it randomly returns to the Linus screen and does not start up again.

Any help, or direction on how to post a debug log would be appreciated.

Gyrogypsy, how do I go about giving the ATV1 a static IP address and DNS entries?
Sorry to post again, but I wanted to post that the problem only occurs when there is an internet connection.

When I unplug my ethernet cable and turn on my ATV, I can navigate the XBMC menus.
The problem fixed itself somehow. I tried again hours later.