Kodi Community Forum

Full Version: Getting DTS-HD Master and Dolby True HD to work on XBMCbuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

I am experiencing a problem regarding my HTPC setup. I can't my get my installation of XBMCbuntu to passtrough DTS-HD Master or Dolby True HD.

I am new to Linux, except some previous experience with Ubuntu.

The reason why I am trying to get help is beacause I've tried to install XBMC with Ubuntu and I couldn't get the passtrough to work either. So I tried to install the version of XBMCbuntu.

I am running a custom made HTPC only dedicated to XBMC.
This is connected with HDMI from HTPC to AVR (Harman Kardon AVR255) and with HDMI from the output to the TV.
My current HTPC is running:

The latest XBMCbuntu img. from (www.xbmc.org) (I have updated with terminal to version 13.1 release 6 june)
Motherboard: http://www.gigabyte.com/products/product...id=3978#ov
CPU: IntelĀ® Core i5-3450 Processor (Intel HD 2500 graphics)

I have been looking around to try to solve this problem on my own and I found this guide from the wikipages:

Im not sure if I got this right. Do I have to download the files manually first from 1.1? Or can I just download them directly like shown in the 1.2?
After doing what 1.2 told me, I rebooted and I still could'nt enable the DTS-HD master and Dolby True HD from the audio settings in XBMC.

If you need anything else besides the information above, please ask me and I will try to provide it.

Thanks in advance.
xbmcbuntu v13 does not need a single change to anything from that page, in contrary it harms!

xbmcbuntu comes with a 3.13 kernel which is far newer than anything mentioned on that page.

Don't change your alsa config - it will break complete audio. This has long been fixed.

Edit: I updated the wiki to make that clear.
After that post your Debug Log that will show the enumeration.
Do you want me to post a debugfile running a file that contains the format Im not getting?

Thank you for quick response

P.S can I roll back the previous kernel update?
just any debug log, does not matter ... the 3.10 kernel is lower than trusty default kernel so it does not matter. If you want to make 100% sure, that nothing is fucked up - just reinstall it.
Quote:22:52:05 T:140681772120000 NOTICE: Device 4
22:52:05 T:140681772120000 NOTICE: m_deviceName : hdmi:CARD=PCH,DEV=0
22:52:05 T:140681772120000 NOTICE: m_displayName : HDA Intel PCH
22:52:05 T:140681772120000 NOTICE: m_displayNameExtra: HCG *Harman_AVR* on HDMI
22:52:05 T:140681772120000 NOTICE: m_deviceType : AE_DEVTYPE_HDMI
22:52:05 T:140681772120000 NOTICE: m_channels : FL,FR,LFE,FC,BL,BR,SL,SR
22:52:05 T:140681772120000 NOTICE: m_sampleRates : 32000,44100,48000,88200,96000

All there with all the formats you need, but(!) one is missing. Your AVR lies about not being able to do 192 khz(!)

Without that 192 khz we cannot open DTS-HD nor TrueHD. That's a bug in your AVR, you can try to workaround it, by pushing the correct value to the relevant /proc/asound/cardX - therefore google: alsa sad5_rates

when that is fixed, xbmc only needs to restart and will pick up the 192 khz

If you AVR is attached to the first port
sudo echo sad5_rates 0xc0  > /proc/asound/card0/eld#0.1

then restart xbmc

should workaround that
It says no such file or directory?

Am I doing something wrong?

When Im browsing trough the folder I can see a file named eld#3.0
Quote:If your AVR is attached to the first port

Pastebin all eld files you find within card0, card1, cardX
I only got one folder wich is card0 inside is the version of eld#3.0

I cant open the file to view the content of it, is that normal?

Tried to open XBMC now, and going trough the sound options I can now enable TrueHD and DTS-HD with passtrough, but I dont get any sound...
Post the logfiles, including the eld file as requested.

Here is the logfile

Could you help me with how to post the eld file? I can't figure how to open it to view the content of it.
[email protected]:/proc/asound/card0$ ls -l
insgesamt 0
-r--r--r-- 1 root root 0 Jun 13 23:42 codec#0
-rw-r--r-- 1 root root 0 Jun 13 23:42 eld#0.0
-rw-r--r-- 1 root root 0 Jun 13 23:42 eld#0.1
-rw-r--r-- 1 root root 0 Jun 13 23:42 eld#0.2
-r--r--r-- 1 root root 0 Jun 13 23:42 id
dr-xr-xr-x 3 root root 0 Jun 13 23:42 pcm3p
dr-xr-xr-x 3 root root 0 Jun 13 23:42 pcm7p
dr-xr-xr-x 3 root root 0 Jun 13 23:42 pcm8p

What's in yours?
[email protected]:/proc/asound/card0$ ls -l
total 0
-r--r--r-- 1 root root 0 Jun 14 00:15 codec#2
-r--r--r-- 1 root root 0 Jun 14 00:15 codec#3
-rw-r--r-- 1 root root 0 Jun 14 00:15 eld#3.0
-r--r--r-- 1 root root 0 Jun 14 00:15 id
dr-xr-xr-x 3 root root 0 Jun 14 00:15 pcm0c
dr-xr-xr-x 3 root root 0 Jun 14 00:15 pcm0p
dr-xr-xr-x 3 root root 0 Jun 14 00:15 pcm1p
dr-xr-xr-x 4 root root 0 Jun 14 00:15 pcm2c
dr-xr-xr-x 3 root root 0 Jun 14 00:15 pcm3p
cat /proc/asound/card0/eld#3.0 | pastebinit
Pages: 1 2