Kodi Community Forum

Full Version: airplay under 13.1 does not work any more
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
After the 13.1 update, I am no longer able to use the youtube app on an iphone or ipad to airplay content to xbmc. When I try, nothing happens on the xbmc screen.
The Linux box has the dependencies installed and avahi-daemon is running. Airplay with 13.0 worked fine with the same setup. Any advice is appreciated.

I have debugging enabled in this log file: http://pastebin.com/Py1xwL0F
In case someone happens on this thread, here is the official word from the xbmc dev team pasted from the bug report I referenced above:
Quote:This is not the update from 13.0 to 13.1 which causes it. Its the update to the latest youtube app. Google b0rked it for us and there is no solution. They introduced some unknown URL scheme (mlhls) which points to "localhost". There is no way for us to play those streams.

Just FYI - i tried the current youtube app with an original AppleTV2 running iOS 4.3 (iOS 4.x is the base for our implementation of airplay - all later versions of iOS do encryption which can't be reverse engineered). Long story short - youtube app doesn't work with AppleTV2 on iOS4.3 either.

No way to fix it. Try a different thirdparty youtube app (some mentioned that using youtube.com from the safari browser on ios works too).