Kodi Community Forum

Full Version: Musicbrainz Picard Tagging Issues.... Solved Finally?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hey yall,

I know there have been a lot of people confused about how *perfectly* tagged files from Picard are not showing up correctly in XBMC. After recently trying to solve an issue with a fellow member on the boards here, I've finally figured out at least 1 major issue that could be the source of your frustration.

First here are my settings in XBMC:
Image

Here WERE my tag settings from Picard:
Image

And this was the result in XBMC with an MP3 album that had featuring artists.
Image

I'm sure a lot of you have been dealing with that...... arghhhh!

After messing around a bit, I changed my Picard settings to the following (change the ID3v2 version to 2.4).Image

And here is the result in XBMC:
Image

Well I'll be damned.......

(post continued below due to image limit)

So why is this happening? Lets fire up MP3Tag to see the differences on one of the tracks with a featuring artist,

Here is the output from my old Picard settings:
Image

Notice how the "MUSICBRAINZ ARTIST ID" has the artist id's separated with a "/". Even if you manually change it to a " / " (space / space) XBMC will not scrape this correctly, nor will it scrape correctly if you change the "Artist" tag to "112 / Mase".

Now lets have a look at the tags of the ID3v2 2.4 tags:
Image

Now notice how the "MUSICBRAINZ ARTIST ID" are on seperate lines....... BINGO. That's the key.

Here is the XBMC output:
Image

Thank goodness!

In conclusion:
Picard inherently tags ID3v2 2.3 tags in a format that is incompatible with XBMC as it stands right now.
I'm not that surprised. ID3 2.3 is kind of brain dead when it comes to multiple entries in tag fields (frames). The spec only provides for multiple entries in artist and composer, and that is "/". Tag software use their own conventions when adding multiple entries in other fields. 2.4 uses a null as separator in any field, so much more flexible. For this reason I had added APE2 tags on all my mp3 files which doesn't have this limitation.

You might need to look at the file with a hex editor to see what Piccard is actually putting the file (I think it should be something like TXXX=musicbrainz artist id) at least for 2.3 tags. I think if you are in mp3tag you need to use \\ as the separator for mp3tag to treat it as a multi-value field.

scott s.
.
Confirmed working. Thanks helta
helta - great post - everything makes sense (I only have 2 albums out of about 1500 that were bugging me) - this is exactly the way forward
+1
Work so great thx you for sharing !!!!!
I'll make a chance so that Picard's tags are read anyway - it's pretty obvious what it's supposed to be.
Having a hard time with a few things. Live Dj sets in particular. Tried manually setting musicbrainz artist id and no go. Shows up under various artists.
5015 (PR)
Thank you @jmarshall. That will clear up a lot of frustration with the music library.
I suspect if we really want that, a setting just to turn off MBIDs completely may be appropriate Wink
Never! MBID's are the best thing since sliced bread.
That's not solving all the Problems. I converted my whole library to 2.4, but still getting more then one artist entry for one album (feat. xyz etc). Sometimes there are two absolutley identical artist entrys with the same albums inside. If i check the "do not display artist in compilations", some "real" artists are missing from the list. (Like I have one johnny cash "best of" album. without the option checked, i get johnny cash as an artist and 20 others, cash feat xyz. Checking the option everything is dissapearing, eaven Johnny Cash itselve...) But other "feat" entrys will stay on the list when checking the option.

I'm going bananas here, my library was so perfect tagged, everything is messy now.

Another main Problem is with an Album like this
https://musicbrainz.org/release-group/e9...96998679c7

there are two "Album Artists", but xbmc won't display them as "Billie Joe" and another one as "Norah", but I get two identical "Billie Joe + Norah" entrys... I have that several times
So I just tried your Billie Joe + Norah album and my results are:

Image

Make sure you have "Override song tags with online information" checked.

Also, do your Picard settings match mine in the first post (the 2.4 one)? Mainly "Clear existing tags" and "Remove ID3 Tags from Flac Files" and "Remove APEv2 from MP3 files"?
Thanks for trying that! I checked the setting to override Title Information, but I didn't delete the Database and rescanned. Now everything is exactly as it should be!

-> Load the whole Database in Picard
-> Options exactly as in the first Post
-> Write everything (Takes Time... ^^)

-> Delete Database
-> Setting "Override Title Information from Internet" in Music options set
-> Setting "show Artists only in compilation" not set
-> Rescan whole Library

-> Problem solved Smile
(2014-07-12, 23:48)jmarshall Wrote: [ -> ]5015 (PR)

(2014-07-13, 03:28)helta Wrote: [ -> ]Thank you @jmarshall. That will clear up a lot of frustration with the music library.

Nice find helta... Is it being added to Gotham or Helix only?
Pages: 1 2 3