Kodi Community Forum

Full Version: Linux What version of java is needed?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
When I run this
I get
java -Djava.net.preferIPv4Stack=true -jar getdown.jar .

Now this is a new install with Debian Jessie OS. I am sure I am missing a package but I have no idea which one(s)
Take openjdk 7 - this should be fine..
Have this installed
And it does not work
So which of these 5 that are available would be the right choice


You need openjdk-7-jre in addition to the headless package
Was already installed
Any other ideas?
you misunderstood me:

openjdk-7-jre-headless is only the core for java (for apps without any UI).
To use java apps with UI (like tmm) you need also openjdk-7-jre
# apt-cache policy openjdk-7-jre
Installed: 7u60-2.5.0-2
Candidate: 7u60-2.5.0-2
# apt-cache policy openjdk-7-jre-headless
Installed: 7u60-2.5.0-2
Candidate: 7u60-2.5.0-2
this the result
java -Djava.net.preferIPv4Stack=true -jar getdown.jar .
how do you start the shellscript?

via console or via file manager? you may probably add the executeable bit to the script and/or start it with a terminal emulator (be sure you cd to the tmm dir before executing the script)
I know nautilus does not start executeable shellscripts... this may be your problem
Konsole I get
:~/tmm_2.5.5_full_linux$ /home/geo/tmm_2.5.5_full_linux/tinyMediaManager.sh
bash: /home/geo/tmm_2.5.5_full_linux/tinyMediaManager.sh: Permission denied

Yet owner and user groups are owned by user

/home/geo/tmm_2.5.5_full_linux/tinyMediaManager.sh is done by KDE and Dolphin

This is a new install of Debian sid/testing. On my last install I had no difficulty over the last year. So I am assuming something has changed. On both installations TMM was in the home directory.
Permissions originally 100644
And then I changed this to 100777
and all is fine.
I do not recall this issue at the first install so whatever program (ark I think) extracted the file gives my wonky permissions
Sorry for the noise

Is there a solved button somewhere?
no problem Wink

linux and the permissions is sometimes tricky (and some file managers suppress executing of shellscripts too like nautilus..)

I will mark the thread as solved. have a nice weekend
Hi everyone.

I'm a well experienced Linux user, running Gentoo on the desktop and I have the following Javas installed:

% java-config -L  
The following VMs are available for generation-2:
*)    IcedTea JDK [icedtea-6]
2)    IcedTea JDK [icedtea-7]
3)    IcedTea JDK [icedtea-bin-6]
4)    IcedTea JDK [icedtea-bin-7]
5)    Oracle JDK [oracle-jdk-bin-1.7]
6)    Oracle JDK [oracle-jdk-bin-1.8]
7)    Oracle JRE [oracle-jre-bin-1.7]
8)    Oracle JRE [oracle-jre-bin-1.8]
9)    Sun JDK [sun-jdk-1.6]
10)    Sun JRE [sun-jre-bin-1.6]

Yeah, quite a lot, I know.

I have tested tmm (2.5 and today 2.6) with all of these, but, while they all do show the splash when starting up, only with number 1 and 3, i.e. icedtea-6 and icedtea-bin-6, do I get a working UI. With all other versions, after TMM has started up, I get nothing more than a gray square without any UI.

So in other words, for me, TMM only works with icedtea-6 and icedtea-bin-6.

If I can help debug, please let me know. I'd like to get rid of icedtea-6 in favor of a more recent version.

Thank you! Nod
I am using Linux myself for ages now (Manjaro/Arch Linux) and got tmm working with openjdk6/7 and oracle jre 8.. So it should run with 5/6/7/8...

could you have a look if any log is written to the tmm/logs directory? (tmm.log) - maybe there is a hint
(2014-09-06, 16:20)mlaggner Wrote: [ -> ]could you have a look if any log is written to the tmm/logs directory? (tmm.log) - maybe there is a hint

Perhaps this one (the only useful line I can find):

WARN  [main] org.tinymediamanager.ui.TmmUIHelper:61 - cannot open init filedialogorg.eclipse.swt.widgets.FileDialog

Is this a local issue on my side?

*edit* FOUND a solution!!

See: http://forum.kodi.tv/showthread.php?tid=...pid2005121
this only indicates, that tmm was unable to load the optional swt.jar (http://www.tinymediamanager.org/index.ph...er-dialog/)

are there any logs after that point?
None, I'm afraid, unless there is a debugging option I have missed..
Pages: 1 2