Kodi Community Forum

Full Version: TIDAL music (former WiMP)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
Hi, I'm trying to login to tidal in kodi (windows) and it's shows an error.
http://pastebin.com/R4igdLiM
it works great on kodi for android and also on kodi for mint(ubuntu).
there is a solution for it?
I tried both versions:
1. from kodi repo - does not log in.
2. from github - shows an error.
The TIDAL music addon topped working almost entirely for me about a week ago.

About 9 out of 10 tracks that I play fail with an error message similar to the following:

20:53:57 T:140281730471680 NOTICE: -->Python Interpreter Initialized<--
20:53:58 T:140281696900864 NOTICE: Thread GUIDialogCache start, auto delete: true
20:53:58 T:140284853602240 NOTICE: DVDPlayer: Opening: http://audio-pop.tidal.com/5598982/20150...cf6adcbe1e
20:53:58 T:140284853602240 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
20:53:58 T:140281696900864 NOTICE: Thread DVDPlayer start, auto delete: false
20:53:58 T:140281696900864 NOTICE: Creating InputStream
20:53:58 T:140281696900864 NOTICE: Creating Demuxer
20:53:58 T:140281730471680 NOTICE: Thread FileCache start, auto delete: false
20:53:59 T:140281696900864 ERROR: Open - error probing input format, http://audio-pop.tidal.com/5598982/20150...cf6adcbe1e
20:53:59 T:140281696900864 ERROR: OpenDemuxStream - Error creating demuxer


Anybody have a clue what could be going wrong here? Are others experiencing this as well? It might be a clue that it all stopped working right after a brief ( ~1 day ) complete Tidal outage, during which I was unable to play Tidal from any interface. Everything else resumed working but the addon never did.
Is the Tidal add on currently working?

Edit: Should have tried a little longer. Everything seems to be working as it should. Only hifi option won't stream. Is that still the case? No progress on this front? I would have really liked to have used this but that is a total deal breaker. Pretty much the whole reason to have tidal, no?
When searching for an artist, I no longer get a list of albums. Anyone else ?
Hello fellow kodi and tidal users.

I've been using kodi for a while now and just today started with tidal addon. From the level of kodi app, tidal addon works just fine -play whatever playlists i got there. This however does not meet my full expectations because the interface of tidal in kodi is very limited. Now i was hoping to use it in a different manner but unfortunatelly I cannot get it to work. I use samsung android based phone with tidal app installed and my kodi is on a Qnap NAS with hdstation attached to my home theater. My idea was to browse tidal app on samsung and play whatever browsed music by "share" option given by yatse which is also there on my mobile. Now when i do this, I can see on kodi the icon that processing has been initiated but it does not proceed to playback. Any ideas?

Cheers
Marcin
Same problem here. No list of albums of songs. Too bad this add-on is pretty useless this way. Hope it can be fixed soon because playback with the new AEON MX 6 Kodi skin is spectacular
Hello,

What is, if any, the progress on lossless streaming? Would love to be able to use all in one solution, instead of having separete box just for lossless, or having to airplay all the time....
Please, please bring lossless to Tidal addon.
The browsing actually works pretty well for me. I've been going to the search> albums. Then search for the artists name. Gives me a list of albums and when I go into one, the tracks are all there.

The lossless option is all that I'd like to see. It's been very helpful on any pi setups I have. Nice to be able to listen to stuff I don't have locally with ease.
Don't ask me how I know this, but if you change the token to that of an Android phone or emulator, the HiFi streaming should work.
Real-ll-ly?
The 1.2.2 update from sunday uses an android token. Did you guys try if it works?
I just tried the 1.2.2 and, so far, I haven't had any luck with lossless. Even tried erasing the add on data. It always says item failed to play. Any other ideas?
Haven't had time to try the plugin, but it may require some changes to the code. I haven't had very much time to read it, but what I do know is that

Code:
GET https://api.tidalhifi.com/v1/tracks/<TrackID>/streamUrl?soundQuality=LOSSLESS&sessionId=<SessionID>&countryCode=US

returns

Code:
{
    "url": "<DirectURL>",
    "trackId": <TrackID>,
    "playTimeLeftInMinutes": -1,
    "soundQuality": "LOSSLESS",
    "encryptionKey": ""
}

If a <SessionID> from a token from a PC or the web interface is used, the <DirectURL> points to a .bin file and encryptionKey contains an encryption key. If a <SessionID> from a token from an Android device is used, the <DirectURL> points to a FLAC file, and the encryptionKey is empty.
I'm experiencing the same problem as well with the latest version of this addon (1.2.2). Selecting high quality plays the stream without any problem, when I switch to lossless I get playback errors each time.
In the Kodi logfiles I see; "Error creating demuxer" etc.

In the github code I see another token is used for lossless streaming now, but this doesn't seem to resolve the issue (at least not for me).

Hope you guys can fix this. The whole point of streaming with Tidal is to have FLAC quality.
When I view "my favourite albums", they are sorted by date, and the sort by option is greyed out - is it possible to sort by artist? If so, how? If not, can this be added as a feature request please?

The only other "cool" capability I can think of would be to have the "favourite albums" appear in the normal music library.

Love the plugin, tks.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45